Setup weirdness

I set up my othernet receiver today from the one spot in my yard that has a relatively clear view of the horizon. It worked at first, but after a while the RSSI and SNR and % valid packets started dropping. Mind you, there was no local bad weather, clouds, or wind. The LNB was mounted to a tripod and wasn’t moving.

I was using KenBarbi’s latest setup PDF, which appears to have just been uploaded today (the PDF says 3/12/2021 2:36PM): https://davs.org/DreamcatcherV3.05.pdf

I am apparently at a disadvantage, setting up the receiver during the lower bandwidth time. However, when I first pointed the LNB, I got lock right away, with -10dB SNR and RSSI around -70. The Dreamcatcher downloaded about a dozen current news stories and I was excited.

However, over time, it seems to drift and lost lock, and the RSSI and SNR would dwindle down to worse numbers. I was doing this in the early evening and the temperature and sunlight were not changing all that much. There was no wind and there are no leaves on the trees, and there was nothing moving in front of my LNB (trucks, people, etc).

I saw that recently, the channel bandwidth has been reduced. The setup document now says you (may?) have to start changing the frequency. I was surprised then when I didn’t change anything and started to get really good reception right away. But a few minutes later, I lost lock and the numbers got worse. I tried changing the frequency by 5khz as recommended (starting from 12.0894 and adding .00005 at a time; for example 12.08945, 12.08950, 12.08955, etc). The results didn’t seem to converge at all; I went from 12.08945 to 12.08970 and the results didn’t seem to trend towards better or worse, they just randomly changed throughout the test. I would wait a minute or two after each change and watch the Lock, RSSI, SNR, and % valid packets received. Sometimes I would get higher values, sometimes it would go lower, and sometimes it would seem to ‘peg the meter’ at the worst values (-40SNR, -160dBm RSSI) but there was no rhyme or reason to it.

  1. should I try going down from 12.0894 in 5hz steps too? The setup document only mentions going up

  2. Should I try the autotune script? I downloaded it and will see if I can get it to run later

  3. Which LNB do I have? It’s the one shown on the product page ( https://othernet.is/products/dreamcatcher-circuit-board ) with the red radome that has two F-connectors (one red and one green). What is this Maverick LNB I keep reading about??). I assume this is correctly set up as a Dual LNB in Skylark, but I am not sure.

It sounds as though you are doing everything right. That LNB is the Othernet Bullseye, and the best one you can have for this project. Be sure you are connected to the green coded connector. Bullseye is very stable (±10 Khz) compared to anything we have used previously. I haven’t seen the autotune script yet, however, it may work for you. You can try moving down in frequency, same as you went up. First, I would reset the Dreamcatcher to 12.0894, then reboot. Occasionally something strange occurs and after a lot of ups and downs, it gets a little rocky. You won’t see anything on the status screen until you are receiving (I think you have experienced this already). Once you get a good signal, (lock=yes, SNR is -12 or better) you can work it up or down in smaller increments than 5Khz, which I would do if I were using a Bullseye. At that point, watch the SNR figures, your best indication. The less negative the number, the better. Along with that, be sure to pay attention to the skew adjustment, it is critical with this signal.
The Maverick was issued with Dreamcatcher 3.02Q, one of the first units we were using on the KU band. It has a stability of ± 1Mhz. With the Dual LO Single LNB, issued with Dreamcatcher 3.05, the stability is ± 200 Khz. With Bullseye, it is ± 10 Khz.

2 Likes

Those were actually 50 khz steps. But if it was locked on, then something changed while sitting there. Do you have a stable voltage source?

1 Like

That is correct, 50 Khz steps as he wrote. I agree that it could have to do with a too-small diameter cable connecting the power to the Dreamcatcher, or a source that goes below 5.0 volts. It has been recommended to use at least an Official Raspberry Pi power supply or equivalent, we have found these to work well and sustain the output as they age.

1 Like

Hi folks!

Just to clarify;
-It does seem that I was jumping by 50khz, I will try 5 khz tomorrow during the day (.000005; ie 12.0894505, 12.089451, 12.0894515…)
-I had no extension cable between the LNB and the Dreamcatcher, just the very short (~5") cable that comes attached to the Dreamcatcher board. I screwed it right into the LNB and ziptied it to the tripod head
-I was connected to the green F-connector on the LNB (not the red 10khz output)
-I was powering the Dreamcatcher from a USB battery pack which can supply >2A. The one thing that remained constant through the experiment was that the Log Viewer said “Bias-T Voltage Normal” and “LNB Detected, Normal Current Flow: 0x23”

Thanks for the quick tips and comments!!

I’m going to clarify that in the User’s Guide. That 5 kHz increment in GHz is .000005 as you say. Ken

2 Likes

Just a note to be clear on my above comment following @Mr_B’s post, it was in reference to the 5v power cable between the power source and the Dreamcatcher. Many of us had trouble because the cable was not capable of carrying enough current to the board, in spite of the power source being fully capable to supply sufficient current. That is why Ken specified a “sync/charging cable” in his guide, as these have larger conductors than the commonly found USB-A to micro-USB cables. The coaxial cable can be pretty much as long as you want, some have used up to 500 feet with no problem.

1 Like

Ah ha! I missed that you were specifically talking about the power cable. I believe it is a good quality cable with reasonable current carrying capacity, but I have others I can try. However I just set this up again this morning and am having much better results, but I don’t know why.

I didn’t change the frequency at all. Like last time, it started receiving right away even though I left it on the 12089.4 frequency. It has been running for over an hour now, and is getting a solid 98% valid packets, with about -12DB SNR (it varies) and -84 RSSI.

I attempted to run the autotune script but I must be doing something wrong. I copied the .html file onto the micro SD card and can see it in the file manager (at home:////…/…/boot) when I connect to the Dreamcatcher. When I try to open it, I just get a 404 File not found error…?

In the limited experimentation I’ve done so far between yesterday and today, I have only seen data/files in the stream. Is there a certain time of day when radio/audio files are sent down? Or has that been deprecated now with the reduced channel bandwidth?

Also I have never received any Weather data. When I open the weather app, it says “no data”. It lets me spin the globe around but no information is shown.

I just double-clicked the autotune/ app to open it. It would likely be better in a Downloads directory. @Tysonpower (Manuel) is a bit ahead of @kenbarbi with the new releases of these apps, so it will take a little while for Ken to catch up his user guide, as the app will have to be exercised a bit in order to learn the ins and outs of operating it.
It is possible that the weather feed isn’t currently connected just yet. When things begin to smooth out, @Syed will get a better carousel running for us. Right now, he has his hands pretty full. I don’t know about the audio just yet, again, Syed has only connected the basic feeds back onto the satellite, so some of the selections may simply be devoid of packets (radio, weather) at the moment. Sorry that I have no better answers, but we will be getting better, as I said, it is a long road back to full functionality when the feed equipment has all been revised and replaced, so please bear with us here.

1 Like

Thanks, understood about the radio and weather (though I’d like to get confirmation that they are not being transmitted to ensure I am not doing anything incorrectly).

I put the microSD card in my computer, there are no subdirectories, and only 5 files:

boot.scr
sklylark-dc-2003041129.ksop
sun5i-a13-dreamcatcher.dtb
zimage
…and I put the DC3_freq_finder_1.04.html here as well, it shows up in the file list.

How do I get it into a download directory? Or am I supposed to wait for it to come down from the satellite feed and populate into the download directory by itself (?)

@Syed
I don’t recall how the original Downloads directory came into being, although you can right click on Home and create one: