Skylark 4.4 Network setup?

Now that Skylark 4.4 is flashed and working fine as a hotspot, time to try breaking it. In the past, I tried to set up the network connection for reporting, but I always got locked out. If you boot the C.H.I.P. outside wifi coverage, does it time out and revert to hotspot coverage as did the old Librarian version? Also, is the network locked to the channel specified in the hotspot configuration, or does it scan? Finally, I find that operating in hotspot mode, I pretty much need to be withing 15 feet or so to connect. Since my router, 25 feet away through two wood walls has much better reception, is this likely to help, or am I wasting my time.

I would connect it to your router. I didn’t have the network issues this time around. I got an error message after clicking apply and reboot, but it is just saying you lost contact with your chip, its fine let it reboot. You also have the config reset option now.

Yes - partly. It takes about three minutes. Though it doesn’t reboot automatically to switch to AP mode right now (bug). So if you switch to STA mode, are locked out, let it remain booted for 4-5 minutes, and then reboot it (power cycle). It should have switched back to AP mode. But let me know how it goes.

In AP mode, the channel is locked to the one you select - doesn’t scan automatically. We tried scanning, but the driver has issues.

Yes, AP mode has known signal strength issues.

Thanks. I just saw the instructions for the configuration wipe procedure, which should get me out of trouble. Will give it a try later.

Flashed per the letter of the instruction with no issues. I can confirm that my wifi network mode appears to (continue to) be working well in my set up, Router is some 35 feet away though several walls and a floor down. RSSI is -68, which by comparison is about the same as a iphone’s wifi at the same distance.

Thanks to patient answers here, I now have my system working with the house wifi. Much more convenient to access. Thanks all!