Skylark 5.1 for Dreamcatcher 3


#1

Skylark 5.1 for Dreamcatcher 3 (Ku-band) is up on archive.

Main fixes and features:

  1. The Log Viewer app now shows LNB Status.

  2. The Reader app is fixed and now can be used to view pdfs, epub ebooks, Opendocument docs/presentations/sheets (like the ones made using LibreOffice), html, markdown and many audio and video formats (mostly the ones natively supported by your browser).

  3. Copy-to-external feature now supports using both USB-sticks and SD-cards (in the SD2 slot). There was also a bugfix related to failed file-syncs when there was a large number of files to copy. The Status LED (LED10) now flashes while copy-to-external is working.

  4. Support for the new Outernet Audio service (more about this separately).

  5. Other bugfixes, some tuner app changes.

It is safe to burn this release over a Skylark 5.0 sdcard. There is no need to format the card first if it was already burned with 5.0 earlier.


Dreamcatcher v3.02: Feedback Thread
#2

#3

#4

Used 7 zip to un-gz the image, then w32DiskImager to write the image.
The DC booted up nicely, noted that it remembered the client Network settings from the previous
installed so everything worked.
This surprised me that it did not return to the default network setting of Hotspot
after re-imaging the OS. I guess this means that to get back to hotspot mode will only
happen if the sd card is formatted/cleaned.


#5

yeah, or put a “reformat_conf” tag file on the sdcard and boot from it…or if everything is working fine but you just want to switch back to AP mode, you can do that from the UI


#6

All the changes you made work beautiful, however, now my Dreamcatcher only works about 5 minutes before it fails when connected to my 500 foot cable run to my FTA LNB/dish assembly. Bias-T voltage is running 12.9 vdc as measured with a voltmeter, and the new LNB status tab reflects the new failure mode:

I presume I can reburn the old image for Skylark 5.0 until you figure out a solution to the new problem? Ken


#7

I re wrote the sd card with the Skylark 5.1 image, and started over. Seems to be ok now. Ken


#8

looks like i had a bad flash time to reformat and remove all partitions and try again lucky me i have a linux pc with gparted on hand… Edit Dang it kept its data after i quick formated and reimaged it…


#9

Reader App

Just a quick note on how the new Skylark 5.1 Reader App handles Rachel files - -

1

The HTML files all open OK, but because of the “drill down” structure of the Rachel HTML data base, the Reader App can’t render subsequent HTML files. To really make Rachel work, you still have to “Download to computer”

1

Which brings up a usable product. Ken


#10

I am trying to determine the best way to track the loading of files on the op sys sd card.

Really so I can know if it is getting too full. the log viewer of the system status is the only thing
I have found… Is there some warning message built in to give me advance notice that
something needs to be upgraded ?


#11

@kenbarbi, isn’t 500 feet a pretty far stretch with a direct current (DC) voltage of very limited current over a predominantly steel center-conductor (Most RG-6Q uses a steel center conductor with copper plating)? The “surface effect” would take care of the 3G testing very well, but whether there is sufficient copper to give efficient conduction of the bias voltage may be in question here.


#12

I have measured it - - 500 feet. It’s the feed from my outside FTA Quad Polar Invacom QPH-031 LNB/80 cm Dish. I share the feed with my FTA tuner with an F-Connector AB switch. In the FTA position my Dreamcatcher sees no antenna. So I can move my antenna to whatever satellite I need to see with my FTA tuner. In the Dreamcatcher position, only the Dreamcatcher is connected.

I was very surprised to be able to do this, but has worked fine since day one. My Rssi (dBm) is much lower (-104) than what I get when I set up next to the dish (-75 usually), but my SNRs are always very low. The cable shields the signal and just drops signal level - - Ken

2018-03-31 11_31_01-Anne Arundel County Public Library _ Educate, Enrich, Inspire _ Anne Arundel Cou


#13

Thanks for that reply, @kenbarbi, I wondered what the bias voltage might look like at the LNBF end of the cable, but then if you are using a similar of the same unit, I guess that is moot. I was about to suggest an animal gnaw or loose F connector, but if it is working for the FTA unit, my next guess would be check the continuity of that coax switch itself. I have used these, and know that sometimes they can fail also. Just my $.02. M.


#14

I’ll measure it later today and report back. Ken


#15

Just wondering if someone had advice on that satellite status window? I received my Dreamcatcher today and have been setting it up, all appeared fine, and I started to receive content. Now when I try to view the satellite status, it’s blank and I get the scrolling icon at the top of the screen. I have tried another image on a new sd card and I am getting the same. The log shows the LNB working, I just can’t view the receive quality. Everything else seems to work.


#16

When you say the LNB log show it working - - does it look like this?

If it does, then the LNB is being powered. You cqn double check that by measuring the dc voltage across the SMA connector your LNB is hooked up to. It should read about 13 to 14 vdc.

If all this is a yes, then my guess is you are not accurately pointed at SES-2, and therefore not receiving. That is another reason why the Tuner Status tab is blank. Ken


#17

Ok, I’ve never seen the status window go blank in eithe my Rasp PI or CHIP setups, so it through me off. Although, it hasn’t really been the best weather to be playing with the antenna. It’s about 12 degs out today. I had switched from using just the LNB to trying the LNB with a sat dish when it went blank. I switched it back and it is receiving again. I will try making a mount roughly the height of the old sat LNB and try that again. With just the LNB I am getting about -13 - -13.5 db. I’m in SD, so it’s clear skies here. I’ll be playing a lot more once the weather improves.


#18

Good - - you solved the problem. Work on the pointing and let us all know the results. Konrad, as you may have read, got additional gain on his system with a martini pitcher cone design like I tried last week. Ken


#19

Questions on Wikipedia app in Skylark 5.1

1 Generic to all the apps in skylark. can the window size of all apps be saved when opening/closing?
Right know I have to manually resize the outer corners of the app and then try to resize the internal columns within the app every time I restart the app. (the mouse resizing is not very precise … sometimes gets stuck and generates a “404 not found” error when resizing)

2 Links within wiki articles are currently not embedded in the “pages” that are downloaded. Can somehow they be maintained with a pointing to the “search” within skylark (not the internet link) ? In particular can they reference other wiki pages that have been previously downloaded… thus building up a real reference database of information.

3 Maybe a built in dictionary link


#20

I live on an Indian Reservation in SD, so I figured I would use the resources laying around. I had an old dish mount attached to my house and figured I’d either go to the dump or pick up a dish laying in a yard, I chose the latter. I’m using 40’ of coax, I used with my old cellphone booster, which was mounted to the dish mount. With wifi calling it isn’t needed anymore. Took an old spatula from the dollar store and made a mount for the LNB. I’m getting +3.75 dB now. I will happily take that. I feel spoiled with the faster speeds for downloads.