Skylark 5.4 for Dreamcatcher 3


#1

Skylark 5.4 for Dreamcatcher 3 (Ku-Band) is up on archive

It is available in two forms:

  1. The normal image file, to be burned to the sdcard as usual. If you are running Skylark 5.3, just burn this 5.4 image over the 5.3 sdcard (do NOT try to format/partition/etc, do NOT clear config/factory reset/etc). Then insert the sdcard back into the Dreamcatcher and boot up.

  2. An update file: this is a preliminary test for OTA. You can use this file to update your Skylark 5.3 to Skylark 5.4 via the webui - no need to remove the sdcard from the Dreamcatcher. To use this method:
    a. Download the update file to your computer. DO NOT extract it or process it in any way.
    b. Login to Skylark as the “othernet” user (logging-in as “guest” WILL NOT WORK)
    c. Open File Manager app
    d. In File Manager, in the left-most pane, select “Downloads” and then in the right-side pane, double-click the “opaks” folder to enter it.


    e. In the File Manager app menu bar, select “File” -> “Upload”. This will open up the file upload dialog, and your normal OS file selection dialog; select the update file you downloaded to your computer in step “a”. Click Ok/Open etc (as per your OS) to begin the upload.
    f. The update file will be uploaded to the “opaks” folder, and from there Skylark OS will start processing the update.
    g. Be patient. The update process will take 15-20 minutes to complete! Do NOT reboot your Dreamcatcher during this process.
    h. After update process is complete, the Dreamcatcher will automatically reboot into the new version. You will need to refresh the webui in the browser.
    i. If the process fails, just use the normal sdcard burning process as before to fix things.

New features in this release:

  1. Audio streaming over http. This means you can listen to Othernet Satellite Radio in your browser on your desktop/phone etc. It will also work in most audio players (Windows Media Player, VLC, mplayer - all have been tested). You can play the audio in any of these ways:
    a. Logging into Skylark (guest user is fine) and opening the “About” app. From there click “play” on the builtin player.
    b. Or you can click the “Othernet Satellite Radio” link in the About app (just above the player) to open just the http link in another browser window/tab. This should show your standard browser media player.
    c. Open the url: http://<your dreamcatcher ip>:8090/othernet.mp3 in any media player that supports http stream playing (Windows Media Player, VLC, mplayer all do - I don’t think iTunes does). Same URL can also be opened in most browsers (including mobile browsers) directly. No need to login to Skylark.

  2. Audio volume control and mute/unmute in lcdui. This controls only the speaker/3.5mm audio out, of course. Not the http stream (which can be directly controlled in whatever player you are using).

  3. Audio LED flashes while audio plays, and audio bitrate reporting in lcd ui as well as Tuner app.

  4. Bug fixes, biggest one being fixed mounting of large external SD cards which used to fail earlier. Bunch of other smaller fixes.

Known issues:

  1. If http stream stops (it will do that randomly, periodically), just click play again in your player, or refresh the browser page. You may have to do it 3-4 times, and may have to wait about 45 seconds.

  2. If you click play and it seems its playing older audio, its cause your browser has cached the data. You will need to refresh your page/ctrl-shift-r. This typically doesn’t happen on dedicated players like VLC.

Please report results/errors/problems in this thread. Thank you!


Skylark 5.3 for Dreamcatcher 3
#2

#3

#4

The over the air file (OTA) worked great, manually downloaded. Started with skylark 5.3 and after following the directions… it rebooted and now I am at skylark 5.4

The audio streaming is working. It’s a little hard find since it is in “about skylark” icon.
I am using firefox browser and it seems to have run the mp3 in it’s built in player.

My home wifi router must allow port 8090 by default. I didn’t have to make any changes.

Good job to team othernet

Edit: the led by the audio jack is flashing again ! (a good thing)


#5

Fantastic :heart_eyes: :heart_eyes:

Standard image writing worked fine, and audio is great - -

Playing right away out of “About App” icon. I’ll update the user manual as soon as I take Skylark 5.4 thru its paces.

Don’t forget to tell us when you put up Orson Welles’ War of the Worlds !! Ken


#6

@Abhishek, @Syed, @kenbarbi, @ac8dg We updated both the 3.02Q and 3.03 today, using the OTA option 2, both are successfully running v.5.4, audio is working as advertised. Great job, Othernet guys!


#7

Seem to be having a problem launching “whats new” app icon.

Attempting a reboot to see what’s up with “what’s new” app

edit: got it launch finally, on-close the “api call” spinning wheel has been rotating for 8 minutes

edit 2: now I have 11 spinning api call wheels along the top edge, but it is still responding

Since I only did the ota update. this time I will write the v5.4 image.
–nope coping the os partition still makes “what’s new” fail.
Next I will try (what is not recommended), repartitions/clean the sd and write to it like a clean sd

edit 4: cleaning the sd card got things working “normally”. Except I had to fine tune custom frequency in order to get the tuner packet rate, and audio rate to display (at 11902.4 they read 0).


#8

I got it in about three minutes just now… looks ok otherwise


#9

@Abhishek Abhishek, could you do OTA Step-by-Step Update Procedure for Dummmies like me who have never done it before. Ken


#10

@kenbarbi the first post, “a” thru “i” is a fairly detailed step by step description. Please let me know if theres any thing unclear in them, and I will try to fill it in.

I should add though that if you have already upgraded to 5.4 using the full image, doing the manual-OTA upgrade will not do anything, the system will simply recognize the OTA file as a non-update and ignore it.


#11

@ac8dg If that keeps happening, its a good indicator that your sd card is dying. Doing a factory reset will help to an extent (as that reformats the card), but its best to replace the card at this point.

Rewriting the image etc cannot help in this - in fact to a small extent it can only hurt as all that image writing will just speed up the sdcards’ demise.


#12

I think I’ll start using the ‘industrial’ rated sd cards . supposedly they support the Health Status Monitor feature, which enables OEMs to monitor capacity usage, performance levels.

datasheets for either the -i or -xi :


per amazon


#13

This is the one I use and have had a very good experience with, considering i must have burned 100s, maybe even 1000s images over the last few years:


#14

I will try it on my Lantern box which is still 5.3. I want to add this process to the User Guide I’m re writing after I get comfortable doing the process. Thanks, Ken


#15

I think you may want to note that future automatic OTA may be send via the satellite download ( @Abhishek could confirm ). The future updates may not require much user input except a reboot ( if that ? )


#16

It works like a charm. The key is to be patient as you say in step g. :heart_eyes: Ken


#17

Probably - - the file is on 4 MB large. How long would that take to download? Ken


#18

4 MB would take about 15 minutes or so.


#19

That’s a reasonable time.

The Preliminary test for OTA worked well when I downloaded the file to my computer, then transferred it to the Dreamcatcher opaks folder. Once done, the Dreamcatcher simply loaded the new file, processed it, rebooted itself, then deleted the file from the opaks folder.

I’m looking forward to the day when you try it through the satellite (while we sleep) for Skylark 5.5 :grinning: Ken


#20

The file would have taken about 80-90 minutes with the audio service running. Without the audio service, it would take about half that.