Skylark 5.7 for Dreamcatcher 3

Skylark 5.7 for Dreamcatcher 3 (Ku-band) is up on archive

  • Please update from 5.5/5.6 in the normal manner: overwrite the 5.5/5.6 sdcard with the 5.7 image, without trying to repartition//reformat the sdcard first.
  • This is primarily a bugfix release - it (hopefully) fixes the regular lockups seen in the 5.6 release.
  • If after burning this image you can’t access the AP or STA does not show up on your network, you may have to do a factor reset (see below).

Dreamcatcher v3.05 is in stock and ready to ship.

Dreamcatcher 3.05 has a PB1 function push button for triggering common recovery actions. It is located right next to the Power button (the one closer to SD2 is power). PB1 works with LED1 (FUNC) (located at the corner of the board next to SD2 slot). This is how to use it:

PB1 can trigger three functions:

  • Function 1: “Switch to AP mode (Reboot)” - You start with LED1(FUNC) switched off. Press PB1 once. LED1 will light up and then blink in a long-on->short-off->long-on repeating pattern (the single short off indicating function 1) and wait for approximate 7 seconds. DC3.05 will automatically reboot and switch to AP mode.

  • Function 2: “Configuration Reset (Reboot)” - You start with LED1(FUNC) switched off. Press PB1 twice (wait a second or so between presses). LED1 will light up and then blink in a long-on -> short-off -> short-on -> short-off -> long-on repeating pattern. (the two short-offs representing function 2). As before, wait for about 7 seconds (while the LED1 keeps blinking). DC3.05 will automatically reboot with configuration reset to default (this implies it will be in AP mode as thats the mode in default configuration).

  • Function 3: “Factory Reset (Reboot)” - You start with LED1(FUNC) switched off. Press PB1 three times (waiting about a second or so - 1-missisippi - between presses). LED1 with light up and then blink in s long-on -> short-off -> short-on -> short-off -> short-on -> short-off -> long-on repeating pattern (the three short-offs representing function 3). As usual, just wait for ~7 seconds (while the LED1 keeps blinking). DC 3.05 will automatically reboot with both configuration reset to default, and alll storage/downloaded files cleared, sdcard reformatted. Remember, this means it will reboot into AP mode.

At any time, if you have pressed PB1 and the LED1 is blinking a 1, 2, or 3 pattern, but you want to cancel out of it, press PB1 within the ~7 seconds as many times as needed so that LED1 switches off.
For example, if you pressed PB1 twice for function 2, and LED1 is now blinking a “2” pattern, Just press PB1 twice (waiting a second between presses). First press will take it to Function “3”, and then the second will will cause it to cycle back to “Function 0”, i.e, no action.

The three PB1 functions are exactly the same as the three corresponding ones on the DC 3.03 LCD menu.

Please post bug reports, etc in this thread.

Once again, a big thank you to @kenbarbi and @maxboysdad for testing this release over the course of last week.

Apologies to everyone for the messed up 5.6 release. Hopefully 5.7 is back to the same level of stability as 5.5.


Up and running on both 3.03 and 3.05, green balloons over Utah on the map! This ran great during the tests, with no crashes! I would encourage everyone to move up to Skylark 5.7!
My unit 3.05 is available for your viewing at: admin = othernet/j7m*2

1 Like

Great Job… :medal_sports:

It is working so I decided to try and customize my board. The flashing audio led was
too bright for my taste… I logged on and ran the command to change the brightness,

Now it no longer flashing… everything seems to work great …I won’t post what I did until the testing completed.

1 Like

Just installed it on my DC 3.03, all worked fine. Let’s see if the chrashes are fixed :slight_smile:

1 Like

Hello i want to know if i can download the Skylark 5.7 on my ancient device lighthouse which was receiving from HOTBIRD IN 2016

No, unfortunately the old hardware (anything older than the Dreamcatcher 3 series) is not compatible with the current Satellite service or with the Skylark 5.7 firmware.

Thank you for the information . if i use andruiono or raspberypi devices?

No. Only the Dreamcatcher 3 series hardware can receive the satellite signals.

If i by the recent device Dreamcatcher 3 can i sent and receive message i live in morocco north africa i think the signal is weak.

No, Othernet currently doesn’t offer a service to send messages. You can only receive data.

can i receive data in north Africa?

Its possible - as you said, the signal is weak. You may need to add a hand made horn or a dish like a lot of people on the forum use. Please look around the forum for what people have done.

Thank you very much nice to meet you good wiches .

1 Like

Last night, I left my Dreamcatcher v3.03 running Skylark 5.7 out side unprotected. The entire board got soaked in the rain and the Tough Screen lite all blue. I could not restart it after drying the board, so figured the board was fried.

I put the micro SD card into a dry DC v3.03 or v3.02Q could not bring them up either. I cleansed the micro SD card and reloaded SK 5.7 on it, and it worked fine everywhere.

Conclusion was the rain caused the DC to corrupt the Skylark program. Moral - - don’t let your Dreamcatcher get wet :rofl: Ken


Something you may try next time you get all wet is to take out the sd cards, then put the whole works including the sd cards in a pan full of dry rice (cover it all with rice) and let it sit a few hours. Works well on cell phones that fall into a toilet. Don’t ask me how I know…

1 Like

For the second night in row I have used my DC v3.05 running Skylark 5.7 also outside unprotected.
Although outside temperatures were near to 0° Celsius (32 Fahrenheit) everything is working absolutely fine.


Hi Willi, when I first received my DC 3.02Q, I built it into a “Husky” box from Lowe’s, and set it up on my patio, where it stayed all winter (as low as -12F that year) until it got too warm in June, then had to get out of the sun. It performed well in the cold, just didn’t like being hot. Jerry

Anomaly (?) Question: Both Dreamcatchers, 3.03 and 3.05 have been up using Skylark v5.7 for five days with no problems. All apps seem to be working and up-to-date. However, as you can see in this screen shot, a bunch of the rotating pluses have shown up to the right of the “heartbeat man” . If one closes the tuner app, the heartbeat man goes away, but the rotating pluses do not. I have not re-booted either unit, and both are displaying this behavior. I have logged on and off the tuner app in both units numerous times. Did not see this in previous versions of Skylark. Do you see this when logging in remotely at (my v3.05) admin login is othernet/j7m*2 ?