Skylark Release 4.4 Issues with flashing (This is my first attempt to flash from VM)

Hey guys, I am having issues with the flash, but I think it is procedural for my setup at this point. I have never tried to flash the chip before so this may be easy. I have the VM loaded, I think I have my chip jumpered correctly (can I tell?) and I plug in the CHIP, then start the VM. The VM says it never finds a CHIP in FEL mode and eventually times out and drops to the shell.

I see a USB device listed called “Onda (unverified) V972 tablet in flashing mode [02B3]” so is that it? When I look at the USB settings I see that there is a “filter” set to “CHIP FEL Mode”. Should I add a new filter for the device I mentioned above? (I don’t think that will help because when I tried it the created filter was identical except for adding a “revision” number) Have I done something wrong? I didn’t load any drivers in windows 10, but then again it didn’t ask me to. I do see a device that doesn’t seem to have a working driver loaded in my win10 device list.

@Syed This was a fresh install of Virtualbox and the VM image. I did not load any drivers and so far I have not messed with anything except the “USB Filters” where I looked at adding one, but ended up deleting it.

Here is a picture of my chip with the jumper installed.

The jumpers look good. Now what happens when you start the VM? Can you take a picture of that screen?

If you look at my first screenshot above you can see it in the backgound. I can get a cleaner picture tomorrow but it boots all the way to the part where it is trying to find the chip. It tries twice and times out.

Try a different USB cable. Where did you get that case?

Did you confirm that you have virtualization enabled on your PC?

I too am having issues flashing. CHIP is same as shown above. Using VM under Win7.
Also see the same Onda USB device.
I get kernel panic errors.

1 Like

@Zathras Can you confirm the extension pack is installed and that virtualization is enabled on your computer?

Yes, extension pack is installed.
As far as I can tell/check, virtualisation is enabled. There is no setting in the BIOS that mentions virtualisation.
PC is HP 8200 Elite All-in-One.

What cpu do you have? It looks like the hp 8200 elite all-in-one came with either an i3 2120 or an i5 2500s. The 2500s has virtualization, but the 2120 doesn’t. The setting in bios may be labeled Vt-x.

All good now.

I used a cmd line BIOS config tool and found it was disabled, even though other software indicated different. Used same tool to enable VT-x. CPU is i5 2500s.
Ran VM and and the CHIP updated perfectly. Skylark now running.

On a side note, updated the AiO BIOS to latest. This time managed to find VTx setting under Security > System Security. Why did they hide it there? Go figure…

Thanks for the guidance :slight_smile:

Shoot, I thought after I saw @Zathras post that maybe I just hadn’t gotten virtualization turned on in BIOS, nope, it is there. But, now that I see what resolved his problem, I may see mine, maybe someone can tell me where to fix it. When I run the Flasher VM and look at the bottom of the window I see that virtualization (VT-x) is listed as “inactive”. Is there a setting I need to change in Virtualbox? Anyone know?

I got the case from Amazon, the idea came from another thread here so there must be at least two of us! :slight_smile:

It is pretty nice, the instructions were just a picture so you had to pay attention, lots of little parts. pretty well thought out though, it has a way to extend the reset button, holes for port access and at least one hole that I am assuming is for ventilation. The only thing it didn’t have in the way of port access is for that white port that I think has to do with battery power? I think it is a newer part of the CHIP and they don’t have a hole for it. If I need it I may need the drill. It is very nice for protecting the CHIP, my only concern is if it will cause heat issues.

1 Like

Can you show me a screenshot of “VT-x” showing as inactive?

The FEL mode chip is showing up fine - yes its that Onda tablet thing - they are the earliest users of the SoC thats on the CHIP, so their name got associated with the particular usb id used by the SoC in FEL mode.

The only thing I see amiss is that in the usb settings of the VM, I don’t see the Onda tablet being actually connected to the VM. If you re-run the VM, and manually “enable” the Onda device connection to it, does that make the flasher VM see it?

Other than that - see if completely uninstalling Virtualbox and reinstalling makes a difference. The filters and everything are all already correctly configured on the OVA, so you should not need to mess with those. Another thing to try is running Virtualbox as administrator.

Failing all this, see if you can snag a live-usb linux image to boot off a usb stick, and try to use that.

Edit: this “check mark” next to the Onda device is missing:

Here is a picture of the virtualization thing I was talking about, although that may not be the issue.

I tried to select the USB device, and I get an error, here is the error:

I don’t know why it would be “busy”. Could windows 10 be trying to capture it for some reason?

I forgot to mention, this morning I completely removed both the VM and VMbox and reinstalled them both. Exact same results as yesterday.

see if you can find a device driver already installed for the Onda device in device manager and un-install it.

It seems like this is the device that shows up when I plug in, I have un-installed it and it just shows up again next time I plug in.

Even though I deleted the older outernet flasher from VirtualBox the following error showed up when I tried to install the new one –

"Failed to import appliance C:/Users/Richard/Downloads/skylark-chip-flash-v4.4-1702272118+8ed427f.vmflasher.ova.

Machine settings file ‘C:\Users\Richard\VirtualBox VMs\Outernet Flasher\Outernet Flasher.vbox’ already exists."

So I renamed the original “VirtualBox VMs” folder (didn’t want to delete contents yet) and was then able to install the new flasher for Skylark 4.4. Flashing the C.H.I.P. went without incident.

Bottom line: Skylark v 4.4 is now up and running fine.


I bought a Zebra case for my Raspberry Pi 2B a couple of years ago – one of the better ones I could find with proper openings to the board Now need to order this one for my CHIP I suppose!