Station mode problem (among others)

I hope I put this in the right category.

I’m having difficulty getting my Dreamcatcher to be accessible in station mode. I’ve put the SSID and password of my router into the Wifi tab in the Network app. I’ve rebooted it into station mode, and it comes up with a DHCP-supplied IP address. But that IP address is not reachable on my local network. We have a Fing box, which detects that it is on the network, but ipconfig/arp -a does not show it as available, and browsers, etc. cannot see it. I’ve tried rebooting, resetting to factory and reentering it, changing location, etc.

If the system logs would shed light on it, which one, and what would you suggest I look for to help determine WHY my Dreamcatcher is connecting to my router, being assigned an IP, but that IP is not visible to other devices on the local net? This is all very distressing.

Another question pertains to the instructions given in the user guide. It says that you can’t connect to a network that does NOT broadcast an SSID (ours does) and is NOT connected to the Internet (ours is), BUT you CAN connect to a network if the password on it is 8 elements and “complex”. Is this password thing only an issue when the network doesn’t broadcast an SSID and/or doesn’t have an Internet connection? Or is it ALWAYS something necessary? We have a 10-character password, but it is not terribly complex according to the example given.

Do we HAVE to have a complex password, even if the router DOES broadcast the SSID and DOES connect to the Internet? The logic in the instructions is vague and doesn’t parse cleanly.

Second issue: I do not have Firefox installed on anything. I haven’t used Firefox in nearly a decade. I’d rather NOT use Firefox if I can avoid it. So, seeing as I DON’T USE FIREFOX, is there any way to work around this %#!#!$ “No more sessions” bug? I can fiddle with it to get around it SOME of the time, but it doesn’t seem consistent, and I just spent 20 minutes trying to get around it again. The most recent attempt involved surfing to instead of leaving off the port number. THAT worked, but I can’t tell if that’s just a fluke, or if it’s a valid workaround for Chrome.

Is there a workaround for Chrome similar to the one for Firefox?

Last question, related. Under what conditions can you SSH into the Dreamcatcher? Can you only do it under Station (client) mode? Or can you do it in Hotspot mode as well, from a device connected to it via WiFi?

Ok, I think that’s enough for now. If you need more info, I’ll have to figure out how to get it into a post for you. The most important one is, of course, the station mode issue. It’s a major stumbling block at this point.


I was able to ssh in both in client and AP mode, since I was fussing about trying to get my dreamcatcher to connect to my network (by editing the wpa supplicant configuration). Perhaps I should set up a travel router as a disconnected network to see what happens when I put a dreamcatcher on a LAN with no internet.

But since we’re grousing about ssh, can we persist the authorized_keys somewhere so we can turn off password logins?

Hi, i use my DC3 connected to my wifi network as you want as well.

I did not have any Problems so far, did you maybe have a typo or some other Issue in the Network?
The Password lenght shouldn’t matter.
I also use Chrome and had no issues so far with the Interface.


Thanks for replying, Manuel.

I’ve triple-checked the SSID and password. I even factory reset it and re-entered it. I compared it to the SSID that my phone uses to connect, and it’s precise.

I think the Chrome issue is a problem with cookies for session info in Access Point mode. I’m going to clear the cookies in the machine I’m using to connect to it and see if the sessions issue goes away.

I can’t see any problem with it. I don’t know why it isn’t visible on the local net. It also doesn’t help that a) there’s no RTC on the board, and b) the logs only contain the CURRENT boot status, not the PREVIOUS one, so if you want to see the logs of the Station mode, you can’t get to it if you can’t see the IP address on your local network. If I’m mistaken with that, I hope someone will correct me, but from what I could see in the log reader, it wasn’t accessible.

could run something like ‘angry ip scanner’
on a windows (or other) computer connected to the same network as the dreamcatcher.

It is similar to Fing

Maybe that would give a few more clues.

I did try using putty to SSH to the ip at the port 22
it brought me right to the logon prompt and using
othernet , password othernet I can access the dreamcatcher

1 Like

Well, but it shows station mode and the IP on the screen?
Ping works?

Hi @ArdRhi,

Maybe it is an issue of a mixed WiFi network of 2.4 and 5 GHz. Not with the Dreamcatcher but I have got blocked in the past connecting between a mobile and a Pi on my WiFi as one was on the 2.4 and the other on the 5GHz so I wasn’t able to view one from the other. I think this was a particular problem with the ‘hub’ supplied by my BT Internet provider (in the UK) but maybe this is a problem with other providers’ routers?


I’ve heard of this before. My friend said he had it on his router, but I never experienced it myself. The router sets both 2.4GHz and 5GHz AP the same name and creds, and can somehow merge them into one, and have the device to connect to the optimal one.

If this is the case, (idk how it works I never messed with it), it is possible its trying to tell your DC to use 5GHz, which the dongle doesn’t support.

For testing purposes, try disabling the 5GHz wifi and then see if the DC can connect as expected.

1 Like

You can also explicitly name your two Wifis - …_2.4GHz and …_5GHz and then ensure both systems are connected to the same WiFi (the …_2.4GHz based on @zefie comment about the dongle not supporting 5GHz .

Correct, my apologies for replying to the wrong comment :slight_smile:

Also, @ArdRhi, if you have a LvTTL serial adapter, the pins are already attached to the dreamcatcher (between SD and LNB, labeled UART1), this should give you realtime serial console access regardless of network.

We have managed to get the wifi station mode to work, after tearing our hair out trying to figure it out. We think there’s some issue with the wifi extender we have near the workbench where I was working. Taking it upstairs to the position it will have when operating, it connected directly to our wifi router, and is now working properly.

I just got a longer cable, and we’re going to mount the LNB to an antenna mount off the side of the house, so it can get an unobscured view of the sky where SES-2 is located. I hope to get that done relatively soon, so we can get this box up and receiving.

Thank you for your suggestions, all of you.

There was a small issue that I wasn’t seeing the receive data update as I moved the LNB. This proved to be an issue with the Android tablet I was using to access Skylark. It’s an old Nexus 7, and it may simply be too old and slow to properly handle real-time updating, or it’s not playing nice with Skylark for some reason. My phone connected and sees real-time updating just fine. I just wanted a bigger screen.

Anyone else have an issue with a 2015 Nexus 7 not showing changes in signal strength on Skylark?

1 Like