Sudo poweroff command killing USB ports- has anyone tried this recently?

When I first received my dreamcatcher kit and trying various operating systems I followed the instructions in the docs to power everything off.

"8. Note that unlike Skylark, the root filesystem here is modified and is writeable, so it is important you shut this down properly:

sudo poweroff"

reference :

When I issued the sudo poweroff command absolutely everything turned off including my computer - immediately. I am wondering what hardware the sudo poweroff command controls? I think in my case when I issued the command some programmable logic controller component on the Dreamcatcher board latched power to ground and it caused a short circuit that cauesd a high current drain on the computer USB port even though I have a separate 2.5 DC supply on the miniUSB port. This command killed my WiFi USB port on the dreamcatcher board. The WiFi dongle still works.

I would be curious if anyone else has tried this command recently? Be careful if you do use the command.



Hi, I use that “sudo poweroff” command every time I want to shutdown without any problems, everything works correctly here.

That is good to hear. I will assume my USB WiFi port is dead due to some other cause such as ESD or a voltage surge or the power methods with the pc and power adaptor plugged into same outlet. Hopefully it is isolated to my board.



It must be some component of the board that has been damaged, maybe if you have an electronic technician in your area can test the board to find out what was damaged … anyway due to the board does not have an enclosure to protect I recommend that before playing the board we must download static that our body accumulates as this can also damage components, so before manipulating the board you have to touch the earth or some wall to discharge, it may seem exaggerated but it is better to prevent.

I agree!!

Hi Dan,

Thanks for noting this! Personally used on more then about 30 different DC boards that command in the last months and non of my USB ports killed. What I can imagine that you have problems around your mains network grounding, can test it with specific tool or perhaps a multimeter. Also what kind of USB adapter are you using?

Each USB port has current distributor switched against overcurrent (500mA). Do you still get 5V on the broken USB port? (test with LED flashlight etc. which don’t need data). Also please check the socket solderings too.

When poweroff executed the A13 CPU starts the shutdown process and finally at AXP209 power management chip shut downs itself thus cutting off every voltage regulator on board so it’s safe.

USB ports are dead . Without schematics it’s difficult to troubleshoot the root cause on this particular board . I went ahead and purchased a second Dreamcatcher and it worked fine out-of-the-box . With Wi-Fi and everything. I haven’t had it outside long enough to download any files but it has a good signal-to-noise ratio. I suspect over the weekend I’ll play around with it and it will work great !