Updates to USB storage feature (discussion) - was: Files in opacs folders and no "updates"

Hello, don’t know which category i should i put it in.

Have this problem:

files stuck in the opaks folder. Getting no news updates or wikipedia files. Weather, Community Content, Games are updating. Is this normal? I now deletet this folder and get an error message (created over ssh again).

And sometimes i get the message “File not found” when i click on News and on Community Content. How can i fix that?

Chip with Librarian v5
4GB Flashdrive
2A Samsung Charger

greetings from germany :wink:

Would you mind updating to Skylark? I know that mobile support is lacking, when compared to Librarian, but all of the active development is happening there.

first, as Syed said: use Skylark.
second: try without the USB stick. there is something wrong with the USB stick format.

Skylark don’t provide the functions right now that i need. One of them is wlan security because its crashing complete if i try to secure wlan. And i can’t go on the files without login and my smartphone diddn’t display it correctly.

I try it without the usb drive. Formatted it fat32. Now i must reflash it because i accedently deletet all in /mnt

in wifi client mode or access point mode? Access point mode has a bug - i have just implmented a fix for it, it should be in the next release.

you can access files over anonymous ftp.

Mobile is a work in progress. More fixes are coming. Best if you monitor the Skylark 1.0 forum thread.

Best of you format it ext3 or 4. Fat32 is very problematic. Also, given that theres between 3 to 7 GB of internal free space on the CHIP - enough for over a year (with the cleanup script running), there is really no need to use a USB stick anymore. USB sticks were introduced when the on board storage was minimal, and the data rate ( on our now-stopped Ku-band service) was 100kbps.

Please bring back the method of read-only access to the downloaded data via the web application
without login and use the login only for access to admin tasks (tuner, network, deletion of files).

its in development.

You have to remember that Librarian got where it was after about 2 years of development. Skylark is less than two months old.

1 Like

I think i try it without the usb drive. It runs fine without. I build it in a little waterproof box. Thats was the point i added a flashdrive and a hub.

I reflash it (i am silly and deleted the mnt folder) and try it. Is it possible that it dint work correct when i have an bad snr? It was between 1 and 2 for an amount of time. Got 800 failed packets from 70000 recieved.

@Abhishek this USB stick issue why my APRS Viewer in Skylark 4.2 shows no messages? I have a 64 GB stick installed. Ken

bad snr will cause other problems - like reliable and timely reception of files, as with 1-2 db you will not be able to maintain 100% frame lock. While 800 failed packets is bad, there were probably more packets that you didn’t receive at all due to loss of frame lock. So its important to repoint the antenna etc, whatever it takes - to ensure better snr.

But the snr would not have caused the opaks problem.

Also, if you deleted /mnt, a reboot should fix that. If not, could you please report that as well?

its possible. USB sticks are definitely a problem. By themselves, as they tend to unreliable, constant get corrupted, may have random filesystems with associated quirks, and the mechanics to support these external USB sticks is itself a complex and painful one.

I am trying to figure out a way out of these external usb stick issues - get rid of usb stick as “live” storage completely, and just use them for archival.

But in general, I recommend that starting with Skylark 1.0, people simply don’t use external USB sticks. There is no need anymore, there is enough free space on board - 7+GB on CHIPs sold by us till now, 3+GB on “new” CHIPS being shipped by NTC. Space available is enough for pretty much forever - given that there is also now a cleanup process that removes old useless files.

If you prefer to archive all data, its easy to simply setup a script that syncs the whole downloads dir to your computer over ssh or ftp - maybe once a day or something.

But definitely try removing the USB stick. It will also help (a bit) with power issues.


I missed the USB stick removal warning going to Skylark :sleeping: I’ll make it gone today and see what happens

By the way, otherwise my Alpha Lantern has been running very solidly by itself without failure with Skylark 4.2. In rain and overcast weather, my SNRs run from 3 to 4; with clear skies I run 8 to 10. When I run 8 to 10, I test my fractal antennas. Thanks, Ken

Removing the USB stick works! I am getting APRS updates and the new News is just starting to arrive. My Wikipedia files are empty - - I suppose I can upload what was on my USB stick to the CHIP with my FTP program.

As you said, the next update will now occur over the air (OTA). I’m looking forward to seeing that work :wink: Ken

How are Skylark applications developed? It looks like you use OS.js.
Its it possible do develop own apps?

absolutely! All the code is on our github (http://github.com/Outernet-Project)

I reflashed it bevore i read your post. Sorry.

But now it works fine with the usb stick. I have to format it ext4 and put it in bevore i configure librarian. Then all files go to the usb stick.


My USB Stick was 64 GB formated FAT32. Before I removed it at @Abhishek suggestion, I was not receiving any files in the APRS or Whats New Folders along the top of the Syklark 4.2 screen. With the stick removed, I now see content there. Of course, I had to start down loading new files as all my previous files got stored on the stck.

Is the problem something changing the Stick format type might fix? I believe @Abhishek said it was a bug. Ken

no. not a bug.

usb sticks are flaky. especially when they are used with filesystems that weren’t designed to be used with such storage: flaky, flash-based-but-pretending-to-be-block-based-like-hdds, and prone to random shutdowns and disconnects/pullouts.

fat32 is an antique filesystem, but due to historical accident, the most popular one, and most easy to use when transferring files between linux and windows. It especially is very vulnerable to random removal, or device brownouts.

So what happens is this: at the slightest pretext, the filesystem starts reporting errors. The linux kernel notices these errors, and to prevent further damage, immidiately changes the filesystem mode to “read only”. So no writes happen. That is what you see - no new messages showing up etc. Sometimes only files can be created, but not written to.

All of this is a mess, and I strongly recommened not using usb sticks at all with skylark. I am not even sure why so many users use them. They are completely unnecessary.

In fact, I will be removing support for using USB sticks as “live” storage from the next release. USB sticks will still be supported, but only for archival use - when you plug it in, the system will automatically copy over all files from internal storage to the usb stick. and then unmount it.

USB sticks are a source of a very disproportionate number of support problems here.

Good information - - BAN THE STICK

I think that explains what I have seen on my stick with the FSCK#.REC files:


Well I hope you will bring back usb support later on when things are more polished, because 7GB is not a lot of storage. BTW I bought a 2nd chip, and I have been pushing skylark to its limits and It has been holding up quite well. Including the entire Wikipedia database running under mediawiki.