USB0 IP clash with WLAN

I was setting up the kit to join my wireless network, it joins fine but there’s no access.
After poking around i realised that the USB0 interface ip clashes with my wireless lan network. the USB0 interface appears to have priority and any traffic that tries to go back over my wlan goes over the usb network interface.

I have tried editing the various config files to move usb0 to another network range in /etc and in /mnt/conf

However on reboot the changes were not persistent.
Using the serial console and doing a ifconfig usb0 down is the only way to get it to work on my lan.
Am i missing something on making filesystem config changes persistent so that changes to the usb0 config file are kept across reboots.

I would also like to make a suggestion that the usb0 interface IP range should be changed to a non standard range that is unlikely to crash with a regular wifi network.
Something in the high 192.168 range like is unlikely to crash with home router defaults. Shrinking the subnet down to a /30 would also help to prevent clashes.

If you are issuing class A addresses to your network you either know what you are doing or are connected directly to your cable modem.

Presuming the former; make a static IP entry in your DHCP hosts file so that a different IP address gets issued to the CHIP’s MAC address.

Assuming the later; you’re SOL. Put a router between you and the cable modem (you should do this anyway!!!).

  1. classes don’t exist since subnetting and CIDR. You can use any network range with a particular subnet. Its not uncommon to use in lan space. As i said its a which is a subnet.

  2. DHCP won’t make a difference unless i move my insecure network from the range. the usb0 interface is on the network and because its seen as a wired lan it has a lower METRIC value then wifi.

  3. cable modem has nothing to do with anything here.

  4. i am looking at building the firmware myself now but an alternative option from someone who knows more about the internals of the OS would be useful.

So i found a solution without recompiling. it’s not neat and it does stop the usb networking from working as its not possible to modify the /etc/conf.d/dnsmasq files. but atleast when the wifi is joined to a network the device will be accessable over wifi

remove the usb0 config simlink
$rm /mnt/conf/etc/network/interfaces.d/usb0
copy the base file from /etc to the conf partition
$cp /etc/network/profiles.d/usb0 /mnt/conf/etc/network/interfaces.d/usb0
make needed changes to /etc/network/profiles.d/usb0 /mnt/conf/etc/network/interfaces.d/usb0