WiFi dongles for Raspberry Pi receiver


#1

Thank you for your assistance. I was considering just doing the same thing you suggested. Do you have any suggestions as to which Wi-Fi doogle I should purchase. I see Wi-Fi googled it comes with the Outernet kids has a range of approximately 50 ft. Are you aware of any that have a greater range that will work with this system.


When will the Raspberry pi / tuner kits be available again
#2

Hi, and welcome to the forum.

The currently released image has a relatively limited support for dongles, but the upcoming update will extend the support to more commonly found Realtek devices in addition to Atheros and Ralink dongles. Devices based on rtl8192cu driver should have a reasonably high chance of working once the update is released.

My personal favorite is the TP-Link TL-WN722N (Atheros-based). It has a decent signal with the big antenna, and the antenna can be replaced with an after-market one for even more range. It doesn’t support that many clients, though. If you go for this one, be careful: (1) it is big, so it will make at least 1 USB port unusable (will cover it), and (2) there are similar models from TP-Link that look identical but are not based on Atheros (they do have different model number). Not sure what strength external antennas it can support nor its range rating, but this is probably the most flexible option. (In addition, most Atheros-based devices should work fine).

The one that was in the kit is a Ralink-based Tenda W311MI dongle (RT5370). It’s mid-range in terms of price, with decent support on Linux, and that’s why it was chosen. Another reason is that it can support more clients than the other dongles. I forgot where I got the numbers, but I can look it up if you’re interested. Someone did a test with a few of the commonly available dongles. You may see dongles with a similar form-factor (body about the same size as USB plug) with red-grey “WiFi n” marking. They are usually based on the same chip. I’ve seen some that have a detachable antenna. For example this one.

Other common dongles are Netis WF2120 and Edimax EW-7811Un nano dongles, both based on Realtek radio, and supported in the (not-yet-released) update. These weren’t supported till recently, so I had no reason to look too deeply into their characteristcs, and I’m not sure how good they are. You will also run into many nano dongles which have a similar form factor as Edimax and Netis nano dongles (body about half the size of the USB plug). 9 times out of 10, they are based on the same or similar Realtek radio as those two.

Note that power may become unstable if you add a dongle that is too power-hungry. I haven’t had too many issues with the mentioned dongles using a 1.5A phone charger, but YMMV. I think @pradeeka here mentioned some issues using a 2A charger.


#3

I think that I will be going with the Wi-Fi dongle you mentioned above, TP-Link TL-WN722N, when do you expect the update you mentioned to be released so that it will work.

Just a thought, a short USB extension should overcome the problem of covering up the other USB ports.


#4

TL-WN722N should work with the current image (v2.6). We will also release development snapshot of the upcoming update tomorrow or early next week.

And yeah, extension cord can certainly help.

EDIT: Actually, I think I received both a cord and dongle stand with the dongle.


#5

Also, if you can wait, I can do a small (unscientific) signal strength test over the weekend and post the results here. I have all the mentioned dongles here, so I can test them all.


#6

That would be great if you are so inclined but don’t give up any quality time with your family on my behalf. Also work and no play makes Jack a dull boy :blush:


#7

It won’t take too long (I hope). Also, this work used to be my play so it’s all good. :smile:


#8

:blush:


#9

I’m using TP LINK TL-WN722N with my receiver. If you can, connect it with the Pi through a Multi TT USB hub. Then it will become more stable. According to my experience 100%, but without booting with a LAN cable attached.

http://www.tp-link.com/en/products/details/cat-11_TL-WN722N.html


#10

Today I’ve tested 4 different dongles I had laying around to see which one has the strongest signal. Before I begin, let me point out that I’m neither an electrical engineer nor a radio ameteur. Therefore I won’t comment too much on the results of this test.

The dongles tested include:

  • TP-Link TL-WN722N w/ stock antenna (3 dBi)
  • TP-Link TL-WN722N w/ after-market antenna (5 dBi)
  • Tenda W311MI
  • Edimax EW-7811Un
  • Netis WF2120

I’ve tested all 4 dongles as attached to RPi2 w/ 1.5A PSU (Sony phone charger), tuner and external storage device attached. This is a typical setup for an Outernet receiver. All four dongles were able to work without any additional USB hubs, extension cords, or a bigger PSU. The software is an alpha version of the upcoming release which is equipped with Realtek hostap drivers and new AP configuration interface.

The client device is my work laptop with Intel dual-band 7260 wireless adapter. I measured the signal strength and quality at the distance of approximately 2m with clear line of sight. The software used to render the signal infromation is wavemon.

Test procedure is fairly unscientific (as promised) and consists of associating with the AP and letting wavemon run for 5~5.5 minutes and taking a screenshot of the wavemon interface when done. :smile:

Usable WiFi signal is considered to be between around -35 dBm and -90 dBm where anything above -60 dBm is considered strong. Here at my home, I typically get around -45 dBm from my TP-Link TL-WDR3600 router with a 5 dBi antenna. Because of the test setup (2m of clear visibility to the recevier), all dongles will be giving us fairly strong signal. We are more interested in relative differences between the devices. The four dongles seem to perform very similarly, except the Ralink-based Tenda dongle, which has a somewhat weaker signal and poorer link quality. Interestingly, TP-Link dongle w/ 5 dBi antenna performs almost exactly the same as the one with stock 3 dBi antenna.

TP-Link TL-WN722N

TP-Link TL-WN722N (w/ 5 dBi antenna)

Tenda W311MI

Edimax EW-7811Un

Netis WF2120


#11

Thanks for the info.


#12

Hey folks good day. Working on a newbuild with an RPI2B to a Tenda W311MI (Ralink 5370 chipset).
Getting very strange results with the AP mode. I have 2 dongles, same result. AP is visible from a client but no strength and cannot connect.

Works great with one of my Atheros based TL-WN722N.

Using ORxPi2-latest.zip 22-Apr-2016 15:32 66271097

Any ideas? Appreciated.

Dave


#13

Looks like I may have answered my own question. Would appreciate peer review. I suspect our Tenda friends swapped out the chip set on the new W311MI to the flavor of the week. I see no 5370 on the device ID… And it wants some other driver.

CAVEAT EMPTOR!

[ 2857.646068] usb 1-1.2: USB disconnect, device number 6
[ 2861.720407] usb 1-1.2: new high-speed USB device number 7 using dwc_otg
[ 2861.851783] usb 1-1.2: New USB device found, idVendor=148f, idProduct=7601
[ 2861.860626] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 2861.872061] usb 1-1.2: Product: 802.11 n WLAN
[ 2861.878350] usb 1-1.2: Manufacturer: MediaTek
[ 2861.884954] usb 1-1.2: SerialNumber: 1.0
[ 2861.970388] usb 1-1.2: reset high-speed USB device number 7 using dwc_otg
[ 2862.093398] mt7601u 1-1.2:1.0: ASIC revision: 76010001 MAC revision: 76010500
[ 2862.104295] mt7601u 1-1.2:1.0: Direct firmware load for mt7601u.bin failed with error -2
[ 2862.117595] mt7601u: probe of 1-1.2:1.0 failed with error -2
ORxPi2 v3.1 | [email protected]:/lib/firmware> lsusb
Bus 001 Device 002: ID 0424:9514
Bus 001 Device 001: ID 1d6b:0002
Bus 001 Device 003: ID 0424:ec00
Bus 001 Device 007: ID 148f:7601
Bus 001 Device 005: ID 1f4d:3000
ORxPi2 v3.1 | [email protected]:/lib/firmware> 148f:7601
-ash: 148f:7601: not found
ORxPi2 v3.1 | [email protected]:/lib/firmware>


#14

Folks - just need some feedback here. Is anyone getting acceptable performance out of the orxpi2 local wifi ap daemon? I have tried both the supported atheros and ralink chipsets and get very poor IO performance. Basically not usable. I do fine over the local ethernet, and have transitioned to a hardware wifi bridge and it works great. thanks for any feedback.


#15

The hostapd setup in ORxPi is pretty basic, so you could probably get better performance with a few tweaks. Try this via SSH:

$ printf 'hw_mode=g\nieee80211n=1\n' | sudo tee -a /etc/hostapd.conf
$ sync
$ sudo reboot