WiFi Network Outernet cannot be joined

Well, it took me just a few keystrokes to render the system unreachable. Thought I’d try connecting the CHIP to my wireless network, and it failed to connect. Couldn;t find it on a network scan. Tried to recover from wireless mode. Did the reboot with the router turned off. I see the Outernet SSID, but nothing can connect to it.

How can I fix this?

Ok, so actually the issue is that after returning from Wireless mode the range went from 30ft. or so down to 2 ft. Literally, I have to put the laptop right next to the CHIP for it to actually be able to use the interface.

What gives? I changed channels, or attempted to, but when pressing the save and reboot, nothing happens and the change is not set.

If you are running rxOS 3.1, I believe you have to press the reboot icon 2 times. Ken

1 Like

Will that restore the range? I was successfully able to make it change channels, but the range is still about three or four feet max. Before I changed it to wireless mode, the range was at least 20ft or so. After it came back from wireless mode, the range was seriously diminished.

When I rebuild the system into the larger case, I’ll probably use a USB hub and wireless dongle. Is there a vendor for the recommended/supported model?

Several other people have reported poor performance from the CHIP’s WiFi. My CHIP works well. I can get about 60 feet thru 3 wood/sheet rock walls to my Wireless Access Point in my house.

Input power to the device has caused some people problems when they were using USB power cubes that put out less than 2 amps at 5 vdc - - my 2 amp USB draws anywhere from 4 to 7 watts when measured with an AC Watt-meter.

Another solution I have used (which works well), is to use a range-extender on my home WiFi set real close to the CHIP device when it is running too weakly. Ken

I’ll add my name to the ones reporting poor CHIP WiFi. Although the signal is strong, and the advertised SSID is visible at a reasonable distance, no connection can be made unless i’m within a foot or two of the device. I checked power and for interference using a spectrum analyzer, and neither are an issue.

Are exchanges of these devices available (purchased from Outernet)?


Try changing it to Channel 1. I have a considerable amount of RF in the air both from my own setups and from neighbors. Channel 6 and 11 were unusable to the CHIP, but changing it to Ch. 1 fixed it right up.

Let me put my oar in the water too - - I did the same thing, and got good connectivity. Ken

well im having the exact same issue but to fix mine it take me rebooting the chip computer i will try changing the wifi channel next

Water, oar etc. from me…
Note mine has been running Skylark now for 4 days without a reboot, so I can say for sure that rebooting does not “fix” this issue…

Each morning I have tried to connect from my PC about 30 or 40 feet away, through glass, and I can see the signal ( on Ch6) strong enough, but it wont connect ( again this morning too BTW)
The first day I disconnected my laptop from its cables and walked closer & closer, went outside, still no good. Then when I was about a foot away (literally!) it connected… I carried my pc back and it stayed connected…

I have learnt now, that, when it won’t connect, DO THIS:

  1. I carry my phone outside to RIGHT NEXT to the CHIP device , and connect it to OUTERNET
  2. take my phone inside and next to my PC, then I us the phone browser to open the logon page ( for in Skylark)
  3. once I see I can open the page on my phone, THEN I connect the PC to OUTERNET and it works!
  4. the connection to the PC stays good the entire day, until I disconnect to go to bed!

The above has worked every time so far, It is like I am “carrying” the wifi signal in on my phone, like a glass of water from the kitchen LOL!

I suspect that the wifi Receiver in the CHIP is going to sleep ( whilst the TX is still transmitting SSID’s ) and then only a REALLY strong signal will wake it up… This is probably a bug in the firmware of the CHIP IMHO, and, unless there is a constant connection to the CHIP , that they will ALL do it…

try the “carry the wifi signal inside” method & see if it works for you :slight_smile:

if i could just get it on my wifi network but the key is wpa2 based so … time to hunt down a usb hub and a usb eth adapter and another issue i found is if you disconnect from the wifi network you have to reboot the chip to get reconnected… im on a windows 10 pc

What you describe is WiFi congestion. Changing the channel to a less congested one will fix this. I set the CHIP to channel 1 and all the connectivity problems went away. I also decided to stake out my claim to channel 1 by putting up an inexpensive TPlink repeater, linking it to the Outernet SSID, but using a different SSID for broadcast. This serves two purposes. It keeps the Outernet WiFi connection alive, and it creates a “cone of WiFi” around the area on channel 1, so that other access points in the immediate area tend to avoid it because they are in “Auto” mode and can switch away to what appears to be a less congested channel. I can now connect to either the Outernet directly, or to the broadcast SSID if I want to.

The TPlink repeater is essentially a virtual old man yelling “hey you kids get offa my lawn!!!”. This may seem extreme or perhaps rude to some, but the congestion problem is wholly as a result of the local ISP/Cable providers putting up routers and running them at full power in Auto mode on both bands across the neighborhoods. No need for that. They should be looking at the RF environment and observing responsible channel allocation for each customer.

I had the same problem and stopped trying to connect to my home router. Everything should have worked. Tried with WEP and WPA2 and no go.

yes i have a funny feeling that the chip wifi card is under powered and does not have the wpa2 support worked out yet…

the signal strength is a problem. It only has a chip antenna, so if your wifi signal is weak at the CHIP location it might have trouble joining the network.

WPA2 works fine. But you may want to try a repeater setup close the CHIP.

Chip and Outernet Skylark 4.4 = Outernet can not be joined.
Time to move away from Chip and focus on Raspberry PI 3.

1 Like

I am also not happy with the CHIP. Got it in November. After several attempts changed back to the RPI, which flawlessly works until now.
In the meantime I tried several times to give the CHIP a new chance. Flashing works and mostly the first boot also works. But when putting everything together and installing the setup to its final place I always get a fine WiFi signal but cannot connect to the network.
Last attempt is a couple of days ago with Skylark 4.4 with exactly the same negative result: great signal - no connect!.
In December I ordered a new CHIP from Nexthing thinking my CHIP is possibly not ok. But it is on backorder since then. On their homepage they announce “next delivery Q1 2017”.
Concluded I also would be happy if the RPI would be back to Outernet, because the setup is simple and works and also it is available for everybody.


1 Like

the onboard WIFI on the CHIP is not very good at “listening” for new connections

I think you will find that If you go VERY close to it (a metre or so if possible), it will connect… then you can move a reasonable distance away and it will stay connected with no problems…

I have also managed to use my phone to connect very close to the CHIP and then , whilst it is connected , walked inside to the PC and THEN the PC would also connect… I imagine it like I am carrying the signal inside on my phone :slight_smile:

You could also put a (cheap) wifi repeater as close as possible to the CHIP…

Others have experimented with a USB hub and a USB wifi instead of the on board (crappy) wifi, but I think that creates power issues…

Neil, I really managed to get it running by getting very close to the CHIP with my laptop. After connecting it kept working over a reasonable distance. Interesting, that it showed all received files from another attempt after flashing with Skylark 4.4 last week (and I also could not connect).
I´ll keep playing. The next step will be to get a stable connect to my router and forward the whole stuff to the Internet as I did it previously with my RPI-solution.

1 Like

Neil, you made my day!
System is up and running outside my house and connected via WiFi. http://obereip.selfhost.de/
73s, Wolfgang