Wireless issues with C.H.I.P. board

I just received my Outernet DIY kit. I was able to get it pointed and get a strong SNR. My issue is after being connected via wireless without issue, I left the C.H.I.P + SDR + antenna setup to do its thing. When I came back and attempted to connect my tablet that I was connecting to it before with I was unable to get the wireless to connect. I tried with other wifi clients and I am not able to connect. It is not until I power reset the chip, that I am able to reconnect the wireless.

I confirmed that this issue is repeating for me but I am a bit puzzled as to why it would be happening.

Any Ideas?

Software version:
Librarian v5.0.dev1 / rxos3.1

1 Like

I just got my DIY kit set up last night and the propagation of the wireless signal IS on the low side compared to a normal router.

My actual observations: being 28ft from the device thru a wooden/foam insulated wall (with window) there is no communication with the device. Moving to ~14ft thru the window communication is restored. My setup is a tupperware container mounted to a tripod. The container had droplets of water all over as it rained last night. I will re-test when things dry out.

Was going to inspect the CHIP to see if there is a pad to solder a short antenna or something…anyone know?


The issue I am dealing with isnt a reception issue. I can see a strong signal for the wireless ssid. In-fact I was within arms reach, less than 3 feet away, when this issue presented.

@n1ebe here is an article about the c.h.i.p. and an external antenna.

I got my receiver-kit last week and had the same issues. In the end, I did not manage to connect to the WiFi-Signal at all. After digging out and flashing my Raspberry Pi 3 with rxos it is running a couple of days flawlessly. It also seems that the SNR is somehat stronger now. It shows 4 bars instead of 3 and is mostly beyond 10 dB.
Have a look:


One thing @Abhishek suggested was this

"Oh: one thing you can try is to remove the /mnt/conf/etc/rxos_config.json file and reboot. that should reset all your configuration. "

Not sure if it will resolve your issue, but could be worth a try if you’ve tried everything else

Im suffering with the same problem with the CHIP. It was working fine the first day but now i have no wifi signal, but I have used a Raspi 3 instead of the CHIP and seems to be working… Anyone have a clue how to get the wifi working on the CHIP again ??

Steve (EI2GYB)

could you try a full confuguration reset?

log into the CHIP and do:

sudo rm -rf /mnt/conf sudo reboot

You will have to retune the radio and configure wifi. Let me know if that allows wifi to work. I am trying to narrow down what the problem is.

Little more to report. With things dried out a bit the wifi propagation is about 30-40% better distance-wise. During some of my testing I did have issues getting the system to come up, but it was resolved by cycling the power and pressing the button…if that helps anyone.

Hi. Same problem. Received out of the box kit with the CHIP. Worked well first and thand disconnected from the WIFI. Currently, I can “see” it’s wifi trough different clients, but impossible to hook / log-on. Please any hint? Should I flash the CHIP with new image?


Here’s my experience.

I have found if you don’t power the CHIP device (Lantern or DIY setup) with a 2 amp or more USB charger and a SHORT “quick charge” USB cable, the CHIP’s WiFi acts up by dropping out, not connecting or having too short a range. Additionally, I have found that sometimes inadequate power (charger or cable) causes the Lantern/DIY setup to simply shut down and go into LaLa Land.

I have suggested to Outernet that they provide a “vetted” USB charger and cable as part of the package to preclude this problem, but you can explore this issue on your own. I have a whole box of cables - - but only a few of them work with my Lantern, so go figure. :sob: Ken

I have a 1A usb charger. And I have the battery. I have a 6 ft A-B cable from the chip to the RTL-SDR. It has 4 turns through a ferite core. Then another 6 turns on itself. Dual chokes. Then I have the Radio, a long cable going outside, then the pre-amp and then the antenna.

It keeps my snr at 7-8 unless it is morning when it is 3-4. It cycles.

log it and find your own area.