Beta testing RxOS release 4.0 - Skylark. Link in thread!


#221

I sent my 2 CHIPs and battery to Chicago this morning for evaluation. Since I’ve experienced everything from unblemished weeks of service to many of the problems we have all been seeing reported in this Discussion Group with the Alpha Lantern, it will be very educational when the engineers in Chicago complete their diagnosis of my problems, and report them here. Ken


#222

Question: I would like to pull the radio’s RSSI and SNR to a log file to plot it with GNUPlot or send it to a CSV file to plot in excel.

What is the command line to pull the radio status?

Thanks!

-Cecil
AA5CE


#223

Hi,
I decided to flash mine with Skylark, after V3 kept getting “stuck” on single file an never recovered (it continued to Rx packets but no files ever came from them)… Maybe it was a poor choice, but…

  1. The flashing of the CHIP was a delight :slight_smile: It was the easiest flashing of any device I have ever done! worked first time exactly how it said on the box ( using a windows 7 host for the VM) HUGE Congratulation for that!

  2. The “DIY Kit” setup went straight to work once I took it outside to see the sky. It downloaded one file (the APRS log) and then nothing else… I noted in another thread here that the file that V3 hung on was transmitted straight after the "messages-X.html file… :frowning: - I personally think that something is corrupting the database, but I may be wrong…

  3. and this look to me like a bug … The “Tuner” status stops working and displays the last info… the V3 software NEVER did this… It seems the receiver now lasts about 10 minutes and then just borks… I don’t really know IF it is still receiving packets… I can say that if I ftp to it, I can see that files in the “cache” directory grow (very slowly!) and the time modified is the current time on one of the files… I have no idea what that means though :slight_smile: I have to restart the poor device to make it come back ( often It needs to restart twice ;(

I have noticed that , with the DIY KIt , if I try to connect a (2.4 amp USB) charger to the supplied battery, it will NOT power the CHIP :frowning: The CHIP just flashes it’s light once and goes away… that is a real problem, as It means I can only run the thing on the battery till it dies…
I have restarted it at LEAST 100 time today , BTW ( no exaggeration!!) The only two files I have in the downloads are the two APRS Message logs… after most of the day receiving :frowning:


#224

Yes, this is a bug, and I have resolved it - was quite a chase too :smiley:

While I finish baking the next release, ignore the “frozen” tuner status. The internals are all working fine, and the tuner status should also start working again, after some time (and will randomly start/stop). But packets will keep getting received. So just leave it up. Lets see about receiving the other files. Thats more important to check.

Thanks! :thumbsup:


#225

Fantastic!

Yoram


#226

Hi guys finally got around to updating my Outernet to Skylark.

I am very impressed.

It looks great.

A few questions?

What is the latest version of Skylark.

Will Skylark self update?

Will we have to FEL each future update.

Is there a Skylark user Guide?


#227

Right now there only only one skylark-based release - the one mentioned in this thread. The next release is imminent, it will be announced here.

yep. but not the version from this thread - starting next release.

The next one will have to be FEL-flashed. If all goes well, the ones after that won’t need to be unless you miss large number of updates.

Not yet :-/ Working on it.


#228

Abhishek,

Thanks for the reply. Happy new year.


#229

thanks @Abhishek I was going to ask the same questions :slight_smile:
My break from work finishes next week, so I will not be doing so much experimenting :frowning:
I hope I can flash the new Skylark before I start travelling again


#230

You too! Don’t party too hard! :wink:


#231

This post is both a findings of the upgrade process and a request for hardware help.

I agree with the poster earlier in the thread who said that this was one of the easiest flashes he had ever done. I wish all network equipment was this easy to flash! Nice work on the process, guys!

I upgraded to 4.0 due to some fiddly problems – network connection issues, strange boot behavior (would have to power up CHIP and quickly attach the SDR), NEWS folder corruption and the like. The thing that pushed me over was that after moving the unit, it would only hold onto the SDR and receiver for about 30 seconds following a power-up.

I have just now completed the reboot procedure and Skylark is powering up for the first time!

Again, I keep getting “Your receiver doesn’t seem to have reported in. Err: null” when attempting to access my.outernet.is. Rebooting again with the SDR connected allows me into Skylark (like the new look and feel).

When I go to the receiver section to make sure that I am getting connected properly with the sat, I get noise data for about 30 seconds and then it just quits altogether.

Could I have a bad bit in my kit? I’ve ensured that the antenna, LNA and SDR connections are good. I’ve tried the SDR with and without a USB extension cable to make sure that isn’t the issue.

I did download the VM for VirtualBox and tested the SDR end with that. It continues to search and works fine (I didn’t leave it connected for more then a min or two).

Bottom line, I suspect my CHIP is bad / flaky in some regard. Is there anyway to isolate this further or should I just move on and order a new CHIP or do this on a Pie?

Thanks in advance for any help and support.


#232

This is what is happening to me. It acquires, begins downloading and then stops a couple hundred packets in. I’ve been at this packet level for about 5 mins. now.

I’m at a total loss.


#233

sorry - thats a known bug. You should quickly browse this topic from the top to see couple of other ones as well. Its fixed now (for the next release)

Your receiver is working fine - the tuner status has a bug in that it randomly stops updating the status report. It will also randomly start updating a while later (and repeat). If you want to check the actual status, ssh into the CHIP and run the “sdr” command. follow instructions the command shows you!

Other way is to just leave it be. You have good signal - just wait for the files to come down. A new message file should come down every 5-10 minutes, thus letting you know all is well.


#234

@Abhishek sorry to be that guy. I know better, read the forum and threads. I even remember reading that little number, last night, but clearly it didn’t stick with me until you mentioned it.

This project you guys have going here is fantastic! I am so excited to be a part of it.

Do you have any idea when the next round of 4.0 beta will be available for flashing? The tuner configuration isn’t a major issue in my world, and as you’ve indicated … I just let it be and it’s streaming in content…__


#235

next release is imminent! :wink:

days, not weeks.


#236

The flashing procedure couldn’t be easier. You guys have done an amazing job with the flashing! Cannot wait to see what the next release holds!


#237

Maybe at the top of this forum page as a STICKY you could put these known bugs ect.

ie
Password =outernet/outernet
Push PWR Button after flash.
Tuner locking is normal. etc


#238

He’s not kidding. I’ve seen it with mine own eyes.


#239

Best that you have seen it with your OWN eyes… If you had seen it through someone ELSE’S eye, it would be creepy :slight_smile:

Have a Great New Year , only a few hours to go here in the UK


#240

So, guess I’m missing something:

New CHIP, jumper FEL to ground, run the Outernet Skylark beta flasher on a Linux box and all appears to be well. That is, it gets to the “DO NOT DISCONNECT” stage. LEDs on the CHIP are on at that point, so I wait for a while (minutes) until the one LED starts flashing on the CHIP.

Wait a bit more while it flashes, and ultimately it’s solid on.

At this point, it should be all flashed and waiting for a reboot, right?

I take the jumper off, push the button in for a count of five, and the LEDs go out.

Unplug it from the computer I flashed on, plug it into a different USB cable. LED comes back on so I expect it has rebooted. Wait a bit and look for wireless networks. I can see all of my dopey neighbors’ networks, but no “Outernet”.

Where did I go wrong?