First Skylark OTA features and release info


#41

My system is up and running with no external patches applied. I am wondering if the reboot time got cut short vs the patch time and caused the issue? Isnt there a 100 second reboot in there? Could it have found patches in the /mnt file system and completed them after the boot, that let the system, besides the wifi configs work?

-C

And that look for a device is not happening on the hardware log either. Guess it found it.


#42

This OTA event is really bizarre - - but educational. Some people seem to have a seamless event like you, and some (like me) are dead in the water.

At the end of the day, an OTA update needs to be 100 % - - especially for the remote areas of the world that Outernet is targeting. I know this will all work out in the end. Ken


#43

No, mine was dead, without a reboot or so.

What we should do is back up to the flash and study the ota.

-C


#44

Sorry for the delayed response but because I was a new user I ran out of posts for a bit!

Hey guys, got mine back up and running! After gathering a bit of info I did the same as Neil except I changed mine from hotspot to “Connect to WiFi Router”. It already had my settings. When I did the apply it didn’t seem to work at first so I power cycled. Came back up working just fine. The tuner status page appears to be working again now too. I did NOT try to manually re-do the OTA update.

In regards to the dhcp not working it definitely looks like the dhcp service wasn’t running after the update, here is my evidence:

After update but before I saved the network settings:

[Skylark][[email protected]:~]$ ps auxw | grep dhcp
16199 outernet grep dhcp
[Skylark][[email protected]:~]$

AFTER network settings were saved and system power cycled:

[Skylark][[email protected]:~]$ ps auxw | grep dhcp
325 root udhcpc -n -p /run/udhcpc.wlan0.pid -i wlan0 -x hostname skylark
16749 outernet grep dhcp
[Skylark][[email protected]:~]$

So for some reason the udhcpc daemon was not restarted after the update and for me reboots didnt fix it. What did seem to fix it was as Neil pointed out a 'save changes and restart" on the network controls.


#45

Sorry Ken, I went to bed straight after I posted this & didn’t see you reply
In Windoze.

  1. left click on the wifi Icon on the taskbar, near the clock
  2. Right click on Outernet and select “status”
  3. then from there click on “properties”
  4. in the properties you should see something like " internet protocol V4 (TCP/IPv4)
  5. Click on it ( be careful NOT to “uncheck” the box!) and then click on “properties”
  6. then click on "use the following IP address"
    Then follow the rest of the instructions

I know this is probably too late, but I decided NOT to make a super long list of steps in my first list, so I decided to start at the point where this was open. :slight_smile:
Good luck!


#46

That is normal - the file is only found on the first (automtic) reboot after an OTA has been applied. Other boots it will not be found.


#47

ok. I thought I had fixed this, but clearly not. Thanks!


#48

yeah. Carrying over user config is where I expected all of the issues to come from :frowning:

I am going to make that idempotent. The current way that wifi config is setup is a hold-over from Librarian, and its something I have wanted to do-over, but kept letting other fixes take priority. That came back and bit me. :expressionless:


#49

Thank you - - that worked fine, and I was able to get into Skylark and reset everything.

The only issue here is you can’t follow the above steps on a Windows XP machine. I had to use a Windows 10 machine to do it. My XP doesn’t give me the required option for "internet protocol V4 (TCP/IPv4) - -

Is this protocol simply not installed in XP (such that I can install it from the XP disks), or is it too new to be available for XP? Ken


#50

The "internet Protocol (TCP/IP) you see there IS V4 … it just wasn’t called that before they released V6


#51

I see - - so I just have to assign an IP address and gateway in the normal TC/IP setup on my old XP machine, and then I’ll be OK. I’ll try that later just to make sure.

That said, I got both my CHIPs running with the OTA update now, however, @Syed @Abhishek, the clear cover Lantern you sent me in December will not boot up at all with the new power wiring harness that connects under the cover to what? a solar cell - - I havn’t paid much attention to that. I don’t know what is under the cover, but whatever it is, it just kills the bootup.

Additionally, I found that if I go back to the HotSpot mode (which I do when I travel to get on different Wifi nets), I have to run @neil Neil’s routine again. Can the Wifi connection be simplified in the next OTA update? Ken


#52

@CRCasey, you did nothing? Just rebooted again and let it be?

After uploading the OTA it went through the process and Skylark v1.2 was displayed on my browser after reconnecting to the Outernet hotspot. The guest login worked and so did the original.

BUT … There was nothing on the tuner status screen. I never noticed whether the LNA LED was lit but I rebooted manually after a few minutes.

Now the hotspot won’t even accept clients (won’t authenticate) and the LNA is not started either. :frowning:

Any ideas?


#53

Basically same state I am in. What is the answer? Shall we go ahead with a re-Flash?


#54

All I can say is that once I totally powered off for the second or third time the errors I was getting just went away. So then I was able to set a static IP on my laptop to access the outernet wlan and put my settings back to router mode.

From that point everything was normal again. I have since added a user script and re-enabled the hardware PWM module.

-Cecil


#55

I had to recover my CHIP using the serial port. When we had to lose our password anyway, it might
have been better to just reset the whole thing to defaults during this update (remove /mnt/conf/etc), as
that is what I had to do to fix it.

Anyway, I like the new guest user. I changed the password of the outernet user and now I can put the
receiver on the HAMNET again and give other radio amateurs a peek at Outernet.

I would like a bit more logging at the application level and larger initial windows sizes on the webapp.