Skylark 5.7 for Dreamcatcher 3

I can get in fine using the guest login, but the othernet admin with your password says login errorimage

image

The login should be othernet, password j7m*2 sorry for not being clear on that. I don’t know why is isn’t accepting it, that is what I am logged in with. Perhaps part of this anomaly?

Yes - - now I can get in fine. You look fine with the admin login. I just logged in OK. Ken

Hi Ken, it behaves exactly as my setup, the rotating plus appears when entering the tuner-app and remains blinking until i close the app. With the other apps it shows only short while loading.
obereip.selfhost.de

Wolfgang

The apps, when they make a “call” to the Skylark server over wifi, show this rotating “progress bar” indicator of sorts. They vanish when the call successfully complete. Tuner app, for example, makes this call about once every second. The wikipedia app makes it only once, when you open the app. The Log Viewer app makes it every time you click on a label in the left column.

Sometimes while this call is being made, we may experience a temporary connection loss over wifi. That causes the call to fail, and the “rotating plus” associated with that call just hangs around. Meanwhile, an app like the Tuner app might give up on the failed call, and initiate another one. Everytime this failure happens you accumulate another “rotating plus”.

These are really just showing failed calls. If too many of them are accumulating, you should check you wifi signal. If you only see them accumulate every once in a while, the easiest way to clean them up is logout and log back in. They serve as a kind of record of wifi connectivity loss.

2 Likes

@kenbarbi
This is what I thought, in the every day processes, but logout and log back in do not erase them. (I remember that this did work previously, but not so on this iteration, apparently). My WiFi: on the 3.05 is only ten feet away from the TP-Link Archer C7 router, the 3.03 is about 40 feet away, both are acting the same way. Previous versions of Skylark did not do this. Any time behavior changes, I like to let you know, in case it can be fixed in a future OS.

Yes now I see what yo mean and understand what Abhishek says
image

Each time the Tuner app calls to the Dareamcatcher for a signal update, then the wheel turns an goes away. I have seen a build up of wheels here, but only when I had a problem such as losing my Wifi too. Ken

@Abhishek
@kenbarbi
I finally figured this out. After Ken had logged in and no trail of rotating pluses was showing, I figured it may be something to do with my browser. I went in and blew away all the cookies, now the extra goodies are not showing. Perhaps they are not rotating pluses, but actually are rotating cookies? Chocolate chip, yum.

2 Likes

Both my 3.03 and 3.05 have run with no interruptions for 7 days. I’d call skylark 5.7 to be a stable version for both dreamcatcher models.

My Dreamcatcher 3.05 arrived this morning. I flashed a 16 Gb card with Skylark ver 5.7 using Rufus 3.8. Using a 3 amp 12 Vdc to 5 V power converter with a 3 foot Anker USB power cord. This is the same model power cord I’ve used with my Rpi Satnogs station which runs 24/7.

Upon applying power the boot light goes through it’s sequence and finally goes out. At one point I saw the Dreamcatcher on my WiFi list but didn’t get a log-on screen when I connected. Reflashed the SD card. Now when it powers up and the boot light goes out there is nothing on the list of Wifi APs with the laptop sitting next to the unit.
After reading some of the postings regarding earlier Skylark versions I figured it might be in a non-AP mode. Pushed button one once and saw LED 1 goes through the correct flashes, the to continuous.
How long should I be waiting for the LED to extinguish? It’s been on about half an hour now, a long longer than the previous cold starts. I suppose the next step would be to again reflash the SD card.
Thanks,
Ken

If you start from scatch, as you did, you should be in the AP mode, and not need to reflash the micro SD card.

Suggest you Power Cycle 3 or 4 times, and see, after each, if the Othernet Hotspot comes up.

If not, do a Factory Reset - - three presses of the PB1 Button. Ken

Thanks, Ken. Cycled power a few times and no Othernet Hotspot. Did three pushes on PB1 and observed the correct LED flashes, and LED 1 went solid and has been solid for about half an hour.
How long should LED 1 remain lit during the various PB1 options?
Ken (#2)

I re read your first message - - Rufus is a reformatting/cleansing program. To insall the Skylark image on the micro SD card, you need to use a program such as Win32DiskImager or Etcher

image

Say again how you wrote the Image onto the micro SD card please. Ken

I used ballenaEtcher to write the image after using Rufus. The boot LED remained on all night so reflashed with Etcher. After 15 minutes the boot LED is still on. How long should a normal boot take? And how long for a factor reset?

@W7KKE

both, regular boot and a factory reset (which is also just a reboot) take less than a minute.

When you say “Boot LED” which one do you mean?

As far as I can tell, I don’t think your board is booting at all. Have you gone thru the user manual ? It explains what each LED does and how it behaves during boot and after boot.

What does your Heartbeat LED look like (Its called HBEAT on the board). It should a a regular blinking “heartbeat” like pattern once the board is booted.

Do you see the LED on the wifi USB dongle light up at any time?

LED1 and a bunch of other LEDs remain lit during early boot (few 10s of seconds) but then switch off (LED1) or switch to their standard patterns (see user manual for description of each). If it is remaining lit for longer than a minute or so, the board is not booting.

You may want to try a completely new SD card. Using Rufus is not needed - it doesn’t help except in some very specific cases. Just write a new sdcard with the image (please share a screenshot of etcher taken while its writing the image), and try booting from it.

Also, its possible the sdcard is ok, but you have a bad power source. But I can’t tell that without more details of how the LEDs behave.

(Also, just to be sure, please download the image again)

Edit: Just noticed you said a 3 foot usb cable. While thats not unreasonable, could you - just for testing - replace that with a short cable? Rpi has a larger tolerance for low voltage from the usb cable (it just throttles itself). Dreamcatcher browns out when theres low voltage - and the main cause of DC not working normally is bad power.

Perhaps this has been asked in the past, but again may be useful. Is there a reason the Othernet folks persist in using micro-usb for the power connector? It is much easier to build a good power source cable from commonly available wire with a coaxial plug, instead of having to purchase expensive USB cables that may or may not work because of the limited current-carrying ability of the tiny wires inside. Is it only because the USB cables are commonly available, or is there another (engineering) issue involved?

Thanks for the info. Yes, I’ve been using the manual. I’m referring to LED 1 when booting.
The power LED is lit, and the heart beat LED is flashing… Tried another re-flash, this time with Win32DiskImager but the results are the same. When I tried a “verify only” after flashing it failed at sector 16384, so I wonder if I might have a bad SD card What are some known good brands of micro SD cards? I’m using a Kingston brand. And I’ll see if I can find a shorter cable in town as the 3 footer is as short as I have.

Ken, something some of us have experienced in buying these cables is the nomenclature. It seems that the heavier (desirable) cables are labeled “charging and sync” cables. DeWalt, FuseBox, and several others make “armored” or shielded cables that seem to be heavier than the less expensive ones.

re sd card:

This is the one I use, and its worked well for me - even though I sometimes burn a dozen test images in a day.

Its primarily because of the availability issue: even non-technical folks either have a microusb charger already laying around, or know where to get one. Most non-technical people won’t know where to even start looking for a barrel-plug power unit.