Skylark Release 4.4


This topic is now a banner. It will appear at the top of every page until it is dismissed by the user.


Flash upgrade worked slick as owl snot! I especially appreciate the “toned down” entrance and exit sounds :slight_smile:


Flash to version 4.4 worked fine on Win 10 machine.
One minor detail, still no icon for Community Content.
Keep up the great work.


Skylark 4.4 Bug Report

One serious bug to report - - the CHIP reset button no longer powers off the Lantern when you remove external USB power and keep the Lipo battery connected. Both my units experience this problem.

When a CHIP reset is required, I must disassemble the Lantern and physically disconnect the Lipo battery. Ken


Is there a way to update by dropping the file on the device like we did from 1.0 to 1.2? I have a MAC and dont have a way to use virtual box


I run Virtual Box on my MacBook Pro and it behaves exceptionally well.


A quick update to this post - - I can reliably poweroff my Lantern’s CHIP and SDR/LNA thru SSH using sudo poweroff as follows:



Been a way for a few days, just got back & flashed the chip without incident…
I copied the community & wikipedia stuff back onto the chip.
Mine still wont “start” at powerup & requires the button to be pressed…


Can this be done in parallels? Will the device update itself OTA? Why can’t we drop a file in a folder like the last update?


Hi All
Meant to mention, Skylark 4.4 seems to work fine on Samsung Tab10 and S5 using Chrome.


@Neil Is it possible this is a power supply problem?


@neil 's problem is puzzling since my CHIP button do not work on either of my 2 CHIPS with Skylark 4.4, and I have to SSH and sudo poweroff to shut down. Nothing else changed here with my setup, and Skylark is running fine. Ken



the CHIP power button functions entirely in hardware - keeping it pressed for ~8 seconds causes the power management IC to physically cutoff the power to the main SoC.

Nothing in software can interfere with it. So I am not sure why your poweroff buttons aren’t working, but it can’t be due to the software. Software has no say in that function.


OK if you say so. I’ll do a test today and reflash 1 CHIP back to the previous Skylark where the button worked, and let you all know the results. Ken


Nope Syed, unlikely.
I have tried multiple USB power supplies and the “ravpower” battery (via USB.)
Also multiple cables (all good quality)…
I have not tried powering it trough the header connector , I just haven’t had the time…
When I flashed it yesterday is the first time it has been restarted for many weeks, :wink:

If I get a chance I will turn my HUGE 30Amp variable power supply down to 5 volts and have a play, but it is not a big priority for me at this stage :slight_smile:


It wouldn’t be “fun” if it wasn’t weird :slight_smile:
If things were too straightforward we would need beta testers !


You are correct @Abhishek both CHIPs have failed. I tried to go back to earlier versions of Skylark on one of the CHIPS, and it no longer Flashes. Fortunalely I still have one CHIP working.

I’ll be ordering 2 new CHIPs today. Thanks for your help. Ken


Ouch .,. I am concerned about the robustness of these wee beasties!!
I have one that has worked “as advertised” (except for booting at powerup!) since before Xmas…


I flashed CHIP to Skylark 4.4–went smoothly.

One recommendation for the flashing instructions PDF–they say to connect the CHIP-in-FEL to the computer using a USB cable. You could add here “to the micro-USB on the CHIP where it is powered” or something, because there are 2 USB connectors on the CHIP and no photos in the PDF of the USB cable plugged into the CHIP. This may be obvious but probably isn’t to someone who has never done it.


Flashed to Skylark 4.4 today and it all went exactly as expected. v4.4 worked much better than v1.2. I was unable to connect to v1.2 (even after following advice from the forums), so I flashed back to v1.0

I like v4.4. The Tuner app seems to update the current file upload better (in v1.0 it didn’t seem to update the current file being uploaded.) Also in v1.0 I seemed to get way fewer files than what other people were getting. After updating to v4.4 the files seem to be coming in much faster.

For both v1.0 and v4.4 I am getting the same SNR of about 6 - 8 dB (depending on weather conditions) (off 144E).