CHIP power supply problem

I´ve just got my OUTERNET set up with the C.H.I.P. computer but I´ve tried to supply power to it using a phone charger, so far…no success at all . It seems that I´m not using the right amount of Amps for the CHIP and the peripherals. Please help!!

The quick answer is you need a 2 amp charger. Phone chargers are usually 1 amp or less. Two amps at 5 volts is a 10 watt charger.

So go to a Five Below Store and pick one up. Ken

How much current is supplied by the charger? If it is an under-powered charger, there will definitely be a problem.

Ken, thanks for the answer, but I won´t go to Five Below until this Black Friday to get deal for $1 or less…just kidding!! Thanks again and best regards!!!

Hi Syed first of all the OUTERNET is such a great idea!!!.
Soon I´ll will take my OUTERNET receiver back to Chile to make some test there. Regarding the power supply issue I´ll do what Ken recommended.

Just received my kit yesterday. I too seem having a power problem. It seam there is not enough out current on the usb port for the sdr. The CHIP runs fine with Hotspot and Web service. With CHIP/SDR/LNA connected I just get one flash from the led and then nothing. I flashed a SD card and connected up to my PI3 and everything works great. I have tried two known good 2.1amp power supplys. I can’t believe that my PI3 uses less power then the CHIP. the chip is non working with sdr/ or no LNA. Any help??? Bad usb port on the chip I believe.

Hi Carl,
When you first power up the CHIP the status led should flash and after that no leds are lit up. If you hold the power switch down, the power and status led should light up. The status led will start flashing for a few seconds and then the LNA led will turn on. That’s how it is for me, is yours the same?

Yes that seam to fix it. I guess I will have to do that each reset. There goes my automation plans… when I power up. I get one quick flash. Then I hold down the piwer/reset button I getc both led lite and they stay lite. About 30 seconds later the LNA lights up. No flashing on the led, just soild. The web interface works with signal updates. No lock yet but it is indoors and we are in Alaska on the border coverage. Will update tomorrow or after the storm passes.

Carl, I initially had thought the same thing re the power supply, but figured out on my own that it wasn’t the case.
It could easily have been a fluke, or caused by a capacitor having a small charge and making it appear that power was pressed, But when I connected power via the gpio header, GND/5Vin, it fired right up for me before I knew it had a power button…
Aside from that, I believe I saw a video where somebody added a wire between the power button, and something else, in order to mitigate the necessity of pressing power…

So now you have 2 leads to try yourself and still automate things.

@Carl_Pajak Do you mind flashing to another version? The requirement to push the button for booting was a “feature”, but in retrospect (and based on user feedback) it should not have been implemented. Skylark does not have this requirement. If you flash to v3.1 of Librarian, it will also not require you to manually boot the receiver.

My outernet setup worked first time on the battery.

As I wanted to run it 24/7 I needed to run it from an AC

I had several 240/5V plug packs and had a frustrating time
getting one to work. All were rated at one amp or more.

It wasn’t until I measured the current required to run the
outernet hardware that the reason become clear. All of the problems came from
the USB leads I tried. The voltage drop in them was excessive.

In the end I made a USB lead from cable with more than four
times the cross sectional area than the usual leads you buy.

This cable is rated for seven amps. Even so there is .2Volt
drop in one metre of this cable.

One only wonders at the wisdom of using 5V for high current
devices. No matter how you try you can’t overcome I²R losses.

5V USB power supplies were meant for low current devices.


This is exactly right. Selecting the right usb cable is key. And yeah, large currents over microusb is definitely questionable. Unfortunately its also the most convenient option these days - everyone has the 5V usb wallwart and micro usb cables.

Best thing to try the highest quality , thickest cables you can find. I ran thru my entire collection and found that the cables that ship with “fast charging” phones had the best performance when used with the CHIP.

1 Like

Is it possible to power Chip by connecting to to the +5v line & Gnd on the long connectors?


I did that for a long while many months ago - before I found some good usb cables.

The “CHG-IN” pin on U13 takes 5.5V to 7V. Note that it has a voltage regulator behind it, so there is some additional voltage drop. While it may work with just 5V you will have much better results with 5.5V-6V.

But need to be careful when using the CHG-IN for power input.

  • do NOT use higher voltage than about 6V - all that additional voltage will generate higher dissipated heat!
  • if you switch the connection by mistake (swapping the CHG-IN and GND, theres a decent chance you will blow your CHIP.

IMPORTANT EDIT: I mean the CHG-IN pin, pin “2” on U13. NOT the VCC-5V pin (pin 3)!

1 Like

Great advice … Thanks heaps @Abhishek :slight_smile:

I mean the CHG-IN pin, pin “2” on U13. NOT the VCC-5V pin (pin 3)!

Do not plug in a power supply on the VCC-5V pin - thats an output, not an input.

1 Like

We don’t want to let the smoke out of the device now do we?
The smoke has to stay inside, as it is what makes all electronic devices work :slight_smile:

Just curious- with all the running dialogue about “the right” power supply, why not make one available on the Outernet store and remove the doubt? I love this concept, but am struggling with all the little gotchas in my mind when I contemplate if Outernet would work for the masses. As a project, us techies can wade through these things. But it also somehow needs to be made as idiot-proof as possible eventually, no?

In the works. the final Outernet receiver is not a DIY kit.

1 Like

I’ve done this three times; same result each time (sizzle and smoke).

@Wirednot You are absolutely correct. The real solution to all of this is to offer a fully integrated receiver, with the proper power cables. It’s all definitely on the list–and actively being worked on.

1 Like