Dreamcatcher 2301 Update Issues

I recently found time to try to get two Dreamcatcher 2301 boards that I purchased over a year ago up and running. Both boards are stamped as follows:


However, when I power the boards up and connect to them, the Device Information section indicates the following:

Hardware Version: 2022.10
Firmware Version 1.0.0
IP Address:

I thought this did not bode well, but I decided to try and update the firmware using the Version 3.9.6 (latest) ESP32S3 Flash Download Tool. I used the Version 1.0.10-20240116 firmware available on github.com. Upgrades of both boards indicated that the upgrade "PASS"ed, but if I connect to the boards, I still get the old Device Information (Hardware Version 2022.10, etc.).

The Flash Download tool indicates the following when I try to perform the upgrade:


flash vendor: C8h:GD flash devID: 4018h QUAD, 16MB crystal: 40 MHz

When flashing, the box next to the status box indicates the following (for both boards) on completion:


Also, in the SPIFlashConfig section, the SPI Speed radio button is marked as 40MHz unlike the instructions, but it seems to match the detected value given above.

So, do I have a proper 2301 board? Should I be using older firmware?

Thanks for any information.


Could you please take a picture of the board?
Did you power cycle the board after flashing?
Is only one board on at a time, after flashing?

I disconnected the board(s) from the Windows laptop after flashing and used the same power supply that I use with an old Version 3.03 Dreamcatcher to run the boards. I only run one board at a time.

After I posted yesterday, I noticed that there was in fact a slight difference between the AP, STA and BT values (the last few digits were different between the two boards).

(Reduced size) photos are attached. The full size photos are over 5 MB apiece.


The quality of the power supply can matter for a dreamcatcher 2301. I tried to use a generic 5-20V USB C laptop power supply from amazon with the dreamcatcher and the dreamcatcher did not work reliably. I switched to a name brand USB C charger and the dreamcatcher was rock solid.

@AL0I Other than not accepting new firmware, is the Dreamcatcher performing as expected?

I ran both boards for about 30 minutes apiece today, and both boards perform the same. Instead of the Packet count incrementing about once per second, the Header Error increments about once per second. The ratio of Header Errors to Packets is about 20:1. The Dashboard reported from about -8 to -10 dB and an RSSI of around 88 during the test period. The File indicator never showed a file name, just Infinity%.

Would it be possible to reload the 2210 Version 1.0.0 firmware since that was what was apparently on it previously?

Could you send those back to me? I’d kind to What is going on with the flashing. I can send you a shipping label. Please contact me by PM.

Since you were confident that the boards should be upgrading, I assumed that I was doing something wrong and tried to upgrade again. Let’s just say that, apparently, I can’t follow instructions. I did eventually get both boards upgraded, and the header errors were resolved by fine tuning the receiver with respect to the Bullseye LNB.

Thanks for your help. I will send you a PM.