DreamCatcher Armbian ... does it contain a Skylark App?

I have a DreamCatcher board that runs the Armbian firmware just fine.

However, it does not seem to work with the Skylark firmware due to a mess-up on my part. I wanted to put it on my WiFi Network, but I messed-up the SSID or password. I’ve tried re-flashing, etc. That’s the subject of another thread.

Now for my question: Is there a Skylark App for the Dreamcatcher board running Armbian?

–Konrad, WA4OSH

No skylark for armbian…

In skylark you can delete the settings folder and It returns it to default and start over… or reflash the sd card…

When I reflash the card (using Etcher), i get the same behavior. The unit appears to be working, but I don’t see it actually associating with my WiFi network. I have not yet looked at what it’s doing with Wireshark.

I will try deleting the settings folder. I have a Linux laptop. I should be able to do that.

–Konrad, WA4OSH

You can always plug into the usb port of the DC and console with mincom on linux or similar app like puttytty on windows. Then make your changes.

I have a raspPi connected to mine 24x7 so I can console at anytime from a different network…


I have putty on my Linux laptop. I’m assuming it’s a serial over USB connection at 9600 baud?

An RPI connected to the DC board makes sense.

I would have hoped instead of trying to lock this thing down, they tried to open it up more. I would have had SSH and VNC running on the DC-Skylark. You always need a solid backdoor. There’s not that much that needs to be secured.

But, I guess they did not think the project could be monetized by hobbyists. Most of the people buying the DC are hobbyists and not people without Internet. I would suspect many, many are hams who are not allowed by their HOAs to put up anything but a satellite dish.

–Konrad, WA4OSH

Skylark was designed to be a robust turnkey system. I actually agree that making it very simple with few entry points was the way to go… just makes it easier to secure and support. Skylark wasnt designed for much modification although I’ve been successful at doing that.

I dont remember the actual baud rates but its pretty easy to work out.

Outernet has some challenges but its a very Cool system and deserves more use for sure…


I understand that the Skylark firmware was designed to be robust and turnkey. It’s locked up and nearly fool proof. I get it. I suppose that Inmarsat does not want an app around that can be used to hack the rest of the satellite service they offer.

I would have thought it would have been possible to build a similar skylark app that would have run under Armbian so that it can can be adapted and expanded to provide more functions. It would have been nice to have an API that allows other daemons or services to be constructed so that something can be done with the data. For example, if you wanted a simple e-mail service or packet forwarding service , or a data streaming service where you would not have to wait for an entire file to be downloaded… Think of the possibilities.

It’s probably 9600 Baud. I’m not there yet.

Agreed. Outernet has some challenges. I see it as a model for what Amsat Phase 4B will offer.

–Konrad, WA4OSH