Dreamcatcher Ethernet

For those who interested about, ethernet connection works out of the box with this under Armbian.
iperf3 shows almost 100 Mbit/s in my test under LAN.


Works natively under Skylark and Armbian operation systems.

1 Like

I happened to already have the Anker AH212 which is a 3 port usb3.0 and Ethernet hub. Using the Armbian 5.27 image. Worked just fine.

1 Like

Zoltan, can you use this to access Skylark right away without getting into its Hotspot. If so, I want to add this to my Draft User’s Guide to Setting Up and Using Outernet Dreamcatcher V 2.03with Skylark 4.4 as an alternative way to connect the Dreamcatcher to ones router network. Ken


… + one…!!

As I recall the original question had to do with powering the DC via the USB port using an ethernet adapter that provided power over ethernet (POE).

Am I correct to assume if your POE router can put out 2 amps or higher thru the ethernet ports, that will be enough to run the DC? Len

Do we know if Skylark actually recognize the ethernet adapter or if it’s only usable on Armbian?

1 Like

Hi Ken,

I confirm that TL-UE300 Ethernet Network Adapter works natively under Skylark and Armbian, tested right now for you guys.


Tested also a cheap CH9200 USB ethernet adapter from ebay, that’s not working natively under Skylark, but working under Armbian (in limited speed due to driver issues I guess, runs around 10 Mbps)

How about the POE issue - - some folks may use it. I’ll make sure when I add the Ethernet adapter to the Setup Instructions that I specify the one that works, and that others may not work. Ken

This is not PoE capable adapter! (I was not able to find such creature…)

I’m using a PoE injector in the lab and a splitter outside where my receiver is, data goes to the adapter, 5V goes to Dreamcatcher micro usb input, works nice. Important to have 5V option on the splitter, as there are different voltage variants out there. I also had to fabricate a barrel to micro usb cable for myself.

My setup:


1 Like

I use these for other things, would work up on the roof for what you’re doing without the custom wiring: https://www.amazon.com/UCTRONICS-802-3af-Splitter-Ethernet-Raspberry/dp/B01MDLUSE7/ref=sr_1_3?ie=UTF8&qid=1510937632&sr=8-3&keywords=poe+micro+usb&dpID=41yrqOTd9zL&preST=SX300_QL70&dpSrc=srch


I bought the TP-Link one as it was cheaper at Microcenter than the other no-name brands. Worked on Skylark first time but the IP details are not reflected on the Dreamcatcher LCD. The LCD states that there is no WiFi and that there is also no IP. This is not the case as a look at my DHCP server tells me about the address and I can connect to the Skylark WWW GUI.

It would be nice if the script that drives the LCD were modified such that it pulled the IP address from the active network device rather than only from wlan0. I’ve had a quick look but am unable to find the script for the LCD.

That’s a good suggestion… My application would be to have it save power with edup wifi usb not installed, or the option to turn off wifi.

The ip address and the shutdown menu are the only uses I have found for the LCD screen.