FTP Uploading to External Storage On CHIP

On the latest Skylark 4.4, I am able to FTP transfer files back and forth to all directories on the CHIP. However, I can only move files from my CHIPs external storage (a USB stick) to my computer - - I cannot send the files back to the external storage plugged into the CHIP. This not a new issue, I had the same issue with both Skylark 1.1 and 1.2.

It appears to be a permissions issue as writing to the CHIPs external storage is not allowd, but I can’t change the external directory’s permissions with CHMOD to allow writing back to the external storage:

Any thoughts on this anybody? Ken


The filesystem for external storage is mounted read-only to minimize the chances of file system corruption. So yes, uploading to external via ftp will not work.

you could ssh in and remount it read-write temporarily:

sudo mount -o remount,rw /mnt/external

then upload via ftp and then switch it back to read-only:

sudo mount -o remount,ro /mnt/external
1 Like

Perfect solution, thank you. It’s those 10 screws again. :wink:


@Abhishek, I finally got around to trying this solution and can’t get it to work. I want to make some MODs on my Rachel .html files now that I got the USB Stick to be fully recognized.

Here’s my PuTTY screen dump:

Using username “outernet”.
[email protected]’s password:

Skylark v4.4 / chip (8ed427f)
built at 2017-02-27 21:18:19+00:00

Copyright 2017 Outernet Inc
Some rights reserved.

[Skylark][[email protected]:~]$ sudo mount -o remount,rw /mnt/external
[Skylark][[email protected]:~]$

I can move files from the USB Stick to my computer, but I can’t write them (or new ones) back to the USB Stick. Ken

New Incites

I did discover a way to change the write properties of the external USB stick by revising your @Abhishek suggestion. The new command I’m using is:

sudo mount -o remount,rw /home/outernet/external

instead of …/mnt/external

With this new approach I can delete files on the USB stick and copy files to the stick ONLY from within Skylark’s File Manager. I’m still not able to use my FTP program to place new files on the Stick when it is installed on the CHIP.

Still a big plus as now I FTP new files to the CHIP’s Download directory and use Skylark’s File Manager to move them to the Stick when the Stick is “writeable”.

What I’m finding though, is my Rachel Program still won’t run correctly on the Lantern (as it used to in the RXos versions). I think this because the new Skylark HTML reader won’t run Java scripts. Ken

More Incites

My problem so far has been the Skylark Reader’s ability to drill down into the Rachel navigation architecture. I keep getting kicked into the wrong http address within the Rachel Modules shown at the bottom of the picture, and they don’t go to the correct files. is my Lantern’s local address on my LAN.

I’m going to load the latest version (rachelusb_32EN_4.0) of Rachel’s USB stick version on an NTFS formatted 64 GB Stick and try again. This way all of us who want to try this will be starting from the same set point.


Is NTFS file structure the only format CHIP can see?

I believe it can also read exFAT on big STICKS and FAT32 on little STICKS. @Abhishek what say you?

Right now, I just put my system back up on the air with an NTFS 64 GB STICK loaded with Rachel. I will see what I see soon. Ken

More Interesting Observations

I could not get my CHIP to recognize a 64 GB FUJIFILM USB Stick formatted exFAT or NTFS.

Instead, I installed a 32 GB FUIJIFILM USB 2.1 Flash Drive into the passive HUB that came with the Lantern. The Stick is formatted FAT32. Immediately, the CHIP copied its entire DOWNLOAD directory to the Flash Drive, and I was able to see other files located on the Flash Drive.

Since the Rachel USB files are only 21 GB in total size, they will fit nicely on my new Stick. I will setup Rachel today as it takes about 12 hours to copy the 21 GB of files. Ken

Thanks for the update. I could not get my 64gb ntfs to work last night either. I will try a 32gb fat32 tonight after work.

My 32 GB Flash Drive files are visible in SKylark 4.4, but when I run the Rachel starthere.html file, and try to go to Rachel subdirectories, I can’t.

When I try to drill down to Art, the CHIP directs me to which can’t be found. The is my CHIP’s router address on my lan. Additionally, with Skylark 4.4, I don’t popup the framed Rachel page as I do below with 4.2.

I re flashed a second CHIP to Skylark Version 4.2, and tried the same thing and was successful.

Drilling down in Art sends me to: which can be found. Again the is the network address for my Skylark 4.2 system. (I have 2 CHIPs running simultaneously each flashed with a different version of Skylark)

My thoughts

Best I can figure is the HTML reader in both Skylark Version 4.2 and 4.4 are the same program, but because @Abhishek changed the CHIP’s external storage file structure (and write protected the external drive), my Rachel program addresses get fowled up, and don’t go to the correct file locations.

Another thing I found is in Skylark 4.4, the external drive (my Flash drive with Rachel on it) stands alone at an equal level with the CHIP’s Download directory. In Skylark 4.2, the contents of the same external drive appear (or maybe are mirrored) within the CHIP’s internal Download directory

Hopefully you or maybe @Abhishek or @zoltan can suggest a fix. I’d like to be able to see Rachel on Skylark 4.4. I full well understand why 4.4’s external drive was changed, and don’t think a back step would be good. Perhaps there is a simple patch we can SSH into our Skylark running Rachel, or maybe a quick and dirty new Rachel Start-Up file we can write. Ken