iPhone / iPad cannot connect to Raspberry Wifi


#1

I have no problem connecting to the Raspberry with a PC however neither iPhone nor iPad work. After the devices attach via Wifi, they try to launch a login page. One can shortly see an Outernet web page giving a 404 error, then the device disconnects with no way to stop that and the Wifi connection is dropped.
Maybe because there is no working Internet connection, Apple devices try to go to some login page similar to what you get in a hotel? That standard login url probably does not exist, so the device thinks the login failed and it bails out of Wifi.

Else, the system is up and running. Just received the kit yesterday. I have 93.33% signal level and a data rate of 88 kbit (using Galaxy 19 in Southern California). Content is streaming in. So far world news articles from DW along with embedded photos.

Nicely done!

Thanks
Martin


#2

Are you running ORxPi 0.2.4?

If so, I can get someone to connect to mine to see if I can repeat it. But not until Monday.

It sounds to me like your explanation makes sense though. Perhaps you could google iPad /iPhone behaviour on a non internet connected LAN as a wider issue?


#3

FWIF, we’re looking it this issue. It also seems to apply to Androids and later versions of OSX and Windows (in that the URL for a supposed login page is opened).


#4

Android works fine for me, also Win7 via Chrome/Firefox and chrome on Ubuntu.


#5

What Android version are you testing with? For me it only appears to be a problem in Android 5.0.


#6

I’m on 4.1.2, and the wife’s phone is 4.4.4


#7

Thanks. It looks like it’s a new ‘feature’ in Android 5.0.


#8

Also, if anyone runs into any information on how this works exactly, please let me know.


#9

I see. Will try to find someone with Android 5 at work too, as well as the Apple fans.

Shouldn’t be too hard in an office of 50+ engineers.

(That’s 50+ in number not age!)


#10

Thanks


#11

Yep, got a colleague to try to connect with iphone, and the wifi drops out almost immediately.

Tried googling the issue, but most of it revolves around configuring AirPort or general internet connectivity issues.

Even tried calling apple technical, but they wanted an IMEI number!