Javascript Errors/other upgrade issues


#1

I upgraded from 5.3 to 5.5 yesterday and the issues keep piling up. I don’t claim to be an expert but for months, I was able to get things to work, now I am just frustrated. First it was the admin password issue but at least I was able to read the news under the guest log in yesterday. I let the system run over night. Now, every time I go to read the news I get a javascript error. I get it on both an Ipad and a windows pc using firefox. From what I was able to find on the forum search, I was supposed to clear the cookies. I have done that multiple times, I still get the javascript error. I was able to read what was in the “What’s New”. I have been messing with computers since the days of 5 1/4" disks but I am not sure why I am having so many problems all of a sudden.


#2

John, I would suggest you re download the Skylark 5.5 .gz file, unzip it, and re write your micro SD card. Then start again.

There are no doubt other ways to attack this, but I prefer brute force :grinning: Ken


#3

That is what I did to upgrade. I downloaded the .dz file dated 1/10/19, unzipped and then used Win32 disk imager to place it onto my micro SD. Using the same image yesterday, everything worked except for the admin log in. It just seems so much more flaky than what it was before. When I used 5.3, I just followed directions and it worked as intended. Now, not so much. I will keep playing with it. If it continues, I will try another SD card but it was brand new when I put 5.3 on it. Thanks for the reply, I will keep working on it.


#4

Just a quickie - - but when you say the “admin login” do you mean you are loging in with User name othernet and Password othernet

Ken


#5

That is correct. By admin, I meant the username and password both being othernet. The user that allows to access the tuner and network apps. I have really enjoyed the service up to this point, I guess it is my turn to have issues.


#6

what errors do you get? Could you post screenshots? I can’t say whats going on without more information.

Are you receiving normally? Do you see fresh news files in your WhatNew report? What does the diagnostics panel say?


#7

I will try to provide more information when I get off of work.


#8

It appears as if the DC obtained a lot of news and multiple APRS position reports during the day. I did have the No More Sessions and the rolling X’s across the top of my screen after a few minutes of reading. I rebooted the DC and then was able to continue on. I will try to take screen shots of issues as the pop up but that probably won’t be until the weekend.


#9

John, a couple of things come to mind which may help you. First the No more sessions issue is a bug that Abhishek is aware of and will fix in future editions of Skylark. In the mean time, I worked out a work around by modifying the Captive portal performance of Firefox. I added it to the top of the Wiki if you have any questions about how to do it. The work around will let you get into Skylark’s AP mode to reset things.

The second has to do with Resetting Skylark’s Configuration files. Doing that sometimes fixes unusual performance issues. Go to the Touch Screen on the Dreamatcher board’s 4th panel, and do a Reset configuration (reboot) The screen is hard to control with a finger, but be patient getting that line to come up highlighted - - but once it does hit Apply.

After you do that, you’ll have to set up Skylark again. This step has helped others upgrading from Version 5.3 to 5.5 getting Skylark to recognize Client Wifi networks, and stay connected properly as you select the different App Icons on the Skylark screen.

In any case, I’m sure Abhishek will have some other ideas. Ken


#10

I did the reset config reboot this morning before work and it seemed to have worked all day so far. While reading through the posts, I saw that some errors were prevented by taking out the data storage card. Is that still applicable with this version? I was going to put some PDF’s in there but if it causes an issue, I can forgo that. Also, I have never really been able to manipulate the weather app. The only thing I have ever seen is wind directions. I am sure that it does more. Is there a way to get a NOAA type radar or satellite image?


#11

With a FAT32 formatted micro SD card, you should be able to put all sorts of files on it. PDFs work fine, MP3 music plays, and .txt documents can be read. You’ll have to experiment with others like .doc, etc. I’m using a 64 GB SanDisk card.

When you external storage card is ready to go, I suggest you power down the Dreamcatcher and plug in the micro SD card securely (sometimes it feels like it is in, but it is a bit loose and doen’t make contact). Start up again, and on the Touch Screen after a few minutes, you will see how much storage is on the card displayed on the Touch Screen. Ken