Lighthouse and ORx development snapshot 2.0.002


#1

Instead of a normal disclaimer, here’s the depcition of a potential outcome of using images posted here:

Just be sure to read everything to the end before doing anything, please. Also keep in mind that these are hot off the press, and not very well-tested. They may not work at all.

Now that that’s out of the way…

This is a snapshot for the upcoming 2.1.000 hotfix release. The list of things that have been fixed includes:

Unicode error causing tuner settings not to render correctly in the settings

When files with non-English names would appear in the stream, the tuner section in the settings would crash and no longer display correctly. This has been fixed in this snapshot.

FSAL indexing not starting when ORx is booted without a tuner

When ORx is powered up without a tuner, FSAL would not be able to connect to ONDD and thus be unable to receive notifications about incoming files. This has been fixed so that FSAL keeps trying to establish the connection until it is successful.

Not being able to select the LNB type in the tuner settings after changing it once

After setting LNB type once, the tuner settings form on settings page would always revert to the originally selected type. This is now fixed and changing the LNB settings should always work.

Incorrect handling of keep_formatting metadata flag

This is an internal change which will manifest itself as previously formatted content appearing with style overrides applied (e.g., wrong page widths, etc). This is because we worked around the buggy behavior from 2.0 release by intentionally using the wrong metadata on content. We will fix the content on final release of 2.1 but in meantime, using this snapshot will render content incorrectly.

Notifications never disappearing

In the previous release, notifications like “N items have been imported” lingered forever. Each new session (e.g., opening the GUI with a different browser or using Private browsing mode) would cause the notification to reappear. In this snapshot a 1-day timeout has been added which automatically clears notifications after the timeout.

System logs download replaced by diagnostics report download

In this snapshot, the system log and application log download buttons have been replaced by a single diagnostics download button (still named “Download sysem logs”) which collects complete diagnostics data from the device including memory usage, network device settings, and logs from key components on the system.

Download links

Lighthouse: http://j.mp/lighthouse-images
ORx: http://j.mp/orx-images

How to update Lighthouse

  1. Copy the .pkg file to USB stick
  2. Rename to wt200.pkg
  3. Plug the USB stick in and wait for all LEDs to turn off
  4. Unplug the USB stick immediately
  5. Wait for receiver to turn on

How to update ORx

In general, it’s better to create a completely new card. If you still wish to update rather than creating a new card, instructions are provided below. We won’t provide instructions for downgrading, as the instructions are exactly the same as for updating.

By using SD card

  1. Download ORxPi-update-2.0.002.zip
  2. Power off ORx
  3. Remove the SD card and open it on your PC
  4. Remove zImage file on SD card
  5. Copy zImage file from the zip file to the SD card
  6. Remove SD card from your PC safely
  7. Put SD card back into Pi

On running Pi

  1. Download ORxPi-update-2.0.002.zip
  2. Unpack zImage file and scp to Pi
  3. Log into Pi
  4. As root, move zImage to /boot/
  5. Reboot

How to restore Lighthouse to stable release

WARNING: While the system software can be restored to a previous release, databases cannot. You may experience glitches after a downgrade.

  1. Download the boot.img file from the download link above.
  2. Download the stable image from archive.outernet.is.
  3. Copy the both the .img file and .pkg file to an SD card, and rename the .pkg file to outernet-rx.pkg.
  4. Power down Lightouse
  5. Insert the SD card
  6. Power up Lighthouse
  7. When LEDs stop blinking, remove SD card
  8. Power-cycle Lighthouse

#2

I did the complete restore with the new boot.img and the outernet-rx.pkg.

System is up and running Librarian v1.1dev1 /Lighthouse 2.0.002 with no apparent problems.

In the few moments after I finished the restore and selected Galaxy 19, I started receiving pages, and my downloads in the Tuner Settings shows 4 carousels downloading jpg, png, and htm files.

I assume I will have to wait to have all the contents downloaded before a page will open correctly, so will check back in while to see how new version is running. Thanks, Ken


#3

FYI, even if content is not in the library, you can open it by going into a folder and clicking on html file.


#4

I tried the new snapshots on a Pi 2, with little success.

I used my Mac to copy zimage onto the SD card as explained. Unfortunately, I forgot to disconnect my tuner and the boot sequence failed and I wound up with some corrupt files, so I was forced to reload the stable release. I then copied zimage over to the SD card (before I had done the initial boot), and the web server did not start (no port 80 available).

I am able to reach the Pi via SSH. I can leave it in this state if you like … so you can have a look at it.

I suspect that if I reload the stable release, let it boot for the first time completely and then copy zimage, I would have better luck. I have to remember that I cannot boot the Pi with the tuner attached.

Cheers,
Brian


#5

Yesterday night I flashed my SD card with snapshot 2.0.002 and booted the Pi receiver with the HDStar tuner connected. I waited for hours but it didn’t boot. Today morning I recognized that the SD card got corrupted. Windows complained that the SD card needs to be fixed for errors.

Then I flashed a brand new Kingston 8GB Class 4 SD card with the same image but got the same result as above.

Following is the list of software that I have been using on the SD card.

  1. SD Formatter V4 - Full Format with Format Adjustment Size ON
  2. Win32 Disk Imager

It seems that while booting the probability to get the SD card corrupted is high. Also, this happens during ‘hard shutdown’.

Today, however, I will test this again with a new SD card.


#6

You may want to try to boot without the HDStar plugged in, then hot plug the receiver . The same thing happened to me - when I booted with the HDStar plugged in, the SD card got corrupt.

It might not be the SD card.


#7

A word of warning about SD cards. I used to bitch about RPi destroying SD cards in the past, but in my case it turned out it was the SD adaptors that were going bad. If you have a card reader with dedicated microSD slot, that would be more reliable.


#8

Can I use class 10 SD cards with RPi?


#9

Yeah.


#10

Ok, so, guys that reported non-booting ORx, can you confirm that you can actually SSH into it even though the web GUI is not available?


#11

I found a bug in the server configuration. Uploading new images for ORx. I’ll update this post when it becomes available. It’ll be in the same folder as before.


#12

I have this card reader. It has a dedicated Micro SD slot.


#13

That’s a decent reader. Did you get card corruption after booting with a tuner?


#14

Its a console msg:

ORxPi v2.0.002 | [email protected]:/etc/init.d> $50lighttpd start -f /etc/lighttpd/lighttpd.conf
Duplicate config variable in conditional 0 global: alias.url
1970-01-01 01:05:01: (configfile.c.957) source: /etc/lighttpd/lighttpd.conf line: 36 pos: 10 parser failed somehow near here: (EOL)


#15

Can you grab the updated image from Dropbox? I uploaded a fix maybe 30 minutes ago.


#16

No, its the original/first 2.0.002 version


#17

Yes. my new Transcend 16GB Class 10 card get corrupted with Pi2 during the boot few minutes ago :smile: . I have no idea how to use this card reader with Pi2.

However I fixed the card using Windows. But after that I can’t format it with FULL FORMAT using SD Formatter. Only can do is the QUICK FORMAT.


#18

I didn’t mean for you to use it with Pi2. Just saying that you can’t be sure the card got corrupted if you’re using an SD card adapter on your PC, that’s all. :smile:

Windows won’t report all the partitions on the card, because it does not recognize them. You can just write the image without formatting the card, and it should work.


#19

No, I’m sure that it wasn’t corrupted due with the SD card adapter on my PC. :smile:


#20

What I’m saying is that, SD adapter itself can go bad, and the system may see the card as corrupted. For example, I had a SD card adapter that had oxidized contacts, and system would keep reporting corrupt partition table.

If you’re not using an SD adapter, then it’s corrupted for real most likely. :smile: