Lighthouse and ORx hotfix release 2.1.000

We’re officially releasing the 2.1.000 hotfix for Lighthouse and ORx.

Before I write about what this hotfix includes, I would like to thank the community members for giving us a hand testing the snapshot builds during this sprint. Thank you! <3

What’s new?

This hotfix includes fixes for some of the showstopper bugs that were uncovered following 2.0.000 release, including but not limited to:

  1. Unicode issues crashing the tuner settings
  2. SD card corrption issues on ORxPi
  3. A few bugs preventing smooth indexing of files
  4. Issues related to selection of different LNB types
  5. Persstent notifications that can’t be dismissed

There are also two new additions:

  1. New monitoring script with enhanced heartbeat data and smaller bandwidth consumption
  2. Enhanced diagnostics data download

Known issues

Intermittent loss of lock

We have observed intermittent lock issue in at least one test Lighthouse. While observng the tuner settings sections on the settings page, you may sometimes se that it says “NO LOCK” and then, after a minute or so resume as if nothing happened. Even though the tuner section says “NO LOCK” the device usually hasn’t lost lock, and resumes downloads in the background. This can be confimed by observing the 3rd LED (one further away from the corner): if it is blinking, it means you actually lost lock, and if it’s not blinking, it means you are seeing this issue. We are still trying to determine why this happens, but it does not seem to be critical to device’s correct operation. If you are seeing this issue, and if you find that you haven’t seen any new content appear in a while, please try restarting your receiver and/or get in touch with us here in the forums.

Monitoring (heartbeat) script does not run

Monitoring may not be running when you boot the device. To find out whether it is running, you can log into your device and issue the following command:

# ORx
grep monitor /var/log/messages

# Lighthouse
grep monitor /var/log/syslog

If it’s not running (you don’t get any output), it is probably missing an activation file (file that tells the script it’s allowed to collect and transmit data) that was never automatically created up to this release, and is only created if monitoring has never run on the device. If you do want the monitoring to run, run the following command:

sudo touch /mnt/persist/monitoring.yes


Pi 1:
Pi 2:

Lighthouse image will be put OTA, but you can also manually download and flash.

A post was split to a new topic: Content redirects to

I downloaded Lighthouse Version 2.1.000 12 hours ago, and I have received only 2 pages so far:

and a tone of “Ghost Tweets”

My Application Log is showing nothing more than Twitter activity as follows:

[2015-12-16 21:36:40 (+0000)] DEBUG Twitter: removing imported file: /mnt/data/downloads/.appdata/tweets/unicefwater-1214.json
[2015-12-16 21:36:40 (+0000)] DEBUG Twitter: importing /mnt/data/downloads/.appdata/tweets/unicefwater-1214.json
[2015-12-16 21:36:40 (+0000)] DEBUG Twitter: removing imported file: /mnt/data/downloads/.appdata/tweets/unicefwater-1209.json
[2015-12-16 21:36:40 (+0000)] DEBUG Twitter: importing /mnt/data/downloads/.appdata/tweets/unicefwater-1209.json
[2015-12-16 21:36:40 (+0000)] DEBUG Twitter: removing imported file: /mnt/data/downloads/.appdata/tweets/unicefsocpolicy-1214.json
[2015-12-16 21:36:40 (+0000)] DEBUG Twitter: importing /mnt/data/downloads/.appdata/tweets/unicefsocpolicy-1214.json
[2015-12-16 21:36:40 (+0000)] DEBUG Twitter: removing imported file: /mnt/data/downloads/.appdata/tweets/unicefsocpolicy-1209.json

I have not restarted my system yet, that comes tomorrow :open_mouth: Ken

Do files show up in the file manager?

Not much.

I should also mention my Lighthouse storage has been increasing all day with many files I can’t find in the files manager:

16 Dec 0830 EST 258.22 MB
16 Dec 1700 EST 471.60 MB
16 Dec 1752 EST 489.20 MB


I have the same question

Can you post the diagnostics log online?

Also, if either of you can forward port 22 on your receiver, we could dive in and take a look at it tomorrow. Please don’t post the IP address here, though, unless you think it’s fine that a random forum-goer accesses your device. Send me a PM or email with login details.

I will, but what/where/how is the diagnostics log, and how do I forward port 22? As an alternative, Branko, you can use a program called Team Viewer to access one of my computers real time, and see everything you need as if you were here. I’ll provide the necessary logon information and password if that would be easier. On my router, the Lighthouse is, and I have Putty installed.

My Lighthouse has remained powered on for 12 hours now with no change in displayed content since 1000 EST when I took a first look, but my disk usage has grown incrementally during the 12 hour period from 258.22 MB at 0830 EST 16 Dec to 541.46 MB at 2003 EST 16 Dec. By the way, all my received Tweets have now incrementally changed from 16 Dec 17 Dec (presumably when UTC clicked over to the new day).

I will not reboot as planned until I hear back from you. In the past, reboots have changed my displayed content which my logs were unable to provide any useful information about. Ken

yes will do. probably after 8 PM SL Time :smile:

Got the TV info. Someone will hop onto your box during the day.

Thank you Branko - - my computer is ready to receive. By the way, my storage show 729.71 M of data in the Lighthouse now, but I have no change in the number of pages, files or Tweets (except the date change on the Tweets).

My Application Log shows constant Twitter activity with lots of lines like this:

[2015-12-17 12:34:32 (+0000)] DEBUG Twitter: removing imported file: /mnt/data/downloads/.appdata/tweets/unicefwater-1214.json
[2015-12-17 12:34:32 (+0000)] DEBUG Twitter: importing /mnt/data/downloads/.appdata/tweets/unicefwater-1214.json
[2015-12-17 12:34:32 (+0000)] DEBUG Twitter: removing imported file: /mnt/data/downloads/.appdata/tweets/unicefwater-1209.json
[2015-12-17 12:34:32 (+0000)] DEBUG Twitter: importing /mnt/data/downloads/.appdata/tweets/unicefwater-1209.json


Guys, we have a snapshot build with some fixes for various issues you’ve mentioned. It’s in the usual place, so if you could give it a try it’d be great.

1 Like

I get Internal Server Error 500 when I try to “Restore Lighthouse to Stable Release” with version 2.1.002 - - with the boot.img and outernet-rx-2.2.002.pkg renamed to outernet-rx.pkg on an SD chip. Ken

I’m sure a picture would be helpful, but I am dead in the water now

I can SSH into the Lighthouse - -what would you like me to do? Ken

Is this only for the LH?

Yes I only tried the LH - - I’m sure if the LH doesn’t, the ORxPi won’t work either.

When my Raspberry Pi is not set as Outernet, I plug a 64 GB RachelPi chip into it and run RachelPi. Ken

Branko, you may want to TeamView into my system again and look at the Lighthouse. I tried to flash the 2.1.002 six times all unsuccessfully. I suspect the Librarian is not running. My Lighthouse is on my router. Ken

@Branko, I updated my ORxPi2 from 2.0.004 development snapshot to hotfix release 2.1.000 by replacing the zImage file. Then I started the server and waited for long time but librarian didn’t start.

Then I flashed a new SD card with the 2.1.000 image but the issue remains the same.

In both cases, the WiFi hotspot gets started.

Here are some outputs.

ORxPi2 v2.1.000 | [email protected]:/home/outernet> ps ax | grep python
402 root     {monitoring-clie} /usr/bin/python /usr/bin/monitoring-client -P /var/run/ -u -k /mnt/persist/monitoring.key -b /mnt/persist/monitoring.buffer -a /mnt/persist/monitoring.yes --platform ORxPi2 --setup /mnt/data/librarian/librarian.json
873 root     grep python

ORxPi2 v2.1.000 | [email protected]:/home/outernet> grep hotplug /var/log/syslog
grep: /var/log/syslog: No such file or directory