Newbie help (pi3 rtlsdr v3 dongle) bias t with L-band Antenna with Integrated Amplifier and SAW Filter?

Hi from the UK.
I purchased the L-band Antenna with Integrated Amplifier and SAW Filter.
I have paired it up with a Pi 3 and an rstlsdr v3.

I have tried briefly to get a downlink I can sometimes get it to 4db and signal 2 but no downloads start.
My icon shows a lock but maybe max is 2 or 3 bars.

I intend to take it in the car and to a clear area but in the mean time–
I have 2 questions
Am I chasing the correct sat - imnarsat 3f2?
does the Ant need power from the dongle I’m told my V3 has a bias T how can I activate it through the pi ?
I would just buy the CHIP but there are non available on the store and it takes a while for shipping.

Thanks in advance Guys

I’m not sure on which sat is used for EMEA, but I can comment that the system needs to sit for some time before you’ll see a download start. It has to wait for the current package push to finish, then it should pick up on the next one. If you’re getting a lock, then you know the bias t is active, you wouldn’t otherwise. In my messing with this exact same setup, I didn’t have to do anything it just worked with the exact components you’re using. Hope that helps!

Method45, your sat for Outernet is Inmarsat-4A F4 (AKA Alphasat), at 25E it covers Eu, ME, Africa and a bit of Asia… the link has been down for the past 2 week but just restored. Its link frequency has also been changed to 1546.25 (see Syed announcement, last night).
You could also verify the t-bias by measuring the voltage out of the dongle’s SMA connector, around 4.8volt, that’s what I get out of my DreamCatcher’s SMA to the active patch antenna.
luigi m

G’day unixp!
advice please… I’ve got a couple of SDRx cards and passive patch antennas which I would like to deploy once I get the Pi’s (on order now). As I am almost totally confused about the various Outernet HW and SW configurations pre-DC/Skylark, could you please tell me what SW/GUI are you running on your Pi setup?

Hi lmantuno, you can download the rxos-rpi3 image from the dropbox below and burn it to a 4GB or larger SD card and then you’ll have the latest SW that’s supported for the Pi I think, its called Librarian. In order to run Skylark, you’d need a CHIP or a Dreamcatcher. But if you have SDRx, passive patch antenna and a Pi3, then you just need to burn and run that image and configure it and should be set. Link to downloads:

thanx unixp (I don’t like to call you a “punk”), that makes it clearer. I’ll get onto it as soon as the APAC sat comes back online.