Problems with Outernet under Raspbian


Trying to get Outernet to run on a Raspberry Pi 3 under Raspbian. I’m a Noobie.

During the upgrade to “Jessie testing” (to be able to use Librarian), everything goes fine until the end. The last line in the terminal shows that “PostgreSQL” is not configured. Is this meaningful?

The demodulator appears to run fine.

However, when trying to run the decoder, an unable to load config error is encountered

Also, an command not found error is encountered when starting the indexer.

Lastly, when trying to start Librarian there is another command not found error.

Some help would be appreciated.



I never run Librarian on Raspbian, so I’m at a loss. @Abhishek Do you have any quick thoughts on this?

No. I can only recommend you try out the official RxOS image instead of raspbian installer.

The raspbian installer is only really something meant for people who want to play around with the internals of the system.

For actual use, its not even close to the official image.

Thanks both. I’ll stick with rxOS which runs fine. :grinning:

You have to install postgresql 5.5. The installer installs a newer version (5.6) but needs an older one.

Can the outer folks fix this in their Raspbian documentation? Otherwise it works fine.

Thanks Charlie.

Unfortunately, postgresql 5.5 seems to be deprecated. Or, I just can’t find it.

Have tried, sudo apt-get install postgresql-9.5 (which is available), but no joy.

Oh well…


@Charlie_nycmesh Would you mind submitting a pull request with the documentation edit?

No problem. Here is the location of the repo.

So has there been any progress on being able to use this with Raspbian on a RPi3? I tried to follow the instructions in document Outernet L-Band on Raspbian which after a while looked like it was working but never received any packets. Just to see if it would help I started over with using the rxos image instead. It worked great with that. Starting seeing packets right away. But I would rather have Raspbian to work if possible, but I am still a novice as far as Raspbian after about 2 years. Slowly learning more and more.


I tried to get this working today, and no joy. Decoder fails every time. Also, Librarian seems to get some errors.