rxOS 3.0/Outernet in a Box r2: Please Update Your Receiver!

rxOS 3.0 has just been released. OuternetInABox has also been updated.

rxOS for CHIP
rxOS for Pi3
Outernet in a Box (virtual machines for Windows, Linux, and Mac)

Unless there are showstopping bugs, there will be no additional releases for the next month. Please update your receiver as soon as possible, as some files can not be received by the previous version. Thanks for all of your support and interest. We are making steady progress.

Syed I am getting 11SNRoccasionally now that I have updated to version 3.00 Library software.

What are the new features of Version 3.0 software?

What new content will it allow?

1 Like

It’s mostly under the hood and has to do with compression. As far as content goes, you should be seeing the following in the coming days:

  • Weather data (from NOAA)
  • News updates
  • APRS feed (hourly)


That’s Great Syed.

If you guys keep this up I do not know where it will end.

Well done.

Library version 3 seems more stable and I am able to run my e4000 dongle on a 5m USB cable directly onto the CHIP. Without needing a powered hub.

HI, I am very happy that you included Weather data from NOAA. Is that means that you broadcast the images from weather satellites ? Thanks.

I am not sure if this is a bug but my Library version 3.0 appears to be stuck on downloading a file at 90%.

Other files appear to be downloading in the background. ie the APRS stuff appears to have come through.

It could be that there were some lost packets, so the file will not complete until the carousel comes around again.

We are broadcasting data we get from NOAA. I’m pretty sure SiriusXM charges $50/month for this kind of service.

Syed I am not seeing any NOAA files coming down, nor do I have a NOAA directory.

Sorry, NOAA is starting on Monday.

Getting a 404 error trying to download the update from the Outernet in a Box link…

Please try this:


1 Like

I guess this is the place to post my problem

Viewing Alphasat from Opatija, Croatia, and alone the Adriatic coast with rxOS Version 2.0 worked fine on my Alpha Lantern. I updated to rxOS Version 3.0 right after it came out, and now cannot receive any signals.

Now I’m in Zagreb with clear sky views and no signal. Since I’m on the move, I can’t go back to a viewing location that worked before to re-verify system performance, and don’t want to send in bogus reception reports.

I had a similar problem when I upgraded from rxOS 1.0 to 2.0 that wiped out my CHIP requiring it to be replaced because I reloaded an earlier version of the rxOS. Unless someone has a suggestion, I’m going to wait till I return home to a know working location and attempt to close a link before I really cry :sob: :sob: Ken

@Abhishek Any idea what might be Ken’s problem? He did a UI-based firmware update.

could you show me the tuner settings shot? and the browser title bar that has the librarian and release versions?

Here it is


there is no signal at all - you need to check if the antenna is pointed right - play around a bit. This is not a software issue.

I am constantly receiving with this sat and software version.

I’ll set my Lantern up when I get back to Washington in the same spot it has been receiving before on Americas and see what happens. If I get no signal, I’ll run the antenna/amp/SDR up on my Windows 10 to verify its performance. I’ll report back in 48 hours. Ken