rxOS failing to install firmware on C.H.I.P - Waiting for fastboot - TIMEOUT

Hi All,

This is a new install of rxOS on a C.H.I.P. I am running virtual box on Mac OS X (vagrant).

CHIP-tools and sunxi-tools installed with no problem.
I downloaded the latest rxOS 2.x from the website.

lsusb shows:
Bus 001 Device 007: ID 1f3a:efe8 Onda (unverified) V972 tablet in flashing mode
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

I run the chip-flash.sh script and it fails:
[ 0.01] ===> Preparing the payloads
[ 0.01] … Preparing the SPL binary
[ 0.01] … Preparing the U-Boot binary
[ 0.31] … Preparing sparse UBI image
[ 0.77] ===> Creating U-Boot script
[ 0.77] … Writing script source
[ 0.77] … Writing script image
[ 0.78] ===> Uploading payloads
[ 0.78] … Waiting for CHIP in FEL mode…OK
[ 0.82] … Executing SPL
[ 3.07] … Uploading SPL
[ 10.23] … Uploading U-Boot
[ 18.66] … Uploading U-Boot script
[ 18.78] ===> Executing flash
[ 18.81] … Waiting for fastboot…TIMEOUT
ERROR: Unable to find CHIP in fastboot mode

The install doc has this section, which I believe is my issue:
There is a note in the documentation:
Note on fastboot and virtual machines
If you are using a virtualmachine (e.g., VirtualBox or VMware), you should be aware that, during the flashing, when the “Waiting for fastboot” message appears, the CHIP will change its USB ID. This means that the USB ID you originally set up while it was in FEL mode will no longer apply, and the guest OS will loose the connection to CHIP. This results in fastboot timeout.

Once fastboot times out, you should reconfigure your virtual machine manager to make the new USB ID available to the guest.

Unfortunately, I am unable to find any example on how to reconfigure VirtualBox to make the new USB ID available to the guest?

Does anyone know how to resolve this when running VirtualBox on a Mac?


I don’t know how to resolve this (and I run Windows anyway), but I wanted to comment that the current version of rxOS is 3.1.

Typo, I meant to say Latest 3.x version. I wish whoever wrote the note had posted a link to the resolution. :slight_smile: