SDRx Windows usb drivers (help needed)

Evening all.

A couple of weeks back I asked if anyone had tried an active usb with sdrx, long story short I ordered one and it arrived yesterday. I tried it out last night and it worked for a minute or so before either sdrx or the drivers stopped playing nicely.

Now every time I plug the sdrx in with and without the active cable I get “usb device not recognised, device descriptor request failed.”(Code 43)
Pretty sure this is a driver issue as windows is listing sdrx under usb controllers so I know it’s not completely dead. I’ve tried running the solutions I found via google but unsurprisingly haven’t got anywhere.

At a guess, I need to assign the bulk-in profile/drivers to it through device manager although i’m not sure to be honest and thats pure guess work so I could be barking up the wrong tree. As you can probably tell drivers aren’t my strong point so any pointers would be really appreciated

Follow the directions here:

Since you are working with drivers it is a good idea to reboot before and after the guide.

Appreciate the link but unless I’m missing something it doesn’t help. I followed that guide when I was originally setting up but now rather than having the sdrx show in the drop down box as either rtl or bulk in it shows as

unknown usb device (device descriptor request failed)

Driver (NONE)
USB ID 0000 0002

And if I try to install the driver on that Zadig throws up an error stating “The driver installation failed” and “resource already exists”

OK, you can uninstall the current drivers and start over. Just right click on the device in device manager and click “uninstall device”. Then try Zadig again. You many need to reboot or reinsert your sdrx to get it visible again. Another thing you can do to give me more information is take a screenshot of the driver details window (right click device, properties, driver tab, driver properties. I had this problem with another RTL-SDR I have and these are the steps I followed to resolve the problem.

I’ve gone through that cycle maybe 15 times and can’t get it to “be recognised” as anything other than unrecognised. Zadig fails each time too but I feel like that’s not the problem and more of a byproduct of something else being amiss

Try it on a different PC to rule out a hardware fault.

Which Windows version are you using?

If you plug in the SDRx board can you use the USB HUB feature of it (try with a pendrive plugin into SDRx USB socket)?

Windows 10 pro 64 bit.

Same error on a second windows computer and no response on either usb port but the power led still lights up lol. Syed seems pretty sure it’s fried and I’m inclined to think the same way

Hmmm… yeah, USB chip is a very common Microchip one, all PCs should instantly recognize. If that not happens then possibly the usb connector or hub circuitry gone wrong…

There should be one micro usb connector and one USB-A connector on the SDRx (it may vary from lot to lot) If you have an alternative usb input port could you please try reaching the board via that too?


Some progress.

Different usb port on the win10 machine, changed to the usb micro for usb and power, device shows up in Zadig, drivers showed up first time, reinstalled them just to play safe, went through fine

Opened up sdr#, sdrx shows up as “generic rtl2832u oem (0)” and all seems good until I hit start where it runs for a split second then stops again, last a touch longer without the patch antenna connected but still stops within a couple of seconds

Hmmm… very strange. I would say lack of power on the USB 5V lines. Basically the SDR part is the energy hungry on the board so logical that when it starts (SDR# starts) the whole collapses.

I think you already checked and have sufficient powered USB (HUB)? basically standard 500…1000mA USB port will do.

On the other hand if all your USBs drive enough current then perhaps the SDRx board has some connector / soldering etc. issue which adds some series resistance into the path.

Not sure how or why but cycling sources in sdr# seems to have solved that hurdle. Next one is a pretty obvious one but that can wait till the morning. Thanks for everyones input!

Great! Let us know if this a “permanent heal”!

Looks like all of your slid buttons turned to zero (right side of your spectrum plot) this is why not seeing any spectrum line also waterfall is effected by that. Move those offset and range sliders into closer to center.

I had it receiving through sdr# with those settings for a second before it stopped working and came up with the usb not recognised error again. I’ve tried all sorts, different cables and pc’s, I sdrx has definitely got a fault somewhere along the line as I have another sdr dongle thats working fine with those cables