Skylark 1.2 feedback

Please help me out with your feedback for Skylark 1.2.

It seems the OTA did work, but messed up the wifi settings. So reconfiguring that might work for some of you.

If OTA did not infact work (or if you are on Alphasat, and the OTA did not even reach you), then you can snag it from:

It’d be a great help if all of you could download this file (do not extract it), and then in Skylark file manager, open “opaks” folder and then select “upload” from file menu. Then select this file, upload.

Once the upload completes, if you now hit “refresh” from the “View” and confirm that the file vanished.

Then hopefully its the regular ota process - about 7 minutes worth of wait and then a (automatic) reboot.


I did the manual update from the file mentioned above and now I am locked out.
The WiFi switched back to AP mode but without DHCP server, both my laptops cannot connect to it.
(my Chromebook cannot connect to networks without DHCP server, an old Windows XP laptop with
a RaLink WiFi stick does not appear to even attempt to connect, no error message. setting a fixed
IP does not resolve it)

How do I recover from this? I do have a TTL->RS232 cable, can I fix it from the shell?
Or can you send another OTA that will fix the WiFi problem?

yes, it should be fixable from the shell.

Easier would be to hookup the microusb to a PC (preferably linux), and you should be able to access the UI over the usb-eth emulation ( would be the receiver IP over usb-eth).

But first, could you try just rebooting once again?

edit: also, if its just DHCP that is missing, maybe manually configuring an IP will allow access temporarily?

I already tried that (reboot) but unfortunately it did not work.
Can you indicate what is wrong in which file? Then I should be able to fix it using vi…

I can’t tell - there is no reason for dhcp to not come up. But you could simply do the equivalent of a factory reset:

rm -rf /mnt/conf

edit: you can also access ssh over the usb-eth, that might be easier to use vi over.

OTA seemed to work - downloaded and rebooted in the time-frame you specified. However, wifi didn’t connect. Outernet hotspot was detected and I tried several times to connect but always timed-out. Rebooted a couple of times as well but didn’t resolve anything.

I then reflashed Skylark 1.0 and based on your instructions, downloaded and installed the upgrade file and was then able to connect to the hotspot and reconfigure back to my wifi.

I have a second unit with Skylark 1 which could be used to retest the OTA but maybe after the wifi issue is resolved.

Richard Schreiber



On the second try with the fresh flash - did you reconfigure the wifi at all before updating?

I am experiencing the exact same issues as pe1chl. In fact I am guessing it may have retained the Wifi configuration because I did see it connecting to my AP, but then it would never pull an IP address. Now it has switched over to AP mode and I can connect but cannot get an IP. It seems like dhcp both client and server may have been killed. I will try to manually IP my laptop and see if I can get in.

ok. so dhcp seems like a common issue both in AP and Station mode.

you did a manual update?

I have to get back in somehow first. I will try to address my laptop, and if that doesn’t work I will try the USB connection.

I reflashed then downloaded the v 1.2 file and immediately updated. Once I logged into Skylark 1.2, I then reconfigured the network. I noticed that my access point and password were still present but it had defaulted to hotspot.

I am sorry, I have to be away from the forum for a few hours, to handle the Alphasat issue.

Bit of a mess today :expressionless:

1 Like

I manually addressed my laptop and I can get in. Should I go ahead and push the manual update,or is there something you would like me to try. It shows it was updated to 1.2.

Some suggestions while Abhishek is out…

if you feel like troubleshooting, SSH in to the CHIP and run the following: ps auxw | grep dhcp

Paste the output here please.

Also run: ls -al /etc/init.d/

And paste the output here please.

Otherwise just reconfigure your WiFi with the settings you want. Hopefully that will kick things in to working properly.


[Skylark][[email protected]:~]$ ps auxw | grep dhcp
16199 outernet grep dhcp
[Skylark][[email protected]:~]$

[Skylark][[email protected]:~]$ ls -al /etc/init.d/
total 33
drwxr-xr-x 2 root root 4096 Jan 1 00:00 .
drwxr-xr-x 1 root root 100 Jan 1 00:00 …
-rwxr-xr-x 1 root root 849 Jan 1 00:00 S00setup
-rwxr-xr-x 1 root root 544 Jan 1 00:00 S01logging
-rwxr-xr-x 1 root root 1630 Jan 1 00:00 S10udev
-rwxr-xr-x 1 root root 2080 Jan 1 00:00 S11remotesetup
-rwxr-xr-x 1 root root 1321 Jan 1 00:00 S20urandom
-rwxr-xr-x 1 root root 359 Jan 1 00:00 S40network
-rwxr-xr-x 1 root root 3066 Jan 1 00:00 S45ifplugd
-rwxr-xr-x 1 root root 1063 Jan 1 00:00 S50dropbear
-rwxr-xr-x 1 root root 841 Jan 1 00:00 S70ui2service
-rwxr-xr-x 1 root root 600 Jan 1 00:00 S70vsftpd
-rwxr-xr-x 1 root root 462 Jan 1 00:00 S80dnsmasq
-rwxr-xr-x 1 root root 706 Jan 1 00:00 S80ubihealthd
-rwxr-xr-x 1 root root 544 Jan 1 00:00 S90cleanup
-rwxr-xr-x 1 root root 1016 Jan 1 00:00 S90ondd
-rwxr-xr-x 1 root root 1565 Jan 1 00:00 S90sdr
-rwxr-xr-x 1 root root 824 Jan 1 00:00 S99incrond
-rwxr-xr-x 1 root root 406 Jan 1 00:00 S99led
-rwxr-xr-x 1 root root 850 Jan 1 00:00 S99motd
-rwxr-xr-x 1 root root 1568 Jan 1 00:00 S99netguard
-rwxr-xr-x 1 root root 1380 Jan 1 00:00 S99remote
-rwxr-xr-x 1 root root 513 Jan 1 00:00 S99user
-rwxr-xr-x 1 root root 423 Jan 1 00:00 rcK
-rwxr-xr-x 1 root root 355 Jan 1 00:00 rcS
[Skylark][[email protected]:~]$

Darn I wish I was at home to look around. It must use dnsmasq as the DHCP server.

Try this: /etc/init.d/S80dnsmasq restart

If that doesn’t work to fix DHCP, then try: /etc/init.d/S40network restart

That will reset all networking, which may bump you off the CHIP for a few seconds.

I can help more in a few hours when I get home.

I fixed this WIFI issue like this
After connecting to the outernet hotspot

  1. Opened the config of the IPV4 on the WiFi on my PC
  2. change it to NOT use DCHP, but manual settings
  3. set the IP as
  4. set the mask as
  5. set the gateway as
  6. in my browser I went to and the page appeared
  7. Logged in as outernet
  8. went to “Network” in Skylark
  9. changed NOTHING as the settings were OK for me
  10. clicked “Apply & reboot”
  11. Set my local wifi back to DHCP
  12. waited for the CHIP to reboot , and connected to the outernet hotspot
  13. connected to in my browser like normal
  14. there is no step 14!

I hope that help the confused out there… :wink:


Before following @neil’s instructions can someone that is still broken grab a copy of the /mnt/conf directory for analysis? Just do: tar -zcf /mnt/downloads/things.tgz /mnt/conf

After downloading it to your PC, remember to delete it from the downloads directory. Also, please don’t post it here, just hang on to it as I think @Abhishek will want it to help see what happened.

I am not familiar with usb-net. How would that work? I connected the CHIP to my Linux machine
but there appear no USB messages in the logfile and I see no new devices in lsusb. I also see
no new network devices. Of course there is no route to This apparently requires more
preparation… the VM used to flash Skylark 1.0 worked fine, it detected the CHIP. Maybe that can
be used as a host to access the usb-net?