Skylark Release 4.4


#1

Skylark Release 4.4 is up on archive.

https://archive.outernet.is/images/Skylark/V4.4/

This is a flash-only release. New features to watch out for:

  1. New “Messages” app - messages from multiple sources - APRS, twitter, SMS, possibly
  2. New Reader app: pdf, odt, odp, ods, epub, markdown, mp3/mp4/ogg/oga/ogv
  3. “outernet” user password setting in Network app.
  4. hostname configuration in network app. Now you can access the receiver as http://hostname.local
  5. nand flash data corruption fixes
  6. logging fixes
  7. wifi config cleanup
  8. fixed 404s in News and Wikipedia apps
  9. config wipe feature (say, if you forgot the password) - removes all config, but keeps data
  10. lots of other bug fixes

Release number bumped from 1.2 to 4.4 to align with the build versions.


#2

#3

Flashed the 4.4 image a few minutes ago. Booted and working fine in Firefox. Receiving outernet data and connected the CHiP wifi to my AP. Thanks!


#4

Clean flash. No issues with upgrade.

Set up the connection to my router with no problem, password change on the outernet user was good as well. Connected to 98W and downloading packets.

-C


#6

Easy peasy

We have a Green Balloon over Washington running Skylark 4.4 Ken


#7

I MOVED THIS TO ITS OWN THREAD IF YOU WANT TO REPLY.

Hey guys, I am having issues with the flash, but I think it is procedural for my setup at this point. I can move to a new thread if that is better. I have never tried to flash the chip before so this may be easy. I have the VM loaded, I think I have my chip jumpered correctly (can I tell?) and I plug in the CHIP, then start the VM. The VM says it never finds a CHIP in FEL mode and eventually times out and drops to the shell.

I see a USB device listed called “Onda (unverified) V972 tablet in flashing mode [02B3]” so is that it? When I look at the USB settings I see that there is a “filter” set to “CHIP FEL Mode”. Should I add a new filter for the device I mentioned above? (I don’t think that will help because when I tried it the created filter was identical except for adding a “revision” number) Have I done something wrong? I didn’t load any drivers in windows 10, but then again it didn’t ask me to. I do see a device that doesn’t seem to have a working driver loaded in my win10 device list.


#8

Flashing went smooth, but haven’t had time to use the new features yet. However I wanted to point out that if you get the error message in the picture below when clicking apply and reboot in network settings to give it a few minutes, it is working.


#9

Let’s move this to another thread. Would you mind deleting/uninstalling everything and staying from scratch? You shouldn’t need to fiddle with any settings.

The tablet you mentioned is not what you want. Can you take a picture of the CHIP with the paper clip applied?


#10

Did you delete the vm through virtual box? That doesn’t always delete the directory as well. Check to make sure the Outernet flasher directory is deleted and try to import the ova.


#11

Moved to Here:


#13

Sorry for the extra posts. Got a bit messed up there. Flashed ok. Can’t seem to acquire signal or lock. Prior to flash was VG sig and SNR was great. now no lock, RSSI -124, Lock state stuck in search. Note the system messages show up as a screen full of dots.


#14

Did you change the tuner to the right satellite?


#15

Yes first thing checked. Maybe tomorrow will do a re-flash… Re-flashed and same deal. No signal. LNA is on, connections ok…


#16

How do you use the config wipe feature, sounds handy?


#17

config wipe instructions:

  1. You will need the same piece of wire/paper clip you use for FEL flashing.
  2. poweroff the CHIP
  3. Connect the piece of wire between pin 13 and GND. Pin 13 is XIO-P0. Its the 7th pin from top in the same column as the FEL pin (the FEL pin is the 4th pin from top). GND is the last pin in the same column.
  4. Power up the CHIP.
  5. CHIP will run thru the normal boot sequence, which takes 30-50 seconds normally. At the end of it, the status LED may blink once or twice. CHIP will clear all the config (passwords, wifi config, tuner config), then power itself off.
  6. Once the CHIP has powered down completely (both POWER and STATUS LEDs are off), remove the piece of wire you connected in step 3.

Thats it. Config wipe is done.

edit: It’d be great if anyone who tries it can take a picture of the connection, similar to the FEL connection picture in the Flashing Instructions, and share here.


Skylark 4.4 Network setup?
I cant see the network name "outernet"
#18

I thought something like this could be done. Thanks I will have to try it out later.


#19

Here you go.


#20

Thank you!

Did it work for you?


#21

I took the picture for you because I already had it in front of me, just moved the jumper. I didn’t try the reset yet, still trying to get my flash VM to work, see my other thread.


#22

I did a wipe and re-flashed. Operator error as I selected the sat but didn’t see the apply button at the bottom of the page. Bang-head! Working well now.

Reporting the Log View, System Messages shows a screen of pixels.