SNMP Support in Skylarc?

Hi Everyone,

i currently Setting up some Monitoring for my Network and i would like to know if Skylark has SNMP Support build in.

Would be cool to add it to my Monitoring :slight_smile:

Manuel DO5TY

Any option to add/enable or install snmp? @Syed @kenbarbi @abhishek

No, SNMP is not available on Skylark.

That’s sad, any Option to install it or add it to a future skylarc image? Would be great to monitor the Dreamcatcher

But isn’t Skylark just a Linux build? Why can’t we simply 'apt-get install snmpd"? or whatever the package manager command line is?

i tried apt, but nothing. is there even a package manager?

1 Like

No apt manager. Very limited set of tools in the root kit. I was able to ssh, switch to superuser (sudo su -) and vi to change othernet profile permissions, but that was about it. I was also able to FTP into the files. That makes me hopeful that I might be able to dump an appimage into the usr section and get wget or aptitude installed. Then I’ll have to find out how to vi some repositories.

ssh and soon is easy, it’s even in the instructions :slight_smile:

But jeah, seems very limited :frowning:

I took a quick look at the rxOS website that Dreamcatcher is built on. AFAICT we are on a hiding to nothing. The only way we can do this is to compile our own version of rxOS with the tools that we want. That might not be too hard. I think the current sources are available so we can hack away at it.

But, other than LAN/CPU/disk/processes etc what are you hoping to get out of an SNMP connection? I don’t think that the data download will give up anything in terms of stats unless someone is able to write a MIB for it? So really all we can tell is that the Dreamcatcher is still alive on the network. OK, great. So we can turn the widget green on the Nagios terminal. We could do that with PING already.

1 Like

Well i wanted to have a look at CPU Load and other Stats. As it seems it is just to complicated, so i have to be happy with a simple Ping and with no stats sadly. Hoped it would be as easy as on other Linux boxes with a quick apt-get or just a short Change in a config to enable it.

I dont have mine available but SSH in and uname -a your Dreamcatcher.
You can either build for that kernel from source or find the bins already compiled and try to run them.

I found this doc that explicity says we need to recompile the sources to add packages …

No build tools
As mentioned under the previous heading, rxOS is built as a unit. It is built on a standard Intel PC and then flashed to a device. Because of this there are no build tools on the device. Adding your own programs to the image is done by rebuilding the image the same way it was originally built (a short guide on that topic can be found in the Building and customizing the image chapter).

Now that we are off the CHiP platform and onto our own hardware with an SDCard for storage we no longer have a space issue. Perhaps a which list of packages might be in order?

I’ll start the list with:

PacMan (or similar package manager)

Just looked at the pdf, that said I have worked around embedded images like this for many years.
If the kernel and CPU it is compiled against are correct you can remount s snapshot the ‘firmware’ image as a rw filesystem on your computer and dump an executable file into the path and unless it has deps it will run once you turn the rw filesystem back into an image file and boot it up on the Dreamcatcher.
My guess is if you grab the deb from Debian ARM and extract the executable it will run just fine if you add it to a bootup script, assuming dependencies are not an issue.
This is also assuming SNMP or whatever future searchers want to add is worth the effort.

edit(I did no work to match kernel versions)
there are deps so some work would be involved, especially since it wants perl; see this for an example
even in that one package there are quite a few files to hand install