Troubleshooting lack of signal


I bought patch antenna, LNA and RTL-SDR dongle from Outernet via Amazon back in October 2016; I’m using with it an Rpi3 with the Outernet image.

Unfortunately I’ve never been able to get it to work. I had always thought it was just my positioning it wrong, or being impatient, but I had a couple of hours today and check it I’m fairly sure I have it pointed correctly. I’ve let it idle for several hours and it hasn’t picked anything up.

I’m hoping someone can take a look at what I have here and let me know if I’m doing something grossly wrong, of if it does seem like an issue w/ my HW. I’d also like to understand if there’s a better way to troubleshoot which of the three parts of the receiver chain is the problem: Antenna, LNA or RTL-SDR.

To determine positioning/pointing I used a combination of my car/phone’s compasses as well as the sun’s position, I then in additionally used my relative position to unique features on the horizon (shape of a nearby building) to be fairly sure I’m pointed at 98W.

My LNA is connected directly between the patch antenna and SDR dongle. I have a small ~6" USB extension on the dongle.

My SNR on the Tuner Settings page is always +/- 1dB around 0dB. I’ve never had a signal lock.

I’ve carefully inspected the SMA connectors, no obvious signs of damage.

I’ve tried repeating the test both on the dash (behind windshield glass, which has no metals in it) and on the hood–it’s the same behavior. I’ve also tried other parking areas far distant from this one by this time, so I don’t think it’s something local interfering. I only took the “inside” photos below because it happens to be very cold today :slight_smile:

The vehicle is not running BTW, and the RPi3 is connected to a 2.5A 12V-5A adapter which I have plugged into an 18Ah 12V jump pack (so it’s not running off the car’s electric system).

As it sits on my dash pointed toward a unique feature of that building:

Note the two curved shapes on the building, I’m pointing at the correct curve:

This is the “Sunseeker” app which I use for some solar stuff, but it lets you get a very good idea of your azimuth using the time of day, location and position of the sun:

I’ve also confirmed w/ another augmented reality sat-finder app that I’m pointed at 98W.

what is the zipcode where you have it setup?

is there a light on the LNA ?

02134 (Boston, MA)

The LED on the LNA is lit up

confirm you are pointing at 215.8 degrees azimuth and 32.2 degrees elevation?

Hi ki4its,

I’m fairly sure I am, that’s also why I posted those photos to give a rough idea of what I’m using as my sources of information.

The side-ways image is “sun seeker” which was manually aligned to the sun which happened to be at 223*, the other is a DishAlign app which pretty clearly showed that while parallel to that street I ought to be pointing at the “right most” curved part of that building to be pointed at 97.6W Inmarsat 4-F3.

As for the 32* of elevation, it’s somewhat eyeballed, but yes I think it’s about right. I also used the 3D augment from Dish Align which overlays the satellites on the camera image and things lined up.

ok couple quick things. ensure a very good connection with any usb connections.
second, is that an iphone? if so there is a compass app built in. its in the “Extras” folder. If so, ensure you are pointing where you think you are

Hi ki4its,

It’s an iPhone, and I did confirm using the compass app. I also have an Android phone that gave similar results with the ‘Satellite AR’ app and its compass app.

The USB connections are good–the Tuner page shows nothing if no tuner is connected.

also, please make sure that in the settings menu you have selected the correct satellite from the dropdown

Hi ki4its,

The correct satellite is selected. I’ve even tried switching away and then back to 98W Americas just in case that would reset something.

Thank you for your help with this

Good deal, no worries. Do you have the ability to SSH into the PI?

The next thing to check in the chain is the RF connections. the SMA connector pins and sockets all look good?

The SMA connectors and socket all look good to me, no issues with center pins or any kinking in the patch antenna’s cable.

I do have the ability to SSH into the Pi, I also have Gqrx (an SDR app) on my Mac which I use with other SDR dongles for 433MHz and APRS experiments–so if there is something I can look at there I can do that.

Is possible remove the LNA from the chain or does mean there is no chance of reception? Is there some way to provide power to the LNA if I were using a non-biased dongle? As I mentioned I have several other dongles, but none provide the bias voltage.

Try it outside of the vehicle. Some windshields will attenuate the signal.

please go to your browser and type this in
run the check link

post your results here if you would

and yes sir without the LNA you wont receive enough signal to lock.

Moving on down the line of troubleshooting… Nothing metallic wedged between the driven element of and either the director or reflector on the antenna? no blob of snow between the “plates”?

Have you tried this setup with the CHIP computer? If so, what were the results of that test?

Hi ki4its,

When I visit the link it says

“Your receiver doesn’t seem to have reported in. Err: null”

No, nothing in between metallic or otherwise, and as far as I can see the connection from coax center and shield are good.

I just have the Rpi3, no CHIP … at the time I bought this it was just individual parts sold by Outernet on Amazon, I think the CHiP was still a new option at a time maybe? In any case, RPI3 was the way I went.