Twitter requests via Twitter feed


#1

Just started playing with the Twitter feed and requests. It looks like broadcast requests (just messages) are working great, but file (page?) requests are not there yet.

This one resulted in part of the PDF (~1300 bytes) being saved to the receiver as an HTML file. I just realized it was 180KB so it wouldn’t have worked anyway.

This one seemed to want to work according to the reply I got with the proper file size and name. However, the logs on the receiver show it being received but it never placed the file.

[Skylark][[email protected]:/mnt/downloads/Community Content/Requests]$ tail -f /var/log/messages
Mar 27 01:34:03 outernetkamots user.notice root: Discovered /mnt/downloads/opaks/3c5a-messages-2017-03-27_01_30.txt.tbz2, extracting...
Mar 27 01:34:03 outernetkamots user.info ondd[453]: [carousel] completed: opaks/3c5a-messages-2017-03-27_01_30.txt.tbz2
Mar 27 01:34:37 outernetkamots user.notice root: Discovered /mnt/downloads/opaks/b95d-2017-03-27.Bitcoin A Peer-to-Peer Electronic Cash System.html.tbz2, extracting...
Mar 27 01:34:38 outernetkamots user.info ondd[453]: [carousel] completed: opaks/b95d-2017-03-27.Bitcoin A Peer-to-Peer Electronic Cash System.html.tbz2
Mar 27 01:47:31 outernetkamots user.notice root: Discovered /mnt/downloads/opaks/2304-news-pack.2017-03-27_0143.tbz2, extracting...
Mar 27 01:47:32 outernetkamots user.info ondd[453]: [carousel] completed: opaks/2304-news-pack.2017-03-27_0143.tbz2

[Skylark][[email protected]:/mnt/downloads/Community Content/Requests]$ ls -al
total 52
drwxr-xr-x    2 outernet outernet      1360 Mar 27 01:28 .
drwxr-xr-x    5 outernet outernet     13904 Mar 22 11:10 ..
-rw-rw-r--    1 outernet outernet      3443 Mar 22 10:48 2017-03-22.Creating a RTL-SDR NOAA Weather Radio Audio Streamer in Linux.html
-rw-rw-r--    1 outernet outernet      8292 Mar 22 19:00 2017-03-22.Don???t Make Russia???s Anti-Kremlin Opposition Angry. You Wouldn???t Like It When It???s Angry..html
-rw-rw-r--    1 outernet outernet       607 Mar 22 12:38 2017-03-22.Everything Is AWESOME -- The LEGO?? Movie -- Tegan and Sara feat. The Lonely Island.html
-rw-rw-r--    1 outernet outernet      2681 Mar 22 11:13 2017-03-22.YouTube Talk Hunting Rogue WiFi Devices using the HackRF SDR.html
-rw-rw-r--    1 outernet outernet      4518 Mar 22 10:52 2017-03-22.YouTube Videos NOAA Satellite Tutorial and Building a Radio Telescope.html
-rw-rw-r--    1 outernet outernet      5066 Mar 22 20:44 2017-03-22.welle.io A New RTL-SDR & Airspy DABDAB+ Decoder Available for WindowsLinux.html
-rw-rw-r--    1 outernet outernet       913 Mar 23 15:07 2017-03-23.Outernet.html
-rw-rw-r--    1 outernet outernet      3422 Mar 23 13:46 2017-03-23.Some HackRF Portapack Demos.html
-rw-rw-r--    1 outernet outernet      3422 Mar 24 08:43 2017-03-24.Some HackRF Portapack Demos.html
[Skylark][[email protected]:/mnt/downloads/Community Content/Requests]$

#2

@zoltan @Abhishek What are you seeing on your end?


#3

hmm. the 1300 byte one - yes that won’t have worked. The backend reported an error while parsing it as well.

but the other one: “2017-03-27.Bitcoin A Peer-to-Peer Electronic Cash System.html” is on all the three carousels, about 25KB in size.

Though I don’t see it downloaded on my receiver. Two of my three are down right now due to development work. Looking into it.


#4

The globtechy.com url works now. I just repeated your request, and the file has gone over the carousels too.

Lets see if this one is received.


#5

Yep got the Outernet story. Actually just noticed the wrong reference to Raspberry Pi on their part. Woops.

Bitcoin web page still not showing up but I did see it download again.

You can take a look at my receiver http://kamots.homeip.net:61080/

If you want SSH access I can arrange that.


#6

Oh, its yours? Didn’t know! Thanks for putting it up. Its been my goto receiver outside of my own :stuck_out_tongue:

For now SSH is not needed. I can see the Bitcoin story has not been received by your receiver either. Its still on all the carousels, so looks like a deliverability problem. I will take it down and re up it manually and see if it gets thru.


#7

Its going out right now

edit: done.


#8

Yep looks good. Do you need any logs to see what went wrong? It is strange it shows it extracting in the logs but doesn’t create a file. Maybe in the future the log entry can show the file size of the tbz2 to confirm it received something. Or a hash?

I also noticed the images in the page were dropped. I’m guessing this was to save space?