Beta testing RxOS release 4.0 - Skylark. Link in thread!


#261

This is a long video and I have only watched the first 30 seconds but I think it will show you haw a APRS cable connection to a uhf / vhf Baofeng $25 radio is done. It also mentions briefly the bluetooth option.

I think the Baofeng radios are incredible value for money.


#262

thanks!


#263

Here is another APRS video a bit shorter and he uses a simple cable to send aprs messages only. No receive capability

https://www.youtube.com/watch?v=8-9_8HVkvgc.


#264

Here is a genuine connector which are way to expensive. It is very easy to hack together a bluetooth headphone/ microphone set instead
.


#265

I have to pop in here, in case you start to play with this
I am using a Baofeng here & I hacked together a cable the other day for the PC… I will document it here (maybe tonight my time) but BEWARE… the old “cheap” UV-5R uses a short between the speaker & mic to enter PTT mode, so it is incredibly important that either the speaker cable or the mic cable is 100% isolated to prevent the possibility of letting the smoke out of whatever you have at the other end of the cable!! (and going into transmit unexpectedly :slight_smile: )
I had a simple audio transformer floating around and so used that in the speaker cable so that there is no earth from the speaker back to my soundcard… It worked first go LOL!
I have to go back to work now


#266

I am in agreement with @neil

I can speak specifically about the UI…

Positive

  • I like being able to “see” more of what’s going and being more modular and application based.
  • I like the added applications and benefits of being able to see storage statistic, system information and the Weather Application being “backed in.” This should help with not having to send the weather application down the beam – eventually, not having to send that payload and allowing for more news, Wikipedia and community content.

Do Not Care For

  • As @neil mentioned, the situation with the spinning wheels for active actions in the UI. I understand your conundrum and unfortunately do not have any recommendations.
  • I find resizing windows to be a frustrating proposition. I struggle to widen and lengthen.
  • I would like to be able to sort the File Manager by date modified or created.

Found Broken – Calculator

  • When using the calculator application, I cannot use the number keys on my laptop (have not tested with a full keyboard NUM PAD).
  • Other math functions seem to be odd, when using the mouse to key in numbers. I recall division being “flaky.”

Hope his helps and thanks for your hard work. Really looking forward to seeing what the next release will bring to the experience.

~JG


#267

d’oh. No one reported that yet. I am going to check it out. Thanks.


#268

I just went back and reconfirmed.

I can type in numbers using the numbers at the top of the keyboard (I am sure there is a technical term). Addition (Shift + =) takes, and you can key in another number, though = alone will not produce a result. I have to manually click the = button in the UI. Minus works properly, as well, save the =. I did find pressing enter produces a result.

It appears that my testing methodology wasn’t complete. Enter is what produces the result, I’m used to = and enter working on the MSFT version.


#269

I think the area needing some more evaluation is the sorting done within each file area. On computers, you can sort by name, date, file type, etc. either forward (last in at top) or backward (first in at top).

Can’t do that in your file manager tabs.

It would really help in bringing the latest news to the top of the tab, rather than having to scroll down to it. Ken


#270

@ tkepe 194 mentioned this issue too. Ken


#271

@Seasalt Are you a HAM?


#272

I believe it’s been mentioned before up above but just in case, I encountered a “blank” white bug on log viewer and tuner. Eventually it came up as some sort of JS error I believe. This occurred shortly after attempting to view the site on a tablet but that could have been a coincidence. After that point though, no browser will populate those windows mobile or desktop.

Prior to that, I also encountered a stability issue with a random power-off. This occurred after I flipped through the various globe rendering options in the weather app. I went through each of them and then back to the default and seconds later the CHIP just turned off.

Looking forward to the next release!

PS. One more issue, flashing was not so easy given my PC did not have VX-T (or whatever the virtualization is called). I ended up running it on a different PC…inside a virtualized Windows machine Inception style. Not ideal.


#273

Yes KW4QB.


#274

@Seasalt What do you normally use for APRS? I take it that an iGate picks up your packet and sends to Outnet via the internet? Is this the correct path or do you transmit on another freq besides 144.39? 73, KD9BKH


#275

I am in Philippines on a remote Island. I am setting up for satellite APRS.

I currently have APRSDroid android phone app to talk to my Baofeng 8w handheld VHF/ UHF radio.

I have made a 19.5 1/4 wave Ground Plane antenna as per Bob Bruninga, WB4APR APRS website. http://www.aprs.org/ This antenna dimension 19.5 inch is magically 1/4 wave VHF APRS and i think 3/4 or 4/5 wave UHF.

I am currently making the cable to go from my Android phone to my Baofeng radio.

So I will wait for either
PSAT 145.825 Mhz
PCSAT 145.825 Mhz
International Space station on UHV 437.550 Mhz

to come over and then send my APRS messages up, addressed to OUTNET or EMAIL. and they will be digi-peated to the world and relayed back to me on Outernet.

Groovy Hey…

I have not transmitted to a satellite yet but I have left my RTL-Dongle connected to my 19.5 inch 1/4 wave antenna overnight on 145.825 and I have received a few APRS messages from the APRS satellites as they go over. I use GQRX for Ubuntu and its inbuilt 1200 baud AFSK decoder

So far I have only used the APRSdroid internet connection (TCP-IP) function to send test messages to Outnet. It works fantastically.

You need to add some 500 ohm resisters as well and possibly other forms of protection between the radio and phone.


#276

@Seasalt That’s a nice setup you got there sir. I may try to send out a few packets myself when the Sat’s are in my area (Indiana). I actually spent some money on my HT and got a FT1XDR that has a built in TNC. I’m sure I can fab up an antenna or use my Yagi for when I talk on S0-50. My first contact on SO-50 was with with N4UFO on a Baofeng 5W HT (which I still have) with a diamond whip antenna. Ever since, I got bit by the Sat bug and been hooked ever since. Luckily, just me having a Tech Ticket most of this stuff is on 2m and 70cm. I figured I would give Outernet a try and been happy so far. I get kind of bored with it. I wish it had a bit more bandwidth but I understand why things are the way they are. I hope Skylark with make the experience better and can’t wait for the release of it. I hope that there are some new features in Skylark. I didn’t bother doing the Beta testing as I don’t have the patience for it right now. I figure I would wait for the official release so I know that most of the bugs are worked out. The only thing I don’t like is that the weather is a day behind, even though the time and date of the weather is in Zulu by default. I also have noticed that once I get a few weeks of data built up, either the CHIP or rxOS bogs down a bit until I FTP in and delete some data. I don’t think it’s a heat or power issue as I am not on a battery pack for power (2A cellphone wall charger) and my SDR-TRL is well ventilated. I hope that Outernet will evolve and change the way we get our information, and be reliable.


#277

Thanks for the grate reply.

I felt the same way about updating to a possibly flaky beta but I updated a week ago. The Virtual box stuff is really easy as they are sending you a self installing Virtualbox module that you click on and IT self installs in virtualbox. Its fantastic. I have never seen anything so easy. (IN Ubuntu Linux)

Next Skylark is much improved and more stable than the old Library software.

Apparently the new Skylark comes out tomorrow I am going to Update straight away.


#278

@Seasalt I take it that the update tomorrow, Skylark, will be sent over the air? Can I update the firmware via Librarian (update firmware option) or will I have to flash my CHIP via the paperclip/computer method?


#279

I only read in another message from Ken that it will come out tomorrow. My understanding is you will have to FEL flash with Virtualbox which is not a big deal.


#280

That’s correct, @Syed announced it earlier this week. @Abhishek also said the next Skylark update will have to be flashed, but this new version is supposed to have an over the air (OTA) update capability for future changes like the old Ku-band had. Ken