Beta testing RxOS release 4.0 - Skylark. Link in thread!


#21

Thanks @Abhishek! I’ve just bought a CHIP, just waiting to receive it. I’ll be moving to that platform and looking forward to participate in the beta! Thanks again.


#22

Thanks for helping out! Keep watching this thread.


#23

I am in too

Peter


#24

Ok. Beta incoming. This being an open beta, its possible for anyone to try it. But I request that most users skip this for now, and ONLY people who are

  1. comfortable doing FEL flashing, and
  2. are comfortable with linux command line (so they can properly report problems by logging into the CHIP over ssh).

give this a try.

As this is a work in progress, there is potential for messing things up. While FEL flashing ensures you won’t brick your CHIP, its still a fairly technical game at this stage.

Continued…


#25

For anyone joining the beta:

  1. Make sure you read this thread top to bottom, before you do anything!
  2. If you had the DIY kit, you are probably already familiar with the connections. If you have an alpha lantern, unless you are very confident that you can get things back together, best skip the beta.
  3. I have created an empty repo to be used only for bugs during the beta.
    https://github.com/Outernet-Project/Skylark_beta_tracker/issues
  4. While feature requests may also be entered there if the missing feature is preventing reasonably convenient usage, please mark them feature request. We are focusing on bugs at the moment though.
  5. Post in this thread. Keep the thread limited to reporting bugs and discussion on that. Before reporting, check if someone else has not already reported the same.

Contd.


#26

Enough with the buildup :smiley:

Heres the link:

https://archive.outernet.is/images/Skylark/beta/skylark-chip-flash-v4.0-201611240128%2B19942a1.vmflasher.ova

We are first going to validate the flasher itself.


pinned globally #27

#28

For any rPi3 vs CHIP flame wars, please start a new thread.


#29

I have a spare clip too. Sign me up. :blush:

Ken


#30

I was starting to get worried there :wink:


unpinned #31

#32

This topic is now a banner. It will appear at the top of every page until it is dismissed by the user.


pinned globally #33

#34

Win10 as host for Virtual Box.
4:45 to get to flashing LED from starting VM cold.


#35

Unable to get it to flash here with ubuntu. Posted in Git Hub repo.


#36

@thomslik,

try under sudo, as shown in post number 8 above.


#37

Didn’t think I would need sudo as I flashed earlier with Ubuntu after changing rules in the udev config. Tried as you suggested but kept getting: sudo: gnome-open: command not found. Changed command to sudo gnome-terminal open and it worked! Got to go try it now.


#38

no, gnome-open is simply a way to “double click” a file on the command line. sudo gnome-terminal won’t do the same.

if your system doesn’t have gnome-open, just do the “sudo virtualbox” and then import the OVA into virtualbox using the menu.


#39

and yes, you should not need to sudo if you already have the right flashing rules under udev.

try this:

when its on “waiting for fel…”, unplug and replug the CHIP from the usb port quickly.


#40

win 10 + virtual box works like a charm here!

don’t forget to separately install the “VM VirtualBox Extension Pack” too