Skylark 1.2 feedback


#22

It would be interesting to do a before- and after-capture like this and do a diff -cr between them to see
what has changed. I am still looking for a simple way to fix it as I have lost all contact with the device.
(it was a station to my WiFi network but it has not connected and now it is an AP that I cannot connect)


#23

Thanks Neil, those instructions worked for me.:grin:


#24

I created this archive. Had to adjust just a bit, I did a sudo to run it and then had to chmod so that I had permission to grab it. Anyway I cna provide it if needed. Anything else I could grab?

Also I have noticed that the “Tuner” app doesn’t appear to be working properly. I can’t see the status info.


#25

He descargado el archivo, y lo he actualizado desde el ordenador, actualizó bien, me creó el punto de acceso wifi, pero el ordenador no se asocia correctamente, no recibe ip, lo he solucionado poniendo a mano la ip.

Al iniciar el icono del wifi me da un error, y no me reinicia ni me guarda la configuración de red que le pongo.

translation:

I downloaded the file, and I updated it from the computer, updated well, I created the wifi access point, but the computer is not associated correctly, does not receive ip, I have solved putting the hand by ip.

When I start the wifi icon it gives me an error, and I do not restart or save the network settings that I put.


#26

You may have logged in as guest? Try logging in again as outernet like before.


#27

Seguro que es eso, lo pruebo ahora. :sweat:

Sure is that, I prove it now. :sweat:


#28

I can’t think of anything else right now, may as well try neil’s procedure.


#29

Arreglado, era eso, accedí como administrador y todo perfecto, ya está funcionando, conectado al router y descargando archivos de Alphasat sin problemas por ahora. :sunglasses:

Translation:

Fixed, that was, I agreed as administrator and everything perfect, is already working, connected to the router and downloading Alphasat files without problems for now. :sunglasses:


#30

Went static on wlan outernet and applied. Looks okay now.

My /boot looks like this…

[Skylark][[email protected]:/boot]$ sudo ls -la
Password:
total 89844
drwxr-xr-x 2 1001 input 480 Jan 1 00:00 .
drwxr-xr-x 1 root root 220 Jan 1 00:00 …
-rw-r–r-- 1 root root 44569209 Jan 4 14:08 skylark-chip-1701041326.ksop
-rw-r–r-- 1 root root 43700640 Feb 2 18:36 skylark-chip-1702021712.sop
-rw-r–r-- 1 root root 40500 Feb 2 18:36 sun5i-r8-chip.dtb
-rw-r–r-- 1 root root 3680112 Feb 2 18:36 zImage
[Skylark][[email protected]:/boot]$


#31

Looks like it borked more than the wifi for me. Outernet SSID is there, and I can connect by manual IP address, but Skylark isn’t coming up and the LNA isn’t coming on.


#32

Same for me except I cant connect with manual ip either. I am thinking about reflashing and trying it again, but for now I am going to wait to see what happens and charge some lithium cells while I am at it.


#33

After waiting couple days I updated my using file manager. CHIP refreshed automatically after few minutes. I was able to connect to chip wifi no issues, but turner apps I don’t see signal level any more.


#34

I just reflashed Skylark back to the last iteration. Maybe a new flash file will be posted here. Would make it easier to check out the new updates. Then work can begin on the OTA issues.


#35

Ok I reflashed my chip to v1, and then tried the OTA update. Everything worked great until I changed my wifi settings to connect to my router. Then it was completely unreachable again. I am going to try again. @Abhishek The ability to auto backup log files to a flash drive could be useful in these situations.

EDIT: I reflashed and upgraded to 1.2 again and instead of clicking on apply and reboot in after setting to connect to a router I rebooted via ssh. Now everything is working great. I haven’t put it outside yet because I am using CHIP to charge some 18650 cells and I want to keep my eye on them.


#36

You are not seeing the same wifi issue?


#37

When I first tried the update I couldn’t connect to CHIP in any way possible, the LNA light was off. I couldn’t find any other option so I reflashed and tried the update again. everything worked fine until I changed the network settings to connect to router and clicked apply and reboot. I was back to the way I was before, no access, no LNA light. I did the same thing again, but instead of clicking apply and reboot I reboot via ssh. Everything seems to be working fine. The only thing I noticed is the watermark on the in the lower right corner sometimes says v1.0 and sometimes says v1.2.


#38

Try clearing your browser cache. Hopefully it is just cached :slight_smile:


#39

Ya I think that is what is going on. Its only seems to do it on the first log in on a tab then it stays on v1.2. But I am not concerned it will eventually fix its self.


#40

So I had the WiFi issue where after update the CHIP came back in AP mode instead of STA. Fixed by simply clicking “Save and Reboot” on the Network screen, all the settings were still there. Likely an easy fix!

I grabbed the /mnt/conf/ directory from right after upgrade, and again after the WiFi settings were fixed so that @Abhishek can have some more information. One thing I noticed that stood out was dnsmasq was not running even though the configs seem to have the CHIP in AP mode. So it seems the CHIP lands in some sort of half-configured state after this OTA.

I had a very long work day today (18 hours), but tomorrow after work I’ll dig some more and post what I find.

BTW @Abhishek please put back the date/time column on the file manager in the next release. Not sure about other folks but I like to see when a file arrived. This is especially useful when looking in the community content since you can see what is new. Usually the “What’s New” screen is overflowing with News and APRS so it isn’t the most useful for stuff that may be a few days old but hasn’t been seen yet.


#41

File manager has view options. You can turn on modification time.