Skylark 5.6 for Dreamcatcher 3

Basically agree, however, since @Abhishek is beating his brains out to fix this lockup thing, I would reserve judgment pertinent the “older” Dream Catchers until the revised 5.6 has been released and tested.
As to the new adventure, there are certainly a lot of good, fresh ideas coming to the forums every day, we are seeing new ideas that work (satellite pointer), and are looking forward to seeing a lot more! Keep them coming!

1 Like

I just shifted BOTH my 3.03 and 3.05 to the latest 5.6 skylark. I don’t think it is prudent to have anyone run an ‘old’ version and expect it to be supported. I am hoping that everything is solved by doing clean installs (not just writing the image of 5.6 onto an old 5.5 sd card).

1 Like

Here is monday report
The 3.03 on s.l. 5.6 has been just fine,
but the 3.05 on sl 5.6 locked up after these files
Oct 7 01:53:38 completed: opaks/c117-gfs.2019100600_gfs.t00z.pgrb2.1p00.f000.grib2.tbz2
Oct 7 01:53:42 completed: opaks/ddf2-messages-2019-10-07_01_51.txt.tbz2

I can’t figure out the intermittent freezing/lockup – my guess is this buffer queue

Here is system messages error repeated about 500 times
in the same second, but this was 12 hours before the lockup occurred
Both of my dreamcatchers were reporting the same message in “system messages log”

Oct 6 12:49:52 othernet user.err kernel: [349097.407412] rtl_usb: Pending RX skbuff queue full! (qlen: 64)

Then what is even stranger, there must have been some files downloaded but not processed
I checked the what’s new on the one that lockedup and several new processed files arrived
note the entires between 11:31:45pm and restart at 6:24:26am

edit: 3.05 board Lockup again at 13:47 utc … made it only 3 1/2 hours before it froze again
diagnostics after reboot says
Jan 1 00:00:16 othernet user.err ondd[494]: [carousel] index failed CRC

Monday 10-07-2019
My 3.02Q on 5.6 crashed again last night.

Tuesday 10-08-2019
3.02Q on 5.6 crashed again last night.

Caught this in the system log on the last freeze of 3.05 running 5.6

Oct 8 15:31:21 othernet init: starting pid 31754, tty ‘’: ‘/etc/init.d/rcK’
Oct 8 15:31:22 othernet dnsmasq[466]: exiting on receipt of SIGTERM
Oct 8 15:31:22 othernet dropbear[392]: Early exit: Terminated by signal
Oct 8 15:31:22 othernet avahi-daemon[378]: Got SIGTERM, quitting.
Oct 8 15:31:22 othernet avahi-daemon[378]: Leaving mDNS multicast group on interface wlan0.IPv4 with address
Oct 8 15:31:22 othernet avahi-daemon[378]: Leaving mDNS multicast group on interface usb0.IPv4 with address
Oct 8 15:31:22 othernet avahi-daemon[378]: avahi-daemon 0.6.31 exiting.
Oct 8 15:31:22 othernet kernel: [88768.468203] wlan0: deauthenticating from cc:2d:21:6a:80:d8 by local choice (Reason: 3=DEAUTH_LEAVING)
Oct 8 15:31:22 othernet kernel: [88768.528875] rtl8192cu: MAC auto ON okay!
Oct 8 15:31:22 othernet kernel: [88768.577691] rtl8192cu: Tx queue select: 0x05
Oct 8 15:31:23 othernet ifplugd(eth0)[366]: Exiting.
Oct 8 15:31:23 othernet syslogd exiting

note the high pid number in the first line , usually don’t see something nearly 31754

and after re-boot there were about two hours of files “discovered”

This is interesting - - I have had 3 DC v3.05 failures running SK 5.6. The first one (no Web browser access) I recovered from with a simple power off - - then on. The second one (no Web browser access) I had to do a restore to the AP Mode (PB1 Function 1) then get back into my Client Network. The third one (again no Web browser access) restore to the AP Mode did not work, so I had to do a Factory Reset (PB1 Function 3), and all was well after I reset all my parameters to work on my Client Network. The time between failures varied from less than 24 hours to the 2 to 4 day range.

Hope this is helpful. Clear as mud!! Ken

Wednesday 10-09-2019
Another crash of 5.6 on 3.02Q.

Thanks @maxboysdad. We definitely know this is a problem and will have a fix in the coming weeks.

Could everyone tell me exactly what type of power supply they are using for their receivers?

Thanks, Syed. My DreamCatcher 3.02Q is powered with a Chinese buck (6 to 26 volts DC in) regulator connected to a 12 volt brute-force power supply. The regulator provides up to 3A at 5.2 volts DC, very clean DC, no ripple.

My DreamCatcher 3.03 is powered with a GoalZero Sherpa power supply that is either solar-fed, or 110v to DC converter fed. Very clean DC on USB to the DreamCatcher.

Actually, Skylark 5.6 is just an incremental update. The really new and big thing is drastically cost-reducing the receiver and turning it into a finished product. Their are some compromises that come with this, but cost is king. Dreamcatcher 3.03 will always be the most feature-rich of our receivers. The trend from here will continue to be cost, size, and power reduction. That’s the only way we’ll be able to achieve the ubiquity that we need to be successful.

I am using an EasyAcc 20000 mAh power bank to drive my DC v3.05. The EasyAcc is powered from an ICleaver Dual 2.4 amp charger with 2 short high quality cables. Ken


I upgraded to Skylark 5.6 a few days ago on my old 3.02 Dreamcatcher. I discovered the old 5.5 SD card was no longer writable, which would explain no new files for several days. I had to copy the 5.6 image to a new card and start over. There have been no crashes. The diagnostics log currently shows “up 5 days, 21:19.” I do not use an additional SD card for storage.

My Amazon Chinese power supply is a " Yuconn Micro USB with On/Off Switch Main Wall Charger AC Adapter Power Supply 5V 3A for Raspberry Pi 3 Model B B+ & Bose SoundLink Color Mini 2 II (1 x Power Supply) by CheTech.

Thursday, 10-10-2019
Another crash of 5.6 on the 3.02Q last night.

my DC 3.03 also crashed again, but only after 7 or 8 Days so not to bad.

Power Cycle did fix it.

I am trying various sd-card settings since it seems that “update” the boot sector may
be the cause of freeze.

My latest experiment is to (using minitool-partition-wizard)

  1. “wipe” a sd-card by writing zero’s into every memory location
  2. remove any existing partition (make it all un-allocated)
  3. the create a new single paritition that my win32diskmanager will recongize

This time I made the sd-card a single exFAT before writing the skylark image.

If that doesn’t work… I have other options for partitions (ntfs, FAT, FAT12, FAT32, Ext2, Ext3, Ext4, Linux swap)

@Tysonpower We’ve had releases that have run for months–almost a year. A change of office was the only reason the receiver shut down. So being up for only 7 days is a real problem. We are definitely experiencing the problem on our end, as well. There has been a fix that we tested internally, but the problem was not solved.

Apologies for this inconvenience.


This is Linux, can we SSH in and use normal CLI?
What kind of device is the sat feed/lora showing up as, some ttys writing to a file which is scanned and executed by a series of py scripts?

My upgrade to 5.6 failed. In trying to start over fresh the checksums for the 5.6 download don’t match ( nor the one for 5.5 either). While trying to flash the SD card with Etcher anyway, I get a failure due to corrupted file error message.

Please explain.