Functionality Questions

I received my Dreamcatcher a few days ago, thank you for the fast shipping!
I have it setup with an old Dish Network dish and have an SNR of -4 with CRC errors at zero.
Files are coming in and after 12hrs I had a lot of tmp files but no news, messages or uploads folders. My wiki folder had only 3 files in it.
I thought maybe the SD card (32gb) was possibly the issue. Did a fresh format (windows machine FAT 32) on an 8gb card and put that into the Dreamcatcher, used the Dreamcatcher utility to format the card again and rebooted (dashboard reboot button) the Dreamcatcher after the format completed.
Now it has been running a couple hours and I see lots of temp files but only the log folder and temp folder.
I see files coming in for wikipedia/ but there is not a wikipedia folder, is this normal?
How does the Dreamcatcher determine when folders get created ? Based on reception of specific files?

All appears correct based on your description. You have a good signal.

Give it a day or so to get more files which will eventually populate like this -

When News gets articles they’ll be filed by day like this in the daily folders within News - Ken


Patience is not one of my virtues, thank you!

Nor mine - - but I’ve stuck with Othernet for many years :heart_eyes: Ken

1 Like

You can look at my terminal at which I have port forwarded. Ken

I actually did find that and checked it out, mine was so different I thought something was wrong as I don’t understand the process yet. Today mine has been running for roughly 18hrs and I have one Wikipedia entry in the Files/wikipedia …one entry in the Files/opaq…a lot of files in the Files/tmp folder and one file in the Files/log folder.

I am assuming that the data comes in as chunked files that are held in the tmp folder until all of the chunks are present and the Dreamcatcher software re-assembles those chunked files into the original file and then places it in the appropriate folder, if the folder does not exist, the folder is created?

Typically the process takes more than 24hrs of download before there is enough data to begin assembling the tmp files into the original files?

Ok so after 40+ hours my folders where still wrong and not adding the news or other folders. I formatted another SD Card on my Win10 machine and stuck it in there and now it finally seems to be behaving.

I’m going out on a limb and saying I think the culprit is the Dreamcatcher onboard SD Card Format is not good. I did 3 different cards and formats using that on board format function (after formatting via windows) and each time I ended up with a lot of tmp files and very little else.

This time I did not use that onboard SD Format and everything seems to be performing as expected.

Ok so something I am not understanding, in your terminal I see it is currently downloading but your newest news folders are from 06/21 but not current like yesterday or today?
I also see in your message folder that messages are older too.

Does the data get transmitted multiple times per day? Does the data change daily ? If it changes daily why is your station so far behind (date wise) ?

I’m also seeing my system downloading “message/” files but no message folder is getting generated.
Is it possible that the automatic restart every 3600 seconds is breaking that download so the file never completes and no folder gets created?


@Daniac Have you tried using the message-broadcast feature on the forum?

I tried the message-broadcast feature just now (was not aware and it is very cool) and the topic was closed a minute or two later. I saw the file start to download at 0.39%, then it quickly switched to a large opak/ download.(possibly a super fast download due to a very small file?) No messages folder was created in my Files area.

I did reformat yet another SD Card using only the Windows slow format. yesterday. I am now at 24hrs of run time and still do not have a full compliment of folders. How many hours should that take?

Sidenote, I did flash with the latest firmware when I received my board, if that makes a difference.


Okay, reformatted again, tried the message-broadcast again, I watch the file download, and no folder gets created.

Wikipedia items came in, folder was created without issue and the wikipedia items are there.

Do I need to flash the firmware again?

So this morning it looks like your SD card is missing ? The Dashboard shows no SD Card and Files shows a couple files and an Examples folder.

For troubleshooting purposes, could you please try uploading another message?

Done at 10:02 EST

Did you receive the message on your Dreamcatcher?

No it did not arrive, but I also was not watching to see if it downloaded, however normally I do see the file in the progress window, it downloads but never gets put in the messages folder. My current SD card has a manually created messages folder as I could not get the DC to create a folder based on received message files.
I saw the same thing happening on kenbarbi’s DC, I watched it download on the Dashboard, but it did not arrive in his messages folder.

Would you like me to try again?

Yes, please.

Ok I did send a message, right now the DC is currently downloading a big opak file, I will watch as it switches when that file completes and grab a snapshot of the download.

Now it appears that the messages are no longer being injected into the download stream, now I am only getting one news story after another even though I have added a few messages.

Ok here is a message coming in but never gets placed in a folder :