L-Band DIY Tuner Kit configeration issues


#1

Hi Outernet, I have received my Outernet DIY L-Band Tuner kit. ( Antenna, Filter/ LNA, E4000 RTL, $9 CHIP Computer)

I am having some issues getting it all to work.

Is there a guide for setting the DIY kit?

What are the Inmarsat frequencies?

Are all 3 Inmarsat Satellites transmitting?

How do I flash the Outernet image onto the raspberry PI 2 or CHIP computer. Is there a guide?

I am trying to use the L-Band arm Linux software decoder, but I am unable to set the Symbol Rate on the E4000? Any advice?

I am happy with the equipment and look forward to getting it receiving.


#2

So you finally got your stuff. Great. So we don’t have a guide yet, but if you can flash a CHIP, then you can flash our firmware.

First of all, here is the list of all our channels an the locations of the satellites.

And this is a guide to flash CHIP.

The firmware image for rxOS is located here. FYI, it is still alpha-software.

@branko Am I forgetting anything?


#3

Thanks Syed.

I have downloaded CHIP flashing file and extracted the file to the following directory rxos-chip-flash-v2.0a1-201608151712+f270bd0.

I have then installed chromium into Ubuntu 16.06.

I have started Ubuntu Chrome browser and gone to http://flash.getchip.com/

It then asked me to install a plug in.

It then said I have to do the about 5 lines of specific Ubuntu terminal Commands.

I then re logged into Ubuntu and started Chrome.

It now gives me the Option to flash my CHIP from a file.

I click this option and it asks me to pick a file.

So I click on the directory with the downloaded CHIP flash stuff.
I then have to click on show all.

I am not sure what file to pick to start the flashing?


Pic attached.

Then if I just pick a file and click start it just sits there and says waiting?
Pic attached.


#4

I rebooted in windows and installed the chrome browser for windows. I then installed the CHIP Flash app. I then connected the CHIP and tried to flash the CHIP Outernet software BUT it could not find a .chp file.

Am I missing something?


#5

Yes, you are missing something. The link Syed indicated as the guide is actually a description on how to set up the development environment.

You install dependencies as described on that link. When complete there is a script in the zip file that uses the utilities installed during dependency setup.

Lines 30 onward of the README.txt file in the zip file should have sufficient information to install the image provided by the zip file.


#6

Alternatively, this will tell you more about rxOS on Pi.


#7

Ben as all CHIP computers are identical could you not just send me the Image that the zip file creates and save me the pain of having to set up the development environment.

I have limited internet here in a remote part of the Philippines. Just downloading small files can take for ever.


#8

Here is the latest rxOS image for Raspberry Pi

Here is the latest image for CHIP

Both images are current as of today. They are both around 100MB in size.


#9

I downloaded it and it is the same thing. No flashable .chp file.

Do you not have a .chp file you can just send.

Right now setting up a Ubuntu development environment and all the things required in a remote country with very poor internet is a big thing when all I want to do is put a 120 mb flash image on a internal memory of a CHIP computer.


#10

Sorry about that, @syed posted an outdated documentation link. .chp files are undocumented, and we haven’t had the chance to reverse engineer and create them yet. For now, we’ll have to do things the hard way and do it manually. Please refer to this guide and use this image.

EDIT: Updated image link


#11

Thanks Branko.

I will follow the guide.


#12

Ok my good friend Larry followed the CHIP / Outernet Flash guide and we have the CHIP Flashed.
The CHIP Successfully turns on and I can connect Via the WiFI Hotspot no problem.

But appears to run out of power and shuts down after about 10 seconds when I connect the E4000 Dongle.

Any Ideas.


#13

Powered Hub solved Turning off problem.

Now I have aimed roughly east, as I assume Inmarsat is over New Guinea.

No signal coming down…


#14

Do you have the antenna more or less pointed straight up and east-ish? Is the on the amplifier on?

Carl from rtl-sdr.com just confirmed reception and file delivery from New Zealand (a few hours ago).

Can you manually enter the value under Satellite? Use the custom-settings. After that, please try restarting.


#15

I still can not get it to connect to the satellite. Everything else seems fine.

What frequency was he receiving on?

I have attached a screen shot from GQRX showing the 1545.525 spectrum. I can see other signals but nothing at the 1545.525 frequency.


#16

Sorry. Extreme apologies. I had incorrectly stated the wrong frequency on the wiki. 144E should be 1545.9525 MHz


#17

Any luck now?


#18

Signal state 4. In Philippines. WOOOOOOOOO. Great.


#19

First Outernet File coming down. Amazing!!!


#20

Email me with any file you would like broadcast. You’ve earned it :smile_cat:

Preferably a file less than 100kB in size. We’re broadcasting at just under 1MB per hour.