ORxPi v0.2.8 Testing and Issues


#1

I could not use the hot fix as I had issues writing to my SD card and adding the ORxPi file from the hotfix archive. My issue with creating and modifying the SD card on the MAC.

No matter - I created a new ORxPi v0.2.8 SD card and fired it up and it worked great. Got the satellite pointed and started downloading files.

After about 1 GB of library size, the system was performing better than before, but I wanted to get the library up to 3G size to see if some of the speed of navigating between screens had been sorted out.

In the middle of all this, the satellite strength and file download progress screen has frozen. I had a wind storm and in the middle of downloading files, the antenna moved. It seems like the screen holds the last signal strength and quality data (in my case, signal=61, Quality = .24). The issue is that screen is now frozen and I cannot use it to re-point the antenna. No matter where the antenna is pointed (or even if I have the cable connect to the HDStar), the Signal remains at 61, Quality at .24.

I presume the process that reads the signal data from the HDStar has stopped, and needs to be restarted. I rebooted the Pi a couple of times (hopeing that this process would recover) and pulled the plug on the HDStar as well, but no luck.

Is there any troubleshooting you would like me to do, or any files you need to see to track this down.

I believe that this occurred under 0.2.7 as well, and I ignored the issue as 0.2.8 was just around the corner.

Just to re-cap, it looks like the Tuner Settings screen freezes after the antenna is off satellite for a bit, while downloads are in progress. (I had 4 files showing in various states of downloads.)

I will leave the system in the state in case you need me to collect some info.

Cheers,
Brian


#2

Hi Brian - - as I recall you are in Western Canada looking at Galaxy 19.

You’ve probably followed some of my posts using Branko’s new v 0.2.7 and v 0.2.8. Quick summary, v 0.2.7 never started in my Pi, but v 0.2.8 did start, but the ONDD module failed to load, and I never got any signal from Galaxy 19 received by the Librarian. So I’m dead in the water to start.

You are more fortunate in that your system worked fine on v 0.2.8, but locked up after you lost signal from Galaxy 19. Branko will probably put your problem on his plate with my problem. I still can’t understand how my old v 0.2.4 works with my gear, but v 0.2.8 doesn’t. I’m using a Pi B+ V 1.2 and a Geniatech receiver powered bya hub and connected at the base of my antenna to a linear LNB on my Quad LNB - - then WiFi to get the data into the house.

Any way, I think your problem will require re-aiming your antenna with an FTA receiver so you can see the signal strengths as you look at video feeds, then reconnecting your Outernet setup. Hopefully it will restart when it acquires signal. Ken in Annapolis, MD


#3

Thanks for the reply.

I am not too worried about re-pointing the antenna - have done it a bunch of times already.

I think I am going to leave my system in its current failed state - better chance at getting some logs and doing some troubleshooting that way. I always get frustrated when a problem comes up and it seems to be fixed when a ‘reboot’ is done. Then, all the data that could help locate the issue is gone.

I am more interested in helping locate and fix the bug.

All that being said - I DID power cycle the Pi and power cycle the sat receiver … against what I just said above ;-(

The good news is that is it still hung up and hopefully we can see what is going on once I get some guidance as to what Branko wants me to do.

Cheers,
Brian


#4

Brian, after I responded to you, I checked my 2 sat receivers (Geniatech and PCTV) with a video input direct to a Windows computer using a standard FTA program as I have done before.

Both failed to see video signals as I thought they would. I’ve asked Branko about the Pi’s boot up not seeing the ONDD with bad receivers connected, so we’lll see what he says.

In any case, I’m planning on ordering a new Geniatech. Ken


#5

The process in charge of managing the download does sometimes report stale values when the tuner is misbehaving or coax is suddenly unplugged, though it sounds very odd that it would do that after a reboot.

Are you able to download the system logs from the settings panel (under Application logs)? It would be worthwhile to download that first before doing anything.

What LNB type are you using?


#6

I received the new Geniatech reciver from the Outernet store and installed it with a newly burned 8 GB sd chip with ORxPi v0.2.8 image. My system has been receiving data constantly for 48 hours, but so far all I’m getting from your transponder is MP3 song tracks from Gasper Nali, Lilly Bander, and Lucius Bander.

My apps file has been showing some really strange entries. I’ll send the whole file to Branko by e mail, but here’s a sample of four entries:

[2015-09-28 11:15:21 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>5018<carousel_id>4</carousel_id>files/Lake of Stars/Gasper Nali/Track 2.mp39fc1803e439f41feecd70309dabefa24b9b97100f7c48d3c010aa41784626018<block_count>4350</block_count><block_received>3369</block_received>yes
[2015-09-28 11:15:22 (+0000)] INFO Found 0 updates
[2015-09-28 11:15:26 (+0000)] DEBUG No captive portal match for librarian.outernet
[2015-09-28 11:15:26 (+0000)] DEBUG ONDD: sending payload:

I used to get hundreds of files in a day, and would get the Twitter app download, but now all I see is music. Is that all your now sending? Ken


#7

As an update - - all day I kept receiving over and over the Gasper Nali MP3 song tracks from Galaxy 19 on my receiver. I decided to re-burn the SD chip with ORxPi v 0.2.8 and reinitialize my system. After the Raspberry Pi reboot, I received no signals from Galaxy 19, but did note in the Librarian post:

the frequency was being set to 1179 rather than the prescribed 11,929. The satellite setup for Galaxy 19 shows 11,929 if you click on the Custom button. I don’t know if you should see that number in the Librarian setup. Ken


#8

Hey Ken, you’re receiving fine. We’ve changed the stream a bit to include those songs for a Malawi festival test. It’ll be back to normal in a day or two. The way downloads display is a bit buggy. It keeps showing the same files even if they’re already downloaded. That will be hopefully fixed in the next release.


#9

The music content downloads fine. Interesting approach. I’ve played it and it’s just like a CD. Good work - - I’m ready for the next update. Ken


#10

Looks like there was an issue with the stream. Should be fixed now.


#11

The downloads on Galaxy 19 are restored. Since I burned a new v0.2.8 sd chip, I have received all your Twitter Applications, SSH-Clients, new articles, Tweets, and 17 Lake of Stars mp3 tracks.

Some of the tweets download twice - not all of them - specifically in some of the UNICEF Twitter areas.

In addition to new content, I am still receiving a constant flow of Lake of Stars tracks which I have already received. I’m sure they not affecting my system, but it would seem to me a waste of downlink bandwidth unless you have a purpose for that. I can see how continuous broadcast of OUTERNET_RX_1.4.000.PKG makes sense if that’s your apps package all new receivers would need to download. Ken


#12

Some of the unicef tweets are available both for the general Twitter app as well as UNICEF-specific version of the app.

It’s like a tape on a loop. You receive what’s playing right now whether you need it or not. Since the teleport cannot know what you have and what you don’t, it just blasts everyone with everything all the time. Advantage is that, if someone was not tuned in while something was beng beamed down, they just have to wait for it to come around again.


#13

Just one more question - - I installed an external hard drive on my hub in accordance with posted instructions changing its name to EXT_STORE expecting my SD chip saved Updates would transfer and they did not. I did power down to install the hard drive then came back up again. The hard drive does not appear to be working.

I SSH the Pi and found the following:

Device 007 is the hard drive, but I don’t see any modules associated with it. Have I missed something in my set up? Ken


#14

Tell me what this command gives you right after plug in the hard drive:

dmesg | grep sda

#15

Here’s the SSH after I connected the hard disk - -

Device 007 is the hard disk. Ken


#16

How is your drive formatted? I see some fairly non-standard partition layout.


#17

My hard drive is 160 GB formated as NTFS on my Windows machine. Ken


#18

I think we added NTFS drivers but it turned out it didn’t quite work. I would have to check again. Meanwhile, you could try and download Gparted Live CD/USB, and format the drive as FAT32 (for some reason Windows imposes a limit on how big a FAT32-formatted volume can be, while Linux doesn’t have this limitation).

I’m working on something else right now, so I can’t jump on the code immediately and troubleshoot that, sorry. When I have some more time, I’ll look into NTFS support again and see if we can patch something for your particular setup.


#19

OK - - I’ll get the program and format the drive as FAT32. My exisiting Windows programs only give me the NTFS and exFAT (I know exFAT won’t work).

I’ll report back later. Thanks, Ken


#20

Ok, let me know if you run into any issues.