Skylark 1.2 feedback


#62

The update link is at the top of the thread.


#63

So far the mobile experience is good for me. I am using a Lumia 735 (4.7 inch screen). The only complaint I have is the top of the menu in the weather app gets cut off so the only time I can tell what day I am on is during the few seconds it is loading. But it is still usable.

The Auto cleanup feature works now. I uploaded my entire backup to CHIP last night. When I woke up today all the old news etc. were removed.

I haven’t used the guest login much so I don’t have much to comment on.


#64

I found a bug in the News app when I’m opening it as guest:

ApplicationNewsWindow.prototype.init/populate/<@http://10.0.0.11/packages/default/News/combined.js:109:56
VFS.scandir/<@http://10.0.0.11/osjs.js:11734:14
[email protected]http://10.0.0.11/osjs.js:11564:7
vfsRequestCallback/</<@http://10.0.0.11/osjs.js:11545:15
[email protected]http://10.0.0.11/osjs.js:11260:5
vfsRequestCallback/<@http://10.0.0.11/osjs.js:11539:11
Transport.scandir/<@http://10.0.0.11/osjs.js:12422:9
internalRequest/<@http://10.0.0.11/osjs.js:12346:7
_apiCall/<@http://10.0.0.11/osjs.js:2262:7
HandlerConnection.prototype.callXHR/<[email protected]http://10.0.0.11/osjs.js:11005:9
[email protected]http://10.0.0.11/osjs.js:1681:11


#65

Still waiting on some direction on which way to go with this.

CHIP boots, starts WiFi, No DHCP, can connect with manual IP, no Skylark. Is this a re-Flash or do I sit this one out and wait til the bugs are worked out?


#66

You could re flash. What are you out? It doesn’t seem like you can access logs or anything like that.


#67

And so I flash it, then it does the same thing, then I flash it, and it does the same thing?


#68

v1 is better than a non functional receiver. The first time I tried the update I had the same issued you have. But after the reflash the update worked but then broke when I clicked apply and reboot in network settings.


#69

Back from a weeks trip and had the same issue after leaving it running (no WIFI connection though it had reverted back to the outernet hotspot and no LNA) …I’m afraid I didn’t follow @kf4hzu s request as I didn’t read ahead. @nell s worked great and it’s reconnected back to my network without changing anything else. Looks like the OTA worked and I have feeds since doing the reboot.

BTW I’m powering using an ANKER 24W USB charger/supply and Anker Powerline cable after fighting with all my other PSU and cables for fulltime mains power. Ferrite choke on next to the Micro USB. Probably going to add LIPO in the next week or so prior to an attempt at a semi permanent outdoor mount as I still seem to need to manually power up in the event of power loss. Dave WJ1I


#70

@pe1chl, you talk about using a “TTL to RS232 gadget”.
But I don’t have a TTL to RS232 converter …
With only my linux computer, the CHIP card and a micro USB connector can I achieve what you suggest or is a reflash my only option.

Thanks
Gary

ps Sorry guys, but seems to me that this OTA update was far from ready.


#71

In the world of small and embedded computers, you can get two kinds of devices:

With one of these, you can access your CHIP or other devices with a serial terminal program.
(e.g. minicom on Linux)


#72

Gary,

For what amounts to a 1 man development team, with requests to add guest access and add portable browser features, a sudden bug mess with ports hanging open, and chasing all the issues we posted about 1.2 bugs I am amazed that the first mass flash software upgrade has gone this well. The OTA upgrade as you say could have been tested further, by holding off all those issues I listed before for a couple weeks on the update.

I don’t know, has anyone besides myself checked out the buildroot for Skylark and built it themselves from source? Or even have the ability to flash any version of Skylark at will? If we had 4-5 testers that could flash to any version or configuration then maybe we could work out how to do better pre-deployment testing.

If you have a linux box already set up you just need to use apt to get a couple of packages and you would be ready.

@Abhishek would this help you at all? If not I’ll just drop it.

-C


#73

Don’t get me wrong, I am not detracting from their achievements but at the same time they should welcome constructive feedback particularly when things go wrong.

If the ota update was failing on user modified systems or corner cases then I’d say fair enough but I specifically left my unit in the default state after the flash to Skylark - as appears have many others who reported problems.

There are enough of us willing to test and it would probably have been a far more efficient process to have offered the “ota” to a few people to apply manually - particularly because their resources are limited. That way issues would have been uncovered in a controlled fashion …

The effort that they will have to go to now is way less efficient - it’s a broad front firefighting exercise as opposed to dealing with only corner case exceptions.


#74

Of course to test the OTA update you would not need a development environment, they would just
have to send the candidate file or the URL of the file to a couple of beta-testers. I did my update not over the
air but by downloading it from internet and uploading to the opaks directory, and it went wrong the same
way as for all the others that reported a problem.


#75

Gary,
Yes, I agree, and i disagree! and I agree with @CRCasey too.
the actuality OTA update DID work (with what seems to be one “Critical” bug), and the new skylark version was loaded, which actually works amazingly well for what was changed!

Looking at this pragmatically, the single bug is one that stopped the network connections after the patch was applied… Admittedly this is a “show stopper” bug for a production system, but just imagine how much we have all learned to help support @Abhishek - the one man dev team :wink:

Possibly in the future he could put a link to the file in the forums here and ask for guinea pigs to run it, before putting it on the satellite ( again something that was successfully tested during the current “fun”! As @pe1chl & I know. ) - I know I would grab it and if it kills the system, well c’est la Vie , lessons learnt !

I only wish I had more time to devote to this fascinating project :frowning:

All in all whilst it may have been a negative “user” experience, it was a successful trial of the OTA update technology!!


#76

@neil,

I don’t believe that the OTA can be considered to have worked at all, and there is more than a “single bug”. You describe a dhcp server issue whereas my hotspot won’t even authenticate clients. I also have a LNA without power. That is at least 3 bugs.

I haven’t learned anything from this experience (yet). And I am looking at this pragmatically - had they taken the approach to distribute the OTA update to a number of volunteers (which is all that I was suggesting) for a manual application they would have uncovered a number of issues without dare I say the embarrassment of a flop. The stress on the one man development team resources would have been reduced.

Update: I take back part of my post above. The wifi authentication problem seems to be the old problem of range. My recent use of the system just prior to the ota update was at a range of about 5 meters, now I have to sit within 2 meters of the CHIP again. Not sure whether this is anything to do with the OTA.

Now applying a fixed IP address allows me to connect to the unit.


#77

Exactly, and once the majority of testers with possibly different user configurations reported the all clear then a “live” OTA update would have been far more likely to succeed. As it is now, they have to sift through various reports from users with varying degrees of customization/configuration and collate information in a completely uncontrolled environment.


#78

@CRCasey,

I agree that the flash upgrade was quite slick - congrats to Abhishek.

You are suggesting that they involve/rely on volunteers for pre-deployment testing - seems logical to me but will require a bit of thought and focus by the developers. Time and effort now that will save them heaps of time later.

I’m not so sure that having a number of users build from source is a good idea - that would likely introduce it’s own set of variables, problems and distractions. I’d say that the developers should build and package within their “controlled” environment and deploy to volunteers for testing.


#79

Flashed back to v1, logged on over WiFi, uploaded v1.2 to opaks, let it work, Waited til Outernet SSID appeared again, no DHCP, made PC manual IP, logged on Guest, then out and back as Outernet, changed Network settings country to US, applied, waited for Outernet SSID to reappear, changed PC nic back to DHCP, logged on, seems to be working.


#80

Flashed back to v1, logged on over WiFi, uploaded v1.2 to opaks, let it work… And now it is possible to set The country settings and to set my wifi settings. And i have The impression that my wifi signal is stronger. (Is this possible by only changing The country settings???) Good job!


#81

I’ve been busy the last few days, so just got a chance to attempt to fix things. Per Neil’s directions, I used the manual ip setup to access the outernet hot spot, selected network, made sure connect to wifi router was selected, using same old settings which were still there, clicked Apply and Reboot. All appears back to normal now. This is with the newer chip.