Dreamcatcher $99

Easy might be a relative term. Have you flashed any microcontrollers before?
Do you have a USB-A/C data cable?

Yes, I have a Type C cable to my computer. Yes, I have flashed ESP32 and if that’s the way I need to go I will figure it out. I was just hoping for a pushbutton factory reset. I am windows based but I can fire a linux box if the GitHub page is what I should follow.

Here, correct?

That link describes the hard way to flash the ESP32. Here’s the easier way:

Download these three files.

Go to this online flashing site.

Connect the USB-C cable to the Dreamcatcher, but not to the PC.
On the Dreamcatcher, hold down the button next to the USB-A port. The button is labeled as PB1. While holding the button down, connect the USB cable to the PC.

Under the PROGRAM heading, click Connect. Then click the dialog box that lets you connect over COMxx.

You should see some output in the virtual console which describes the ESP32. You’ll also see the option to add a file.

Click the add file button twice because you need to upload three files. The order of adding the files and changing the corresponding flash address. Then click Program.

It only takes ten seconds to flash the ESP32. Then just power cycle and you’re all set.

It almost worked. Here’s what I got: Now both lights are stuck on.

esptool.js v0.1-dev
Serial port WebSerial VendorID 0x303a ProductID 0x1001
Detecting chip type… ESP32-S3
Chip is ESP32-S3
Features: Wi-Fi,BLE
Crystal is 40MHz
MAC: f4:12:fa:dc:73:70
Uploading stub…
Running stub…
Stub running…
Changing baudrate to 921600
Compressed 145648 bytes to 26384…
Writing at 0x0… (50%)
Writing at 0x4000… (100%)
Wrote 145648 bytes (26384 compressed) at 0x0 in 1.077 seconds.
Hash of data verified.
Compressed 145914 bytes to 26385…
Writing at 0x8000… (50%)
Writing at 0xc000… (100%)
Wrote 145914 bytes (26385 compressed) at 0x8000 in 1.484 seconds.
File md5: 3d772ad6bb3960a5dd128ec4b24725e3
Flash md5: b22c9e14c79decd81bc351861c3a071e
Error: MD5 of file does not match data in flash!

I tried it again. Bootloader and partition load OK, but it gacks on dreamcatcher.bin.

Wrote 145850 bytes (26437 compressed) at 0x10000 in 1.013 seconds.
File md5: fc8bcab8ea86c3216bc82e4ad4544376
Flash md5: 0af43cd27fc9fe7a45d60a5dca1ce72d
Error: MD5 of file does not match data in flash!

Somehow I had a bad/wrong version of the .bin Back to reset now. Thanks!

Glad it worked out. Thanks for following up here.

Got it to work! (to some extent). What I did:

  1. connect Dreamcatcher (hardware 2022.10, software 1.0.0-rc) to the green port of Bullseye LNB (now shows “LNB connected: YES” in the interface).
  2. in Europe: change frequency to Astra 3B beam (11 682 300 000 carrier - LO freq (9750 MHz) = 1 932 300 000 Hz).
  3. use dishpointer.com to find proper azimuth (I got it completely wrong the first time somehow - either smartphone compass was way off or aiming at the old satellite).
    Just “aim between those two houses about 35 degrees up” worked well.
    Started seeing SNR on the order of -15 to -11 and “packets received” was counting, little CRC errors. No files received though.
  4. put a micro SD card in. Only then did it start receiving files. (“File info” box showing name and progress, CPU usage went above 3%). SNR was about -11.

Files seen as hashes under “Files” tab (hashes instead of filenames, 404 on clicking on them, looks same as iw0hjz’s comment above).
Tried bzip2 -d on the files and getting bzip2: Data integrity error when decompressing.
I’ll just let it fish for longer and see if anything unpacks.

Are you not able to view any content? I just pulled this off of my receiver:

Nah, my Files tab looks like this.

Got 350 files (and counting) in tmp folder:

I took out the microSD card and tried file and then bzip2 on a linux laptop, it says the files are broken.

user:/media/user/0021-0000/tmp$ bzip2 -t *

bzip2: e23b142f7fb621490be44bcdac6acb6e9601fb7618b2d3caa228328611210781: data integrity (CRC) error in data
bzip2: e25b768ad57367675fbae60d7871d4e3f65c57dc31f7515d1785edbf45331d46: bad magic number (file not created by bzip2)

Clicking “Format SD card” had no effect.
Can I debug with a serial cable, or is there any debug over network?

Do you have another SD card? If so, could you please shut it down, insert the card, and then boot?

Got something working! News folder appeared and there are a couple of files. (Still some files seemingly stuck in tmp).
The one with a name in Arabic doesn’t open (“Filename too long”), but files in English work!

URL that produces “Filename too long” isعربي21.زلزال%20تركيا%20يحدث%20حفرة%20بطول%20300%20متر%20في%20ولاية%20هاتاي%20(شاهد).html

I figured that URLs shorter than 268 bytes produce http 404, while longer ones return error 500 with “Filename too long” in the body.

Did you change anything?

I’ve put in an old 1Gb microSD card (last formatted in ~2008). I’ll check with 32Gb card again, maybe it was a coincidence, as files still pile up in tmp.

Are you rebooting after you change cards?

Yes, I unplug the board before removing/inserting cards.

Do my receiver settings look right? (I’m in Europe, using Bullseye LNB).

Yes, that looks fine. What is your current SNR and how many CRC failures do you get?

SNR around -11, few CRC and header errors.
I’ve gotten 15 news html files overnight (all smaller than 7kbytes) and about 130 new files in tmp (some as big as 300k). Is it working as intended for now? Do grib files stay in tmp for now?

@alexus Could you please confirm that your ESP32 module has a laser etched “N16R8” on it? There is not yet a viewer for the grib files, so them being stuck in tmp is normal.

@BillMc Are you downloading files and opening them without any issue?

@mallikdev @iw0hjz @6lat2012 @tylerhoot Any issues downloading and opening?

Yes, it has M0N16R8 at the bottom.